Output Latency - New Cubase installation / UR22 mkII interface

Hello Everyone,

I have just installed Cubase Artist 9 and with it came a new Steinberg UR22 mkII interface with drivers.
The computer has a large SSD and 20GB of RAM, with USB 2 ports.
The Midi signal happens on the screen immediately when I strike the keyboard, but sound coming out takes a lot longer.
I have had a quick search of menus and googled various things, but nothing came up, so I’m trying the forum.
The interface is made for USB 2 and I know the computer should handle this setup, so presumably it must be either a Windows setting, a Cubase setting or a UR22 mkII setting.

It might be worth noting that I prefer Windows 7 so I am using that - a fresh installation.
When I first tried to start Cubase there was a problem with integrated graphics, so I added a graphics card, now it opens and runs.
The only problem is the latency.
Does Cubase Artist 9 run OK on Windows 7?

Any ideas gratefully received.
Thanks,
Justin

And what MIDI Device are you triggering’? Do not use MS Wavetable synth, but a VSTI instead.

Check UR22’s ‘Buffer Size’ setting from Cubase menu:
Devices -> Device Setup … -> VST Audio System / Yamaha Steinberg USB ASIO -> Control Panel

Thanks, a long time in replying but I have only just continued with this, and Jarno’s option has worked.
It was set to 19ms (512 samples) and I have reduced it to 9ms (192 samples). Thank you Jarno.