Overflowing Bars in Percussion Staves

How can I remove the overflowing bars in the 2nd staves? Thanks :slight_smile:

Layout Optionsā€”Vertical Spacingā€”Hide Empty Staves.

Engraving Options > Barlines > Minimal Barline protrusion (or similar)

Whoopsā€¦ I think I misread the request.