oxygen61 revisited

I know there are countless posts about the controls on the M-Audio Oxygen61 sliders and transport controls and Cubase / Cubase Artist 7 but I really am a newbie to this aspect of music production. Is there anybody who could please explain or send me to a link to explain how I map the faders of the controller (C1 - C9) to the channels of the Cubase mixer console?
Many thanks in anticipation,
Dale

Hello,

You can assign any specific HW slider to the specific Cubase fader.

  1. Open Devices > Device Setup.
  2. On the left side, check there is Generic Remote device under the Remote Device folder. If not, click to the + button on top, and add one.
  3. Click on the Generic Remote.
  4. On the right side, there are two sheets. The upper one says WHICH hardware cotrnoller (slider/knob, button…) will control somthings. The bottom sheet says, WHAT parameter will be controlled by the hardware controller.
  5. Set the MIDI Input – select your MIDI device.
  6. Click to the Fader 1 line in the upper sheet.
  7. Click on the Lear checkbox on the right side of the window.
  8. Move the slider, you want to assign.
  9. On the bottom sheet, find Fader 1 (first line). Now, you have to set, what will be controlled. Click to the column, and select, what you want. For example:
  • Device: Mixer
  • Channel/Category: Select the channel, you want to control, lets say: Audio 01
  • Value/Action: Volume.

That’s it for the first slider. Continue with other faders exactly the same way. Choose Fader 2 line in the upper sheet, etc.

As you notice, you can set “Selected” channel in the Channel/Category columne. Of course, you can control Pan, or Solo/Mute/Arm buttons, Insert effects, Sends, etc.

At the moment, I’m working on the software, which convert any MIDI device to the Mackie Control. With this, you will not be limited by using 8 faders for 8 channels only. You will be able to control channels 1-8, press Bank Right button, and control channels 9-16, etc. Same as you can do this on Mackie Control device. I hope, I will be able to release this as soon as possible.

You can do all the above mentioned OR just set your Oxygen61 to preset 10. After you that your faders will come to life. :slight_smile:

Hi,
Thanks for the replies. I began with trying to use the Oxygen on preset 10 but although I see midi activity on the Oxygen display and see the Cubase transport show midi data activity, the faders do not move. I notice that under Device setup, both in and out on the Oxygen are inactive and I cannot seem to set them active. Could this be a problem?
I’ve tried to add a screenshot to show what I see:
I appreciate the help so far and would be grateful of any other suggestions. In the absence of shortcuts, I’ll work through Martin.Jirsak’s (kind) suggestions.
Thanks for taking the time to help,
Dale

Try these settings:

In device setup under M-Audio Oxygen select “all midi inputs” for the MIDI input area and then choose “Not connected” for the MIDI output. See attached image.

Then on the Oxygen keyboard I selected preset 10. Now I got both piano keys and controller faders/knobs working.

Tip: in order for Cubase’s mixer to “catch” the slider input from the controller you have to first move your chosen fader all the way to the top.
oxygen49_inline.PNG

Hi Mark,
Thanks for taking the time to reply further. Attached is what I see but despite taking the faders up to full and back down on the Oxygen61, the Cubase faders refuse to budge. I have also tried it with the midi output connected to the Oxygen and reset the Oxygen to factory default as it was a display model.
Thanks,
Dale

Hi,

In my own opinion, the bottom sheet is wrong. You selected VST Mixer > Drone 1 (which is the name of the track, I suppose). And the last value is 1025, what is strange. Click on this, and choose Volume here.

Thanks again Martin,
I’ve followed your suggestion about selecting Volume (see screenshot)
but it doesn’t make any difference. The settings were as the Oxygen / Cubase set them.
Thanks for trying to help though. It is much appreciated,
Dale

I’m afraid, the Learn function doesn’t work in this window of Cubase very well. It doesn’t work very often to me. And it looks strange to me, I don’t believe, Oxygen 61 sends CC7 on the channel 1, CC7 on the channel 2, CC7 on the channel 3, etc.

So I’m afraid, you will need to find the proper MIDI CC number manually. THere are two ways. You are on Mac, sou I would recommend to download MIDI Monitor freeware. Run it, move the 1st fader, and find, what controller does it send. Set this value on the 1st line of upper line of the sheet. Next, move the 2nd fader, find the value in the MIDI Monitor, and set this in the 2nd line of the upper sheet, etc. I think, all of these MIDI CCs will be sent on 1st MIDI channel, so be careful with this, and set this correctly.

Or, if you don’t want to download the MIDI Monitor application, you can create MIDI track, and record movement of all faders into Cubase. Then, you can find, what MIDI CCs are sent by these faders, and set it manually in the upper sheet of Generic Device again.

Hi again Martin,
Thanks for the suggestion. I’ve downloaded Midi Monitor and will try to figure out ‘what is what on’ the weekend. Had a disappointing response from M-Audio’s support with regard to mapping the faders to Cubase mixer channels but I’m sure I’ll get there eventually.
Thanks for the help,
Dale

I’ll load mine up when I get home and see if I can export my XML for you.

Thank you Mark,

I’ve followed Martin’s suggestion and downloaded midi monitor and checked through the signals my Oxygen61 is putting out - they are a strange muddled up bunch. Only fader C7 is putting out a channel volume message if Midi Monitor is correct. C1 is mod wheel (fine), C2 is breath control. I’m well confused!
As always, I’m glad of the help I’m getting on the forum.
Cheers,

Dale