Ozone 5 plugin incompatibility

Now I do too… :smiley:

I guess you can’t assume that Wavelab will install at 64-bit just yet. I should have double checked this option when I setup the new computer.

FYI, I am in touch with Izotope. We’ll see.

Thanks PG. Please let us know what you guys determine as soon as you know, and what can be done for a fix. I hate to think of all the projects I’ve rendered in the last few years that didn’t get all of Ozone 5 settings applied.

This sounds like a similar issue as Klanghelm and Slate Digital are having. Especially since this seems to be in the VST3 version.

See here:
http://www.steinberg.net/forums/viewtopic.php?f=189&t=48712


If Izotope is also in the same boat… then it’s the fifth developer I heard off, where VST3 versions don’t work properly in WL, but fine in other hosts.

I am also hoping for a fix - since all developers could benefit from that.

I’ve spent a little time testing this, making some pretty bizarre obvious settings in Ozone 5 and rendering and as far as I can tell, the renders sound just like it does in Wavelab running live. That’s not to say there isn’t an issue somewhere, I just wish it was easier to know or it was fixed in WL.

Basic null test seems to be all good, so that is encouraging.

OSX 10.9.2
WL 8.0.3

I’m using Ozone 5 on WL 8.03(32) WIN 8 (Inserted on Master Effects TAB - not master seccion)
I tried DRASTIC EQ settings, Absurd reverbs, enhancer, limiter, etc… and ALL render fine.

I have not tried on Master section. Was the above problem when inserted on Master section?
Will give it a try also on Mac when I have a little time.

I too am testing this on the new master effects tab tied to the montage, I haven’t tested on the global master section as I no longer use that for much of anything in the montage mode.

I’m hoping to have time to do more null tests next week to be sure I’m not experiencing the issues with my normal workflows.

My test was simple - Ozone 5 Adv. in a slot of Master section. 30 sec. short wave so I can eventually send it to OZ people as an example. Check attached pix above sent earlier by me. But I discovered this phenomenon using Ozone as a clip insert in montage pane.

By the way Ozone people noticed the problem so there must be a point. Things are equal for VST2 and VST3.

Thanks for PG for keeping contact with Izotope team on the matter. I believe it will help fix the problem since it is goal for both developers.

I’m working on PC, i7 Intel Sandy Bridge processor, 16 Gb Ram - if it makes any difference.

Izotope told me they found a problem and will fix it in their next version, concerning the plugin at the origin of this thread.

I have a similar issue with DMG Equilibrium. When inserted on a CLIP and bouncing in linear phase mode, it renders silence. When rendering in digilal+ mode it renders ok. When inserted in the Global Master SEC it renders ok in both modes.

I just did a quick test with Ozone 5 VST ///(Not the advanced version), tried with all of Ozone’s modules ON with extreme settings.
Both inserted in CLIP and the Global Master section (not the master TAB) and both render OK.

WIN8, WL8.03

Thank you Philippe for your effort and obviously - great news

My best … Vic

I think the reason for the issue is explained in the efforts of izotope to work at a level equal to Steinberg. They do not want there product to work inline with Steinberg but to compete with the audio quality of Steinberg products. Why is this guy using izotope with WaveLab anyway?

I noticed another problem: rendering a montage with multiple clips and associated clip based plug-ins, artifacts will occur near or after the clip boundaries after render when using plug-ins with high latency.
This includes:
UAD Precision Multiband
PSP Neon HR
IZotope 5 LP EQ and/or LP multi-band crossovers

I don’t have DMG Equilibrium yet; I have Algorithmix Red, but it does not work properly on my Win 7 64 bit platform in Wavelab 8.

The problem occurred at any buffer size my RME Multiface II was set at, and with the ‘Reset Plug-ins upon Playback - Render’ turned on or off in all combinations.
This problem is not consistent, as I had rendered the montage earlier with PSP Neon and had no problem.

I had this or a very similar problem with Ozone 5 right when WL8 came out, but I think PG fixed the problem as far as I can tell. For me, the problem was occurring when rending WAV files that have audio right to the very end and Ozone is applied to the master. I was getting a sort of stuttering effect, but if the song had a natural decay or dead air, the render was fine. This was with Ozone 5 on the montage master, but didn’t occur when it was on the global master. I haven’t tested on clips but I think that my issue was Wavelab couldn’t handle the large latency on the master, maybe it still needs to be adjusted for clips.

I rendered a session 2 days ago with high latency clip plugins with no problem; today, I had clicks after clip transitions & I didn’t change any settings… weird.
I remember problems with Ozone 3 or 4 and Wavelab 5 - the audio would be offset by the latency amount. Although this is not happening in W8, the new design seems to be causing a different problem - in lay terms, the clip processing is not intellegently handling the buffer size of high latency plugins, and the buffer is clearing when the next clip is processing, which causes pops and dropouts. I did not have this problem with Wavelab 6 and remember being relieved that it was solved. I even used multiple instances of Algorithmix Red in W6, which has a second & a half latency at Ultra setting, with no problem.
I have a SSD for my OS drive and don’t have room to install Wavelab 6, so I hope Steinberg figures this out. Otherwise, I may have do the heavy lifting in Studio One V2 and just assemble in W8. At least I will have automation and 64 bit processing thoughout. And the S1 V2 SRC has less aliasing and noise than Crystal.

Another Ozone 5 problem is the FFT in the EQ module: with VST3, any setting but real-time looks like infinite peak. This doesn’t happen with Ozone 5 VST2… most of the time…

This is unfortunate, maybe PG can weigh in on the latency issues specifically, such what is the max latency that can be handled by a clip, track, montage master, and global master section.

This thread has seemed to wander off-topic with respect to the OP’s situation! :wink:

If I understand PG correctly, he is suggesting that your plug-in settings need to be saved before “rendering”, otherwise WaveLab will have no way of knowing the changes you have made to a particular preset within the plug-in, due to the fact that “rendering” is an off-line process… and that Wavelab’s procedure is to open a “NEW” instance of the plug-in to process the file(s).

So, my question is:

Do I have to save all plug-in settings as a presets within each plug-in before “rendering” a file?

Al

No, that’s not quite correct. For rendering, the new instance of the plugin is told by Wavelab to copy the current settings of the original plugin - whether these are saved by the user is not relevant. This is where Ozone is lacking, since it holds some plugin settings in a place that is not according to the VST standard.

That is what I first thought, but:

I would like a little more clarification from PG as to how WaveLab works in this regard, because his answer may also change my workflow to include a workaround to safely insure all plug-ins are being rendered properly… even if they don’t completely comply with the spec!

Al

So regarding the saving before rendering with Ozone 5, do we need to just make sure to press save for the montage itself, or do we need to save a preset on Ozone 5 itself to lock it in before rendering?

I’m thinking just on the montage which I do anyway. I rarely leave too many unsaved moves, I think it’s a habit of learning to use a DAW on a bad PC in the early 2000’s, one hand always in the command+S position.