'p' for 'play from selection' is not consistent

It is my understanding that selecting a single note in a score and pressing ‘p’ will begin playback of the score (all staves) from that point – and this works most of the time – I’d say 70% of the time. 30% of the time, only the staff that contains the selected note will play. I can reproduce this behavior inside of ten seconds in any score I’ve created by clicking random notes and pressing ‘p’ until it happens. I’m using NotePerformer exclusively, so I haven’t experimented with any other playback template. This behavior has been omni-present since I’ve been a Dorico user – (December '18). It happens in every score regardless of size, density, or content. The behavior can pop-up as soon as two staves contain notes.

I’ve tried to determine if any unique note qualities trigger this behavior, but I’ve found none. It can strike anywhere - and often, stopping with the space bar and pressing ‘p’ again immediately corrects the playback issue. Sometimes not, and in this case another note must be selected before I can hear the full score. I can say with confidence however that this behavior has never happened if I select a ‘whole rest’ and press ‘p’. With a whole-rest selected, I will always hear playback of the entire score, this in now my workaround, still a whole rest may not be readily ‘clickable’ in the section where I’m working.

I’ve searched this list for other users experiencing this affliction and it appears I may be the only one. I suspect this might be a NotePerformer issue. Has anyone else experienced this behavior?

If you click on a note and its slur, or a chord instead of a single note, Dorico will interpret that as selecting only that staff. Sometimes, to make sure I’m not inadvertently selecting a staff, I’ll click on a barline, or on a whole rest, as you’ve already found.

I suspect you’re inadvertently selecting multiple items on one specific stave and then hitting “p”. That’s exactly how you’re supposed to tell Dorico to play back that one stave.

(https://steinberg.help/dorico_pro/v2/en/dorico/topics/play_mode/play_mode_playing_back_music_t.html?hl=playback)

The other very easy solution is to always hit an arrow key (left is best) before pressing P.

Thanks Dan - hitting the left arrow key before P is a great idea!

Ah ha, thank you!! Then I’m not going crazy after all. Yes, it seems an attached slur is getting selected along with my clicked note 3 out of 10 times. That solves the mystery for sure. Might have taken me a year or two to figure that one out. Thanks! Glad I posted. ‘L arrow’ key is a nice trick.

I wasn’t keen on this at the start, but selecting a chord or a slur is a pretty quick and useful way of only playing back one stave.

clicking whitespace within a non-empty measure of what you want to hear is another alternative (if you want to hear just that instrument);
otherwise click on the barline to hear everything.

(this assumes you have more than 1 note per measure though)

also useful is to click a measure at the top of a section (piccolo) and shift-click the bottom (bassoon) and you can hear just that section (ww) for example.

The only problem I have with the current setup is that the (for me) mostly used way to play back stuff, which is to play back everything, is the most cumbersome to achive…

I’m sure I’m missing something… could you elaborate ?
just click on a bar and hit P.

See my quote from the manual above. If you hit select two or more notes on one stave, that instrument is soloed. If you hit one thing on one stave, or multiple things on multiple staves, you get tutti playback.

ah, sorry, I forgot to quote. My comment referred to the quote previous to mine:

could you elaborate on what was cumbersome ?
thx,

I think the OP finds cumbersome to make sure there’s only one note selected before pressing P… P and left-arrow is a well established very efficient method.

Another approach is to make your selection, then type Alt+P to move the playhead to the start of the selection, then hit Space. That will always play back everything (provided you don’t have anything else muted or soloed in the Mixer, of course).

For what it’s worth, Paul has made some changes in our current development build such that if you have multiple items selected that start at the same position, when you hit P it will still play back all staves. This is for precisely the situation mentioned earlier in this thread where you might inadvertently select both a notehead and a slur starting at the same position, and then unexpectedly end up playing back just that one staff rather than everything.

Using the select, Alt+P, Space method or the select, left, P method will still work regardless of this change, of course, but hopefully it will feel like an improvement and make the program more forgiving of inadvertently making a multiple selection.

I would not have expected less from your team, but you guys are really fast!
This will probably increase everyone’s workflow efficiency, so thank you :pray:

This sounds like an excellent improvement. I also generally play back all staves, and making it easier to play back all staves is positive for me.

If you select certain staves with ctl -alt, or by marquee group, “p” will play just those staves

Just as a feature request, I would love to be able to have a Play from Leftmost Measure option in Dorico, and to have it be programmable to a Key Command. Often when working on a passage of music, the music I need to hear back is basically what is currently visible on screen. To be able to just instantly play starting with the leftmost visible measure would be a lot faster than clicking something and then two keystrokes (left arrow, P).

FWIW, this is how I have Finale set up: