Padshop 2 not visible in Logic Pro 10.14.6?

Hi folks.
Not sure why my post on Friday hasn’t surfaced, maybe it got missed or binned by moderator gremlins?

  1. Does anybody know the correct installation path for Padshop 2, both the content and the program, for a 2017 Macbook pro, running Mac OS 10.14.6 (Mojave) running Logic Pro (10.5.1)? I have used Steinberg’s download assistant and the library manager.

  2. I have been tearing all available hair out installing, re-installing Padshop 2, deleting AU Cache, re-setting LPX prefs, contamplating human sacrifice at dawn etc. :frowning:

  3. The issue is that since I installed Padshop 2, it appears to have wiped all signs of Padshop Pro I previously had installed and which worked just fine on LPX. Padshop 2 is all licensed and registered just fine in the e-licenser (

  4. Although LPX plugin manager can “see” Padshop (2.0.10), Padshop is not visible as an available drop down instrument. I have Absolute 3 steinberg instruments and they are all visible and available.

I await the wisdom of Steinberg’s glacially slow support gremlins. Apple listened very well but said they couldn’t figure it out either.
Any morsels of help or guidance appreciated, thank you!

Hi Hod,

I have the exact same problem: plugin manager has successfully validated Padshop but it is not visible as a drop down instrument. All other Steinberg products work fine. I have also tried re-installing Padshop 2, deleting AU Cache and re-setting LPX prefs (not the human sacrifice though…).

I contacted the Steinberg Support for this two months ago. They replied after 1 month and couldn’t figure out the problem. They said it worked fine on their end.
I was wondering if you (or anybody else) had found a solution during the last month.

One thing I’ll add is that Padshop (Audio Unit) works perfectly fine in Ableton Live 10.

Hello Hod,

I joined this forum few minutes ago just because of this very topic you mentioned above. I have the exact same problem with the exact parameters you have. Mac OS 10.14.6 (Mojave) running Logic Pro X latest version, USB e-licenser latest ver. etc.

Not only Padshop 2 (update from PS Pro) not in the instruments list but my previously working PS Pro and Zero Gravity also disappeared from instruments list. Pity.

Please post on this issue if you solve it somehow, sometime. I will appreciate it indeed.


I have the same problem…any solution yet?

Hi Hod,
unfortunately there’s nothing we can do to eliminate this issue right now.
We’re in contact with apple and we hope that they will provide soon a fix for Logic or tell us what we have to change in our plugins to solve the problem.

A possible workaround from the LogicProHelp forum is perhaps this one:

Finally I created a new admin user, started Logic and after the validation of the plugins I could create a new empty project with an instrument track. And YES, the Steinberg menu was there, I could use it again.

best regards
Gerrit Junge

hello, is this issue resolved yet?

Pandemics, excuses, that company’s (Apple) or my company’s (Steinberg) issue etc etc. But consider this STEINBERG. I don’t mean to be rude. However I have paid for Padshop 2 after I purchased Padshop and upgraded to Padshop Pro and Zero gravity paid. They all diminished and do not exist in Logic Pro x no matter how you advice in your procedures to follow. I understand you are doing your best to resolve the “not working” issue to your best sincere effort.

But I think you must FIRST pay back my money and then continue to struggle to resolve your problem in your company system and with your partners.

Otherwise you are in a position you have sold an item to me and it was not working for some reason you have admitted and your excuse is minute above silence until this or that. This is probably not only about Padshop 2 installation after Padshop pro but other issues too.

Get serious, please.

From my heart/mind and very serious on your behalf too.

1 Like

i am having the same problem too with Backbone… i just payed 150 euros for a software that i cant use??!

I have been away from this forum for a while and see that a fair few folks have had a similar problem. All that Steinberg can point to is that it might be down to Apple…great :slight_smile:

Gerrit Junge suggested (thank you!) creating a new user profile (for my Mac) but I need to read around that and see what that means. Does that mean I can carry on using LPX just as before, with all current songs and plugins intact etc.

What I can do is install Unify from pluginguru (the simply fantastic Mr John “Skippy” (why does he call himself that…?!) Lemkhul) as a plugin for LPX.
From within Unify I can then install Padshop pro and see it etc. Bit of a crazy workaround but do-able.

Please have a look here:

best regards

OK update here for anybody interested in this.

  1. I bit the bullet and upgraded to Absolute 4 vst instrument collection. I also upgraded to Catalina (OS 10.15.7) as the majority of my plugins, inc Steinberg and those from Spectrasonics, now seem to have caught up.

  2. I decided to install the Steinberg VST instruments one by one. First Retrologue 2 - no problem. It works in standalone mode and is entirely installable and viewable and playable in Logic Pro 10.6.1.

  3. What then about Padshop 2? Logic Pro can now see it - hurrah success.

  4. Now for the “but…” A small but significant problem - I cannot get it to play any presets. When I call up Padshop within LPX I get no sound and see this Apple OS error message “The open file operation failed to connect to the open and save panel service”.

  5. I have tried installing (and removing and reinstalling) the various Padshop pre-set vst files in every conceivable location on my Mac. I tried the default path offered by Steinberg. No joy. I tried installing the Padshop pre-set vst files in my downloads folder, then my documents folder. Each time - no joy. VST (1) FCP_SMT_788_Padshop_Presets.vstsound and (2) FCP_SMT_Padshop2_Presets.vstsound are currently languishing doing not very much at: Mac HD/Library/Audio/Plug-Ins/VST

Support ticket now lodged with Steinberg but in my experience they can take weeks sometimes to reply. Why is installation and removal of vst files so darned difficult? Following the official Steinberg default VST locations for Mac hidden on its website doesn’t seem to work. I presume it is operator-error, but it is very painful!

If anyone can help this numpty, please send me options, thank you!

Hey there Steinberg.

I saw Gerrit’s reply (on this post) suggesting that this issue with Padshop seems to be an Apple one.

Hmm, a few weeks ago I upgraded to Mac OS 10.6.1 (Catalina) and bought Steinberg’s latest shiniest set of Absolute 4 Collection (which includes Padshop 2). What could possibly go wrong? Throw more money at it and it is bound to be a perfect upgrade experience… not

I started installing Steinberg’s Absolute 4 collection of instruments one by one.
First Retrologue (no problem, all good, playable in Logic etc).
Then Padshop 2. Not a chance. Padshop2 installs OK and is now recognised by Logic Pro - a great improvement on before.

The elephant in the room however is that PADSHOP 2 STILL DOES NOT WORK! (Apologies for shouting. Child sacrifice is not working, Brexit was an unwise decision…)

The issue is that the pre-set sounds in Padshop 2 are maybe refusing to install properly and/or are incapable of being recognised by Padshop 2. From within Padshop 2, I get the error message
*“The open file operation failed. The open file operation failed to connect to the open and save panel service.”

Despite lodging a ticket on 08 April 2021, I got a reply from support today suggesting (only) that I try downloading the latest e-licenser control version. I did. It is exactly the same version as on the one I was using on the day I filed my support ticket (eLC Version

This is really frustrating. Is this still an Apple issue?

Mutter mutter.

1 Like

I’m having the identical problem. Did you ever get this resolved? The only validated solution(?) I found involved setting up a separate partition and user, and installing LXP there. Not a pretty picture if that’s the only way forward. Quick update would be appreciated, as I’m (literally) feeling your pain.

Well…here we are, over a half year later and the problem of Logic 10.7.2, running on OS 12.2, on a MacBookPro M1 Max successfully validating Groove Agent 5, Groove Agent SE, HALion SE, HALion Sonic, Padshop and Retrologue, but not presenting any of them for selection/launch, continues to exist. The latest eLicenser is installed on a brand new dongle.

None of the suggestions (short of creating a new account…which is not a valid suggestion in any sense) in any of the associated threads on this subject solves the issue. When is this issue going to be seriously addressed?

1 Like

I am running Mac OS Mojave 10.14.6 on a Macbook Pro 2017. The issue is that while LPX (10.5.1) can “see” Padshop using the plugin manager, Padshop 2 is not available as drop down menu item in LPX. I have other Steinberg products installed (e.g Absolute 3 collection) and they all work just fine.

  1. I installed Padshop 2 seemingly successfully using Steinberg’s recommended Library Manager and Download Assistant.

  2. It has all registered fine with E-Licenser ( and registered on my account with Steinberg. Basically, I want to add this to the best ERP software in Kolkata() and also wants to add related things.

  3. LPX can “see” Padshop using the plugin manager (it shows as simply “Padshop” 2.0.10 which I think is the latest Padshop 2 version. The plugin manager has reset and scanned the plugin and appears to have successfully validated it.

  4. I previously had Padshop Pro installed and it all worked fine with LPX and could be installed in a track with no issue. Since installing Padshop 2, it has all gone to pot.

  5. To try and fix this I have performed no end of clean uninstall and reinstalls of Padshop 2; I have deleted the AU cache several thousand times; re-set LPX prefs; kept the Mac gatekeeper open & unlocked (to allow apps downloaded from identified developers); kept the e-licenser open. Short of the blood sacrifice of my teenage children I am running out of road.

  6. Might it be the location of where Steinberg’s library manager and download assistant has placed the content that is the issue? I am not that au fait with the different libraries Apple has and fiddling about in different application support folders etc never seems advisable unless you have clear instructions.

Same problem here, running LPX 10.5.1 on Mojave. Installed Padshop 2, wanting to try the 30-day trial. Validates in Plugin Manager but doesn’t show up in drop down menu after restarting multiple times. Anyone ever figure out a solution?

I was going through the same problem for both Padshop2 and Nexus. (both plugins run on eLicenser, that could be there source of the issue?). After going through all the same steps everyone else seems to have taken, I have successfully gotten both plugins to work, by doing a “Full Audio Unit Reset” in the plugin manager. I tried this once, and no success, so I decided to try a second time and it actually worked then! Id recommend giving it a go, and trying it a couple times if it doesn’t work the first. Best of luck!