Parts get track names

Is there a way to make new Parts from imported audio files assume the name of the audio file rather than the Track? I know there is a preference in “Editing” called “Parts get track names”. But it does not seem to change this behavior.


  • Import audio into the pool
  • drag the audio file to a pre-existing track with a generic name (cymbals for example)
  • Create a Part for the new file (Events to Part)
  • The new Part assumes the name of the track rather than the name of the file regardless of how the preference is set.

I know there would be a potential conflict if there were several Events being tiurned into a Part but I’d really love to find out if there’s a way to turn a single Event into a Part and have the Events name dictate the Part Name.


If you drop the file from Pool to the empty space of the Project window, to create a new track, then this track will be named by the name of the Audio file. Then even the part will be named the same.

Thanks for the reply Martin - I am aware of that but what I was trying to do was drop new files onto an existing track of similar elements. It’s not a huge pain to rename the new Parts manually.
I sometimes just leave the files on the arrange window without nesting them into Parts but I really prefer working inside the Part editor for tweaking.

Oh well… Onward!

Yes…this was possible in the earlier versions of Cubase, I remember I changed it in preferences so my midi parts can retain their own names. But now, in C8 Pro, I am trying to do the same, but doesn’t seem to work :confused:

Maybe someone found the way to do this?

Preferences > Editing > Parts Get Track Name. When you enable it, then the part gets the track name, once you move it to the new track.

Is this what you are looking for?

Yes, and I tried that. Like I said, it worked in earlier versions of Cubase. Now, with either option, checked and unchecked, when I drag and drop midi files in existing midi track, midi parts/events get the name of the track. Default is unchecked.

So, as far as I understood, OP has the same problem.

Is it different with you Martin?

It works to me as expected here (Cubase 8.5.15, Mac OS X).

Well, maybe it’s a win thing :confused:

I just tested it on Windows and it also works here to me.

Thank you so much for testing Martin.

Just to make sure… you dragged and dropped some midi file into an existing midi track, and the midi event got the name of the midi file, not the track?