Paste automation from an Insert plugin on a Group does not work. See repro

To reproduce:

  1. Create new project or use an old one
  2. Add a Group track (let it be the first track on the project, on top)
  3. Add any VST plugin as an Inserts effect on the Group track.
  4. Automate any parameters in the VST plugin using Write (or put in automation by hand).
  5. Right-click Show all automation on the Group track.
  6. Select/Mark the automation data (or part of) and select Copy (you want to copy and paste the automation data somewhere else on that track). Copy via CTRL+C or Copy via Edit menu.
  7. Paste the automation data somewhere else in the project (still on the same Group track) using CTRL+V or Paste in the Edit menu.

RESULT: The automation from the VST plugin automation lane is now copied onto the Cubase own volume (!) automation lane/track instead of the same/correct parameter lane that automates the VST plugin!

(Windows 10 version 2004, Cubase 11.0)

EDIT: I managed to find out when this happens. It happens ONLY when you have the Group track as the first track in the project (on top)! If you move any other track as the first track, the copy/paste scenario begins to work again. STRANGE bug indeed. :slight_smile:

Updated the reproduction. I have now confirmed this using both newly created and old projects.

Hi,

I think, it’s a user error (sorry).

Once you paste the automation, make sure, the Automation track is selected, not the Group track. If you select the Group track, the Volume Automation track of the Group is selected (because the Group track is just the automation track, in fact, with the Volume automation parameter as default selected). So to make it working properly, make sure your plug-in’s parameter automation track is selected, before you paste, please.

Sorry, but no, it’s not a user error. I’m guessing you do not have the Group Channel first in the project. Be SURE not to have it inside any “Group Tracks” folder - as I said - the Group Track must be the first channel on the project. If a Folder track is first, then the group track is not!

Since I can reproduce it every time I am 100% sure that I am selecting the Automation track. It does not matter if you select the Automation track on the Group track or the Group track itself, the outcome is the same.

I’ve made a video capture that clearly shows the faulty behavior: (in .MKV-format)
https://1drv.ms/u/s!Ai2QSnrrb3AZrWD7l-YAoWJnZto2?e=u4PbYb

Hi,

OK, I see, you were right, I left the default Input/Output Channels folder on the top. When I moved the Group Channel even above this one, I can reproduce it.

Actually, the Paste is shifted 1 track up. If I write another Automation Track, select this 2nd Automation Track and Paste, it has been pasted to the 1st Automation Track.

Sorry, I can’t read MKV files (and to be honest, I have never heard about it). But no problem, I can reproduce it, now.