Patch Scripts TXT vs XML

Hi Experts, I am trying to create a patch file for my Kawai MP-7 using Scriptmaker. I have now a .txt file that may work. However, the “Import Setup” function in the MIDI Device Manager is expecting an XML file. Forcing the upload of the .txt file (by switching the selector to “all files”) does nothing.

I tried with an older (Cubase 4) version hoping it would accept txt files but it doesn’t.

How do I build the XML patch file? Is there another tool for that?

Thanks in advance!

I’m not in front of the DAW at the moment, but isn’t there an Add button too? This scans a folder for the .txt files and displays a list. Again, I can’t tell you where these files are except that they’re somewhere in the settings folder. Put your .txt file in there and it will be displayed as well so you can then read it in.

There are effectively 3 file types used for MIDI devices. The .txt file is for ‘easy’ creation using an editor. The XML type is for export/import, not very easy to edit but possible. Then the MidiDevices.bin file is the private non-human-readable file used by the Cubase app and is maintained in the top level of the settings folder.

If anyone knows how to rename a Midi Device I’d be happy to know…

Mike.

Drop the .txt-file in the folder “Patchnames” inside the scripts folder that sits in your Cubase preferences folder.
Under normal conditions (the script you try to use is ok) you now can see the .txt patchscript when adding new device.

Good-luck!
Peter

Peter, Mike, thanks for your help! I am not quite there yet, though

I tried dropping the txt file at the C:\Program Files\Steinberg\Cubase 8.5\Scripts\patchnames folder but it wont show up in the Midi device manager (after restarting Cubase).

I tried also placing it in the \patchnames\inactive folder as that is where other installable devices are. Still it won’t show up.

To rule out any problems with the file itself, I edited one the scripts in the inactive folder, changing only the Device and Script name fields and saving it with a different name. Still it won’t show up.

I think the list of installable devices is not refreshed dynamically when Cubase starts. In fact I removed one the files in the inactive folder and, after restarting, Cubase would still list the device and let me install it.

I know I’m missing something here, but I just can’t figure it out

Thanks again

Luis

Try to add the script into your user data folder.
https://www.steinberg.net/forums/viewtopic.php?t=62077

Yes!

Thanks guys!