[PC] no EuCon in the drop list of Cubase 6

I am working with Win Seven 64 and latest version of Cubase (6.0.4).
I installed the Euphonix MC Mix with the latest software release (2.6.1), rebooted the PC.
I activated, with the code given, the EuCon licence on mysteinberg and, downloaded it on my eLicencer.
I then installed the EuCon Adpater 6.1 (64bits), rebooted the PC.
I launched Cubase and check in Device Setup drop list and EuCon is not shown.

I tried to uninstall and reinstall but nothing is changing.

All topics I could read solved the problem because generally the EuCon Adpater was not installed. But I don’t see anything else to do…
I set “Cubase” as application in the Euphonix control panel once, I had Euphonix MidiIn1 to 8 that appeared in Cubase but still no trace of EuCon in the drop list.

The last thing I can think about is the version of Cubase (6.0.4) because the lastest EuCon Adapter is said compatible with Cubase 6.0.3 and Nuendo 5.5
I don’t see where to uninstall the 6.0.4 patch of Cubase to replace it with an older one. Would I have to uninstall all Cubase and reinstall it to make it work ???

If anyone has an idear to help, I would be glad :slight_smile:

I don’t think it is a 6.04 problem, I am running it fine with Eucon. It looks like you have done everything correctly, I don’t know what else to suggest.
One thing to check, when you open Cubase, don’t open a project, then check the devices menu to see if Eucon is there.

I found were it was coming from : the firmware of the Artist Mix was 1.4.1

I had to updage the firmware and then, it was fine.

But it is far away for a plug-and-play system… :stuck_out_tongue:


Have you updated e-license because it will not work without doing this. I had the same problem but as soon as I refreshed the e-licence the Eucon appeared in the device list.

Hope that helps!

Hi there

I do have exactly the same setting as loupblanc. It was working fine until last week. I installed UVI Workstation but I am not sure it was related : I lost Eucon in Cubase.

So I updated everything :

  • Firmware 1.5.2
  • Uninstall and reinstall Euphonix lastest version
  • Uninstall and reinstall the Eucon Adpater in its lastest version

Eucon completly deseappared from Devise Setting page. Clicking “+” to add it back doesn’t work as it is not in the list at all. I had same trouble as loupblanc when installing it, it was the firmware that needed to be updated. But now ?!

Any idear?

I found the solution : update to the latest version the elicencer of the Cubase Key. :wink: