PDF exported by Dorico unreadable in Acrobat but Perfect in f.i. Google Chrome

Hi,

I have a very strange situation here.
When I export to PDF my acrobat reader can’t properly read it.
However, when I open the file with Google Chrome for instance, it reads it perfectly.

All help appreciated!

SOLVED - see comments

What is the nature of the problem you’re seeing in Adobe Reader, Pieter? You don’t say what is happening when you try to open it in that application.

My experience:

  • The preview in Google Drive looks good.
  • When I open it in Acrobat Reader, first I get an error message along the lines of “There’s an error with the document; please consult with the creator of the file.”, and all I see is 2 staves of empty lines, no notes, no text, nothing else, only 2 empty staves.

I get the same behaviour as Estigy in Acrobat Reader, but SumatraPDF reads it with no problems.

I’ll just add this to my (long) list of “reasons why I don’t use Acrobat any more” :wink:

FWIW, one online PDF error checking/recovery site that uses Adobe’s tools simply gave up with the message “Unable to process document due to PDF Error”. A different site not using Adobe’s tools said it was a valid PDF version 1.4 file.

Oh, wow. This is not good. People buying our music in PDF format written with Dorico will not appreciate this.

I have produce probably close to 600 PDF scores (maybe more) using Dorico, and I’ve never had this error. Neither have many other users, I assume, since this is the first time I’ve seen this on the forum. So while I’m not minimizing it, there’s no reason to think this is typical behavior.

Add another few hundred error-free PDFs from me, totalling thousands of pages and involving roughly a dozen standard and non-standard fonts. This isn’t typical Dorico behaviour.

Well, the fact that Adobe Reader behaves like a half-baked piece of bloatware is fairly typical behaviour - for Adobe Reader. :imp:

For the benefit of Jode, and anyone else who’s not following Pieter’s thread on the Dorico Facebook group, it looks like user error:

I am getting the same error message, when opening the PDF file with Acrobat. But if I export the attached Dorico file to PDF than there are no errors with Acrobat. A question to Pieter: did you export the file as Graphics/PDF or did you export with Print to any PDF driver? Maybe the driver is corrupt.

Uwe, this has already been dealt with on the Facebook group.
A. Exporting the PDF from your copy of Dorico is irrelevant, because you probably don’t have the relevant font (Aviano Sans) installed at all and Dorico substitutes different fonts when you open the project.
B. He was using the Export Graphics option correctly, but can actually work around the problem by using a third-party PDF printer (which will likely export the text as graphics rather than trying to embed a font that doesn’t exist).

Hi Daniel,

I have the exact same experience as Estigy, same error message.
The PDF looks like this (see attach.)

I am using Aviano Sans font, this is the culprit, see pianoleo’s post.
Aviano Sans doesn’t have an italic version. So if I wanna use it I can by printing instead to a PDF printer.

Best regards and thanks!

Well, regardless of how it “ought” to work (or not) this is what it looks like in SumatraPDF.

That looks like “bold, normal, and italic” in the document to me. And I don’t have any version of the Aviano font on my PC.

If Adobe reader wants to complain about a missing font, that’s OK - so long as it produces a meaningful message, not the garbage it actually produced.

Internally the PDF refers to Aviano Sans Regular and Aviano Bold (and also the Dorico supplied fonts Academico and Bravura). On SumatraPDF both versions of Aviano display correctly (compared with samples from font downloading sites) so they must both be embedded in the document.

I’m not convinced the Adobe Reader problem is related to fonts. I can’t see any evidence either for or against that idea.

Again, the garbage it produced may be down to QT, or it may be down to Dorico, or it may be down to Adobe.

For clarity, this garbage is the list of embedded fonts Acrobat Pro (on mac!) that appear in Pieter’s sample PDF:

Note that
a) “gathering font information” is stuck at 0% and
b) “C:\Windows\Fonts” is completely invalid as a font location on a mac.

What I’d expect to see is something like this (and it’s what I get, in Acrobat Pro, if I’m only using fonts that are actually installed) :

Sumatra doesn’t have a large “properties” display like Adobe, but looking at the PDF itself, it certainly references Aviano Sans Regular as well as Aviano Bold, and both seem to be embedded as well (though I didn’t trace through all the internal cross references to be 100% sure about that) since Sumatra is obviously finding both of them from somewhere in order to display them.

Why Adobe can’t find it is Adobe’s problem.

That is just the internal font name in the PDF. (It was the location of the original font installed in Windows, but that’s irrelevant for an embedded font).

In any case, Adobe gives the same error trying to open the PDF on both Windows and Mac.

There is one oddity: Aviano Sans was from
/C:\USERS\PIETER\APPDATA\LOCAL\MICROSOFT\WINDOWS\FONTS\AVIANO_SANS_REGULAR.OTF
but Aviano Bold was from
/C:\WINDOWS\FONTS\AVIANO_BOLD.OTF

which suggests that the Aviano Sans is only installed for one user but Aviano Bold is installed for all users. That shouldn’t matter, but who knows…

Nope. That’s not my experience, at least. If the font’s properly embedded the original font location doesn’t appear.

These are the font properties for a PDF I exported from Dorico on Windows, as shown in Acrobat Pro on mac:

edit: I’ve got hundreds of these, and I’ve never come across one that displays an original font path.

I guess Adobe works differently on Windows and Mac. This is what I see from Adobe Reader on Windows, from a Dorico PDF.

FWIW The name that is actually in the PDF file is store like this

<< /Type /FontDescriptor
/FontName /QUJAAA+C:\WINDOWS\FONTS\BRAVURA.OTF
…
<< /Type /Font
/Subtype /CIDFontType2
/BaseFont /C:\WINDOWS\FONTS\BRAVURA.OTF

so there is some reformatting going on when it is displayed.

Weirdly, the PDF passed as many Acrobat Preflight tests as I tried, though clearly something is wrong with the PDF font data. If Acrobat displays something incorrectly, that’s a pretty good indication that the PDF document doesn’t follow the spec. (which, after all, Adobe wrote.)

Other PDF viewing engines are often more forgiving in their interpretation of the data.

I have to say that I was surprised by that full pathname for the font, and I am something of an old salty PDF dog.

ISSUE RESOLVED: here’s the easiest fix in the world, I can’t believe I haven’t thought about this before. I reinstalled the font by right clicking: install for ALL users. Tried exporting in Dorico, perfect result! :slight_smile: