Pedal playback ignores 1st note at high tempo (solved, but thought I'd share)

[This is something I solved myself in the midst of typing this, but I’ll keep it posted if anyone else is wondering the same]

At faster tempos, Dorico doesn’t put the pedal “down” until the 2nd 16th note, ignoring the first note if it is a 16th note. At slower tempos, it catches the first note.

The solution is in playback options (shift-command/ctrl-P): With “pedal lines” on the left selected, you adjust the “depression length” to shorter than the your shortest note in the listed tempo range (in my case, 1/4 of a quarter note = 16th note, so I shortened it to 1/8 of a quarter note = 32nd note)

(Now, if only “depression lengths” outside of music could be adjusted so easily!)

Would it help to use the function in Playback options>Timing>Flows>Pre-roll before flows to any value greater than 0?