Pedal/sustain notes Issue with Recording with External Synth

Hi,

I am trying to record a MIDI (instrument track), audio output to 7&8 of my MR816 and the midi input from PSR-3000 Yamaha Synth. However, when I record during playback and monitoring ( both monitor on and off), I hear lots of pedal and hanging notes. I have the local control off on my PSR to make sure, I don’t hear the feedback.

  1. I did try to remove it following this method: https://www.steinberg.net/forums/viewtopic.php?t=10093
  2. force the Sustain pedal automation all the way down to zero from the beginning to the end of the song. activated R for automation.
  3. Move the midi part to another instrument track with Halion sonic GM piano as output, but i still hear the pedal/sustain notes.


    What am I doing wrong please?
    Any help would be greatly appreciated.

Hi,

This worked perfectly: Midi > Function > Pedals to note length.
But would like to know why above methods didn’t work.

  1. How is your MIDI connected? USB or the standard midi ports on your keyboard to a midi input/output device?
  2. Make sure you set the midi input to a specific port on the track and not ALL Midi inputs and your Channel is specific to your Yamaha channel and not ANY
  3. Local=OFF on your Yamaha
  4. Midi THRU = ON by default in Cubase
  5. I use a MIDI track when Im wanting to trigger any external hardware synths with a Stereo Audio Input for the Audio track
  6. If you are using USB midi cable from the Yamaha that could be the bad guy, driver maybe
  7. “Midi > Function > Pedals to note length” Should never need to do this
  8. Are you using a Yamaha pedal?
  9. I leave INPUT QUANTIZE to OFF in Cubase as it gave me issues

OPTION 2:

  1. Change your Local to =ON
  2. Set Cubase THRU =OFF in prefs

shanabit,
I think the issue was something very strange.

After I did Midi > Function > Pedals to note length, it fixed. I played another segment. I noticed pedal issue occurred again.
It seems when I press the pedal and release, it latches. So I need to press it again to disengage the pedal!

Isn’t that strange! My pedal is M-Audio SP2.

I went to foot pedal setting, there is nothing about pedal setting for latch, momentary, etc. What I did was I switch the polarity both on SP2 and PSR keyboard. Not, it seems it is momentary! I will record more and see.

  1. Leave the pedal settings on the pedal itself alone, just switch it on the Keyboard, that should do it

OR

  1. Buy a Yamaha pedal, problem solved.

**I use a YAMAHA pedal here with my Korg Triton but have switched the polarity setting in the pedal settings on the Korg to fix that issue