Percussion disposition

After a lot of experimenting with a suitable percussion-disposition I almost succeeded - except for one issue. My setup is: 1 player with a set of crotales and a set of woodblocks and some additional instruments.

Percussion 2

I arranged this as shown in the screenshot. Whenever I get a label “to xxx” I know how to make it invisble (via the lower panel). However I don’t know how to get rid of the clef-change preceding a switch of instruments which should not appear in the score.
Apart from that I don’t understand why the second percussion clef appears in the Crotales-line.

Should I perhaps move some of these instruments to an additional player?

The clef change is correct. First you have the clef showing notes with pitch notated in treble clef, then you switch to percussion clef. Totally correct.

Regarding the second question: Where do you see a second percussion clef within the Crotales line?
As I read your screen shot, the three-line system with Bck, Gr.Tr. and TT. belong to another player, not your player from the first screen shot, right?

Hi @lim.usic , the clef change and the “zu Perkussion” appears because you set Allow Instrument Changes (in Layout Options/Players/Instrument Changes) for the player (who plays not only the Crotales but also Triangel, Hokzblocks and Perkussion). You can uncheck this option if you desire, or if you want the clef change and the “zu Perkussion” to appear later (with Allow Instrument Changes on), insert, on the Crotales staff in Galley View, an empty Chord Symbol Region (Write/Create Chord Symbol region) just before the “Perkussion” entrance (thus forcing Dorico to “retard” the instrument change).

There is 1 player with 4 instruments, so the 3-line-staff belongs to the same player. What I meant was the little percussion clef in the Bass-Drum-line.

Thank you Christian for your great suggestions! Since I don’t use chord symbols the chord feature was totally out of my mind.
At the moment the unchecking of “instrument changes” seems to do the trick, even if this appears paradox to me in case of percussion players constantly changing their instruments :face_with_monocle:

Glad I could help :slight_smile:

I don’t understand what is the paradox?: you have the option to not allow instrument changes. If a player holds more than one instrument (as in your case, because you has it setup this way in this project) you can choose (through the layout options) if you want all the played instrument appear on the same staff (as instrument change), or on separate staves.

Now there is another small problem left: Why are the woodblock-barlines overhanging and how can I fix this?

What is the context? (staves above and below?). Maybe a bigger picture would be better to understand. Or just the Dorico file with the bar reference.

[Edit] Is this a grid (with 5 lines because you have 5 H.Bl.), or a 5 lines staff? (Layout Options/Player/Percussion)
For the grid is nomal to have the protruding lines, if you set it as 5 lines staff the protruding lines should be not there.

There is an option for the amount of protrusion above and below the staff for percussion instruments on the Barlines page of Engraving Options.

Lim, here the settings page that Daniel suggests, when you use Grid presentation, if you set it to 0 the lines disappear (had forgotten this, thank you @dspreadbury ):

Thank you both, great help!

Also reading your other comments on another thread,

I would remember you that the Layout Options (for allowing or not allowing instrument changes for example, or the presentation type as Grid or 5Lines Staff or single line) are Layout specific: so you can have “don’t allow instrument changes” in full score layout, and “allow them” in part layout.

1 Like