Percussion map problem


I set up a drum kit and percussion map for my midi keyboard and everything works.
I just have 2 problems.
First of all the ride cymbal where I have 2 symbols 1 for the normal play mode and one for the dome.
I only have access to the natural mode.
And the same for the snare drum where I don’t have access to the Hi-Hat writing, open side stick, rim shot and cross stick.
However everything is configured correctly it seems to me.
Can you help me.
In case I attach the files.
I need this to work for my next you tube videos on Dorico.
Thank you in advance.

It would certainly be easiest to diagnose whatever might be going wrong if you could attach the project itself here, Laurent.

Very thanks for answer.

I attach you the filePercussion Laurent.dorico (540.1 KB)
you can see that the additional playing techniques for snare drum or ride cymbal or hi-hat doesn’t work with my midi inputs.
the only way is to reload the snare drum, hi-hat and ride cymbal by default and then it works.
when you save the drum kit then and the percussion map to import it in a new project it doesn’t work anymore and you have to do these manipulations again.
what to do.
I know you will find a solution.

Laurent, I agree that everything looks like it’s set up correctly. Can you clarify exactly what problem you’re having? You can access the different playing techniques you have mapped for the ride cymbal and the snare drum using Shift+Alt+up/down arrow.

I agree that with the arrows everything is ok.
My problem is with my midi keyboard.
When I play E I have the hi-hat closed but when I play F I don’t have the Hi_hat open.
The same goes for the note G sharp or there is the dome wrinkle.
The man problem is my percussion map and the drum kit with my midi keyboard.

Which option do you have set in the Percussion Input section of the Note Input and Editing page of Preferences? You should probably use the Use percussion map option so that you can play the appropriate pitches on your MIDI keyboard, accessing the different playing techniques directly.

I used the percussion map input in note entry and not in relation to the staff, but this does not allow me to access the other techniques of the instrument.
When you try out the midi keyboard do you get to the other techniques of the cymbal ride and hi-hat and snare drum?
Thanks for the help.

my midi percussion map is called Laurent Colombo

Excuse me
Have you find a solution?

Please don’t bump threads, Laurent. I know you’re waiting for an answer. I’m afraid I had other things that I had to attend to today (my role encompasses a lot of duties besides maintaining a presence here on the forum), and it is now past midnight here in London so I’m not going to be able to dig deeper into it right now, but I will come back to you as soon as I can. You can rest assured that I haven’t forgotten about you.

ok excuse me very much.
I have a deep respect for you
Thank you for the answer.
I know you have a lot of work to do and I thank you for the valuable help you are giving me.
Here are my 2 problems.
First, in this project, using the midi keyboard, when I play a b flat I should have the brushes with a certain type of writing and it doesn’t work the same for the hi-hat open on f and the rimshot crossstick and side stick which are configured on the midi notes e f and f sharp.
Then I would like to know if it is possible to remove the GM drummap reading from Halion Sonic SE so that in reading only the key swich respond.
For example, when I do the bell tree on C I get a whistle at the same time.
I understand why because there is the drummap and my keyswitch that coexist.
I only want my key swicht.
Otherwise, congratulations, you are doing a very good job.
You can be proud of yourself.

Percussion Project.dorico (506.6 KB)

Just to let you know that I have been looking into this, Laurent, but I’m still in the process of figuring it out. The problem, I think, is related to what happens to the way Dorico references instruments when you export and import percussion kits between projects. I’ll come back to you when I have a better idea of exactly what’s going on.

Thank you very much