Percussion notation: "stem up" not respected, additional clefs in marimba on instrument change


In an ensemble piece there are 2 percussionists playing tuned and untuned instruments. I am encountering 2 problems, for which I hope you can help me out with some advice.

  1. The stem direction of single line instruments like Bass Drum (currently set to “Up”) is not respected. I know I could change that manually, but I’d rather prefer to have this rule set globally. Do I have to set some other rules, too?

  2. When changing from an unpitched instrument to a pitched one (e.g. from Bass Drum to Marimba), additional clefs will be displayed in mid-measure in the Marimba. This is not needed. How can I get rid of them?

Thank you!

Screenshot 2023-05-30 at 11.18.15

  1. There’s an engraving option Percussion > Single-line Percussion > Default stem direction. But I guess this setting will change all your single-line instruments.

  2. I don’t know exactly how your percussions are set up. I can’t reproduce the same layout.

Thank you for the percussion one-line hint, @Nukkul !

What do you need to reproduce the layout? Respectively, how do you setup your percussion?

In my case, all instruments (except for the cymbals) are kept as single instruments, no kit. The are all set to “grid”.

I put 1 percussion player in a “section” to get a better indication which instruments belong to which percussion player.

Does this help?

I only get the clefs if I combine them to one staff. Which makes sense, because you have to know if they are both treble or bass clef, or whatever.

Bildschirmfoto 2023-05-30 um 14.36.57

If they are separated i don’t have the clefs.
Bildschirmfoto 2023-05-30 um 14.36.48

Interesting! Any chance you could provide your file?
@Nukkul How did you combine Bass Drum and Marimba as you did in your first example?

@Chris-J.E But how can the layout be achieved that @Nukkul shows in his first example?
Oh… you deleted your post… why?

Because it doesnt’ work… I tried, and the clefs still appear. I think, they have to, but it looks ugly…

Edit: If you only have ONE staff, it’s ok i think:

But Marimba has 2 staves… Any @Nukkul managed to get it work as it seems…

What about this solution?:

@Chris-J.E Thank you for your feedback … much appreciated that you take your time to help me! :slight_smile:

If looks like you are working in the percussion part. But my example is from a score, and there i cannot make such system breaks (if that is what you suggest).

No, I am really looking for the solution that @Nukkul posted as his version 1. That would be what I want…

I add another screenshot hoping to show the score setup more clearly:

Like this?


Sorry wrong file, this
Perc.dorico (550.1 KB)

You do have Allow instrument changes on I guess?

1 Like

percussion staff.dorico (645.3 KB)

Here’s the file, from which I posted the pics. The two versions are indeed with allow instrument changes toggled on/off.

Why it doesn’t look like it in your score, we need a (cut down) version. As i said, i cant reproduce it the way you have it.

1 Like

Thank you, @Nukkul and @jesele for your feedbacks and files! Great help, really appreciated!

I looked at the files and compared them to mine, but I was not able to detect a difference, at least not in the Layout → Player settings. Here is my my stripped-down score:

percussion-test-file.dorico (3.1 MB)

Do you find anything?

(BTW: I use Dorico 5 (on a Mac with Ventura 13.3.1), the score is an import of a Finale XML. I did a lot of re-assigning instruments in the Setup section…)

I’m not at home now. So I can’ check the file. But I recently had a problem with a xml import as i wanted to transpose a trombone part. Sometimes the clefs are “hardcoded” at the beginning. You have to delete them, so they become the default.

In my case, i had to delete a bass clef so i had a bass clef, which can be changed, when i tried to transpose the part to Bb in treble. If i wouldn’t have changed it, the clef would stay a bass clef.

1 Like

I you do a Reset to factory in Layout options, it works. Then you have to reset your page format and other stuff. Haven’t found what is the cause though.


percussion-test-file.dorico (1.2 MB)

1 Like

Found it. Untick this in Layout Options.



Wow! You guys are truly amazing! Thanks for all your detective work, @jesele and @Nukkul and @Chris-J.E !

@Nukkul I did try to reset the clefs (while NOT using @jesele 's tip), but that did not remove the additional display of those additional clefs.

I wonder, if @dspreadbury knows something about this behaviour and could shed some light on it.