Performance falls apart and audio dropouts abound when multiprocessing is enabled

This doesn’t make sense as I would think multi-processing in the advanced tab would facilitate better performance. Does anyone know what’s going on? Is cubase always this buggy?

Maybe someone might be able to help you if you post your system specifications, your operating system and a screenshot of your Audio System window. What kind of project is your computer struggling with?

Cubase runs just fine with multiprocessing, and, as a matter of fact, the Export Audio functionality in Cubase [12] is highly parallelized and will make use of most/all of your cores. So, as @Romantique_Tp said, this is likely system-specific, and will require more info for this community to diagnose this.

I can confirm, that I’ve been running multiprocessing enabled with Cubase on Windows 10 just fine for years.

One thing that might be worth checking:

I’ve had issues from time to time, when I’ve allowed a plugin to also allow multi-processing. So that might be something to check and maybe disable.

Thanks so much for the responses; adding a few more details here:

Project - issues start with a completely empty project with even just one instance of a VST like the spitfire labs’ OPW piano library standalone plug.

System: Windows 10, 64GB RAM, Inte i7-8700K CPU @ 3.70GHz, 3696 Mhz, 6 Core processer.

Audio Interface: Komplete Audio 6 - running at 48k hz with a 1024 process buffer. No red flags show up when using the Komplete panel diagnostic tools but the cubase peak performance meter goes off the charts whenever multi-processing is enabled.

This issue does not appear in Ableton, Reason, Max/MSP, Bitwig, or FLStudio on the same machine even when running quite intensive projects - only occasionally in Dorico which leads me to believe buggy steinberg code may be the issue.

Has anyone experienced this issue before? How did you resolve.

1 Like

Thanks for the additional info! What exact version of Cubase are you running? If you’re running Cubase 12, you’ll want to run 12.0.30 (the latest patch), which resolved a bunch of bugs that might be related to this.

I’m currently using a similar but slightly less powerful system (6 core 12 thread i5-10400F @ 4GHz, Windows 11), I don’t really get audio dropouts even with dozens of Firefox tabs and YouTube open in the background when running similar projects. I use sub-640 sample buffer sizes at 48 kHz.

Cubase uses very little CPU when there’s not much going on, specially when VST3 plugins are used. What could be a game changer here is enabling the Steinberg Audio Power Scheme option. This keeps your system revved up even when there’s nothing to process, which should eliminate audio dropouts for almost everyone. Of course, you still gotta watch your buffer size when running larger projects.

If you still get audio dropouts, it’s very likely that something is interfering with Cubase’s performance. Steinberg has posted a list of common troubleshooting steps that you could try. These can apply to any low latency audio application, not just Cubase:
https://helpcenter.steinberg.de/hc/en-us/articles/360008589880-Windows-How-to-set-up-and-optimize-a-Digital-Audio-Workstation

I’ve personally never had to do any of this (besides enabling the Steinberg Audio Power Scheme), but as always, your mileage may vary.

If nothing helps, I would recommend contacting Steinberg Support. They’ve been able to help many users with performance issues in the past.

I’m running 12.0.30 build 286 - is there a newer build I could try?

Activating the power scheme seems to be helping :slight_smile: thanks

On another topic, someone has posted how they finally managed to fix the performance issues with Cubase :

Spoiler : You need a $5,000 computer to run Steinberg producs. Proof here.

Edit : No need to hide my posts, people are allowed to know, there is nothing misleading.

2 Likes

This is highly misleading. That user specifically wanted to run his DAW with power saving features enabled.

The majority of users can run their DAWs on much lesser hardware (even aging laptops) without audio glitches by simply disabling a few power saving features, which has always been recommended for professional DAW use anyway.

Then why is this issue only happening with Cubase/Nuendo and not other DAW as @jms stated ?

This is highly concerning, one shouldn’t have to disable power saving features to make a particular software work, especially when using a desktop computer. In that case the issue comes from the software itself because it fails to report the load for proper EIST/Speed Shift operation and other power features.

2 Likes

Misleading or not, the fact remains from my experience that cubase is by far the most expensive DAW I own and has by far the worst performance. I need it for some features no other DAWS have but it’s still shocking to me how fragile it is considering how expensive it is.

3 Likes

FL Studio enables Windows’ High Performance power plan by default. IIRC Reason (the DAW) has always had not-so-great performance which might be preventing his processor from going into a deeper C-state, similar to when he disabled multiprocessing in Cubase. I’ve not used Ableton or Bitwig but those are of course going to have optimizations for live performance.

It’s not a requirement for the software to work, which is why this isn’t set by default. Many audio interfaces only require you to increase the buffer size to prevent audio dropouts in small projects.

For low latency work, it’s a common sense recommendation to either enable the High Performance power plan or perform the usual BIOS tweaks. And it’s not just for DAWs, Microsoft itself and various other companies provide basically the same recommendations for low latency networking.

Anyway, I think this thread has served its purpose for now, so I’ll be locking it. For general discussion about Cubase 12.0.30’s performance, please use this official topic: https://forums.steinberg.net/t/cubase-12-0-30-performance-issues/790361