Performance issues Cubase 12

I’ve got a pretty high end system AMD 3950X 32 thread 5Ghz 65GB RAM a dedicated SSD for plugin samples, a dedicated SSD for recorded audio, a 5GB/s OS drive, and an RTX 3080 running Cubase 12.

Only about 23 tracks in use that are running audio, all VST 3 plugins with the latest versions, all legit, with only 60 plugins currently active most of which are just EQ s, plus stock compressors, about 5-6 MBs and a few amp sims, which I’m even running in stereo on a group channel, so I can run two guitar tracks through each left and right to save on processing load, some instances of Slate trigger 2 and 5 Vsti’s which I’ve been bouncing down the audio and then switching off as soon as I’m happy with the part.

I’ve got ASIO Guard set to high, buffer size of 256 on a Scarlett Focusrite, with only about 20ms round trip latency, I’ve tried higher and lower buffer setting and it’s hard to tell if it’s making much difference tbh.

Steinberg Power Scheme on, Multi Processing on, 32bit float processing, 48Khz project with 32bit Wavs, and yet even with nothing playing I’m getting processing meter peaking out. I’m only using about 16% process power and and about 14GB of Ram, all latest drivers, etc. I’ve disabled 99% of background apps, and anything else I can turn off without risking core system integrity.

I remember running projects with far more plugins, and tracks than this on my old 3GZ Pentium duel core, with 4GB of ram, back in 2006 I’m really at a loss why my system is struggling so much.

Has anyone else been finding this kind of thing? I see people running way more on far lower spec systems with nowhere near the amount of peaking. Currently with nothing running ASIO guard is already sitting at 50-60%, and peak load and real time are almost at the same.

This is also a clean install a couple of months ago and I run a very clean system so I know Viruses, etc are not the issue.

1 Like

Guess no one’s got any clues then?

I there and welcome to the forums!

Have you tried disabling Simultaneous Multi-Threading (SMT) in BIOS? (I think that’s what it’s called on AMDs.)

Also, questions very similar to your are posted frequently on these forums and is likely a factor as to why you’re not getting any replies. I recommend you use the search function to see what has been suggested in similar cases.

1 Like

I’ve searched many of them, and all the one’s I’ve read seem to be solved by issues I’ve already ruled out, hence the detailed post. I’ll look for the AMD multi-thread thing though that’s not one I’ve seen before, I’ll post back if that solves it or not, thank you. :slight_smile:

it’s very hard to say if the performance you are seeing is ‘normal’ or not

Too many variables - I mean ‘a few amp sims’ could be crippling the system - or just one badly coded plugin.

What I would try is (do a save) and start pulling out plugins and instruments to see if there is one that is causing a particular problem.

I’m assuming you have no tracks ‘input montior’ - as this overides the ASIO guard.

RE: SMT (hyperthreading) - I leave it OFF on my, Intel, system - and in my tests it’s a marginal improvement at very low buffer sizes. Once you get over 64 samples the reduction in cores tends to be detrimental. AMD cpus respond very differently to SMT so who knows ? def worth a try.

Be aware that changing SMT settings may/will change the system ID and some stuff (like plugin alliance) will think it’s a new PC and require re-authorising.

Also look at any other ‘power saving’ things in the BIOS such as c-state and AMD cool and quiet, AMD turbo core - disable what you can.

FWIW 32bit float processing ‘might’ be robbing more CPU cycles than 64bit - worth trying both.

Ultimately you might be chasing a problem that doesn’t exist. You might just be running a very heavy project. I mean it’s only on 50% ASIO load so it still working. plus Focusrite drivers are never super efficient (IMO!)

Memory is a strange and imperfect thing - I have zero doubt that whatever ‘problems’ you are seeing with you current setup, it’s many times more powerful than your PC from 2006.

1 Like

I disabled SMT and saw no practical improvement.

“You might just be running a very heavy project.” - Well as I said that’s the big issue, it’s a fairly bare mix, less than half the plugins I’d typically run in a full mix, this is me still in the composing phase of the track, I’ve been pulling out plugins, nothing is standing out as a huge issue by itself, there are obviously one’s that are adding more load than others, but nothing that suddenly makes all the difference, simply the amounts added by each plugin are accumulating to a higher load way faster than they should IMO.

“I mean it’s only on 50% ASIO load so it still working” Not really, while the ASIO Guard is sitting at 50% currently that by no means implies I can run double the current load, as the load almost grow exponentially, and it only takes about 10% more processing to start glitching, or even completely overload and stop processing any audio at all.

In fact sometimes it doesn’t even need that, I can just one extra plugin, that I’ve already got several instances of on other tracks without issue, or even be adding more processing with the same plugins already active and that will push it over the edge.

“Focusrite drivers are never super efficient” - Any recommendations? I’d understood the Focusrite was a solid choice without getting into mid-to-high 4 digit territory, The focusrite is a new addition, but I’m sure it must more more efficient than the Ancient M-Audio Delta 10/10 and Line6 drivers I’d worked with in the past, that haven’t seen updates in many years.

But, I’ve spent thousands on upgrades over the last few months, and I’m very willing to spend on whatever is needed (within reason) if it solves the issue.

The thing that’s frustrating me is that as far as I can tell, I’m only using a fraction of the resources available so I’m not sure where the bottle neck is, is there simply an upper limit to how much ASIO processing can handle no matter how powerful the hardware is?

Newer versions of plugins adding more latency in the processing because of extra processing? Is that the issue?

I would have assumed the faster the machine the less sample latency each plugin would add, but maybe I’m just mistaken?

Have you tried running LatencyMon to see if anything out of the ordinary stands out?


It’s not totally clear to me that there is a problem with the PC ? Although I totally understand you are not happy with the performance you are getting on this specific project.

that’s just guesswork. The ASIO meter tells you differently.

No, there isn’t an upper limit as such, most especially at higher buffer sizes. ASIO performance does not scale linearly with cores and tends to be much more sensitive to CPU clock speed (ie speed is better than cores).

sometimes more, sometimes less - it depends on the plugins.

plugin latency is generally a fixed value for a specific plugin/sample rate - although some do vary their latency. Not an issue in your instance IMO

Have you tried one of the various benchmarking projects that seem to be floating around the internet ?Do you have access to the old computer that Pentium Dual core from 2007 ?
Do you have access to any other PC ?
Can you set up a dummy project loaded with lots of ‘stock’ plugins so you can compare ?

it’s always good to optimise but, personally, I’d want to know if there is actually a problem before trying to solve it. I’m not entirely sure there is a problem as yet.

and again - just checking - do you have any channels that have input monitor turned on (this disables ASIO guard) ?

1 Like

What motherboard? My ASUS has two different USB controllers. If you have similar you can try to switch USB sock to a other controller. Im not sure how much it can affect USB2 devices but there was some RME responses on their forum about different USB3 hosts and RME devices.

Yes, but it’s hard to tell if the reading I’m getting are even useful, I have got a message that my system may have problems when I do something like load a webpage, with the longest peak being 1400 from the nvidia driver, but if I run it while just Cubase is running, it says “Conclusion: Your system appears to be suitable for handling real-time audio and other tasks without dropouts.”
but Cubase can’t even start playback while it’s running as it just pushes the ASIO guard into the red nonstop even while most of the plugins disabled and only allows me to start playing again once LatancyMon is turned off.

Disabling things in the BIOS around CPU boosting actually seems to have made things far worse too.

MB: MSI X570-A PRO (MS-7C37)
Processor: Ryzen 9 5950X
4 x 16 GB (64GB) Corsair DDR4 2400MHz

From the manual:

AMD® X570 Chipset
ƒ 6x USB 3.2 Gen 1 (SuperSpeed USB) ports (2 Type-A
ports on the back panel, 4 ports available through the
internal USB 3.2 Gen 1 connectors)
ƒ 6x USB 2.0 (High-speed USB) ports (2 Type-A ports on
the back panel, 4 ports available through the internal
USB 2.0 connectors)
y AMD® Processor
ƒ 2x USB 3.2 Gen 2 (3rd Gen AMD Ryzen™) or USB 3.2
Gen1 (2nd Gen AMD Ryzen™/ Ryzen™ with Radeon™
Vega Graphics and 2nd Gen AMD Ryzen™ with Radeon™
Graphics) ports (1x Type-A & 1x Type-C) on the back
ƒ 2x USB 3.2 Gen1 (SuperSpeed USB) Type-A ports on the
back panel

It have two controllers. Have you tried both?

1 Like

Not really, as my system would be perfectly capable of leaving the current Cubase project open in the background, I could then go and open 3 different browser open with 100+ tabs, start a photoshop project several gig in size, start watching YouTube one one screen and then play a game with decent graphics on the other while they where all left open in the background.

Well that’s the thing, this processor has a much higher clock speed than my last, and double the cores, benchmarks put it at around 4-5 times the power overall, but it seems like in my case the exact opposite is happening, the higher I set my buffer size the worse the audio glitching is getting, which I feel like makes no sense.

Is that direct monitoring? If so no I don’t, my amp sim runs stand alone and that plays audio directly itself, but the issue exists if that’s closed too.

No I haven’t I’ll look, but do you have any recommendations for that?

Not currently no.

Maybe that would help? I’m running at 48Khz atm, maybe I should try a higher one.

Well I just loaded a project with 64 tracks and pulled in an mp3 drum track copied it across all of them and stacked each track with maximum allowed plugins including:

  • roomworks,
  • limiter,
  • studio eq,
  • compressor,
  • tube compressor,
  • multiband compressor,
  • stereo enhancer,
  • dither,
  • chorus
  • and VST bass amp.

1024 plugins total, plus 3 stock VSTis and it runs completely fine with the ASIO meter barely hitting 10% in idol and running below 50% during playback.

I then Added 4 of the third party plugins with the biggest impact to each channel along with the stock ones,

  • Fabfilter MB,
  • Fabfilter Limiter,
  • GullFoss,
  • and STL Amp Sim
    That got up to 40 tracks, before it started running into issues, but that’s 160 of third party plugins plus 400 stock plugins, which is over 10 times the amount of plugins I was running into issues with on the other project.

So yeah I guess I’m a little confused now what it could be.

but that’s nothing to do with ‘real time’ ASIO load in that particular project ?


but your issue is not latency - it’s ASIO load - so why would a higher sample rate help ?

as I keep saying - I’m not sure you have a problem with your system

not quite sure how many times I need to repeat it ?

actually I’m actually fairly convinced you don’t have a PC problem - it’s your project that is resource hungry. I’ve gave you some pointer on why that might be in my first post :slight_smile:

Because you’re not really making much sense you’re saying there’s no limit on the ASIO as long as you have a powerful enough system, but then saying ASIO processing is separate from my machines power. You say clock cycles matter, and what I was pointing out is that I’ve got plenty of extra room in the clock cycles to do a dozen other high resource things while Cubase is having issues in the background and using those same resources, and yes those things have an impact on ASIO because I can see running a video in the background for example shows a significant impact on the ASIO meter.

And as I keep repeating it’s not, it’s got 23 tracks with events on and 90% of the processing is being done at the group level to save on resources, so there’s only about 12 tracks with active plugins on them and only 1 - 5 per track, most of them stock, or none at all as I’ve bounced down the processing to save on resources, I’m still in the composition phase and so there’s not even much audio it’s like a few bounced down synth parts and guitar and bass, with midi drums.

No I haven’t, I’ll give it a go

Luke, I think we are going around in circles :slight_smile:
sorry if it isn’t making sense to you - I said :

but obviously there is a limit on ASIO 'power ’ on a specific system - you don’t have and infinite power PC ! As clock cycles increase and cores grow exponentially then ASIO performance will increase. There is no hard limit to it.

You say “I’ve plenty of extra room in the clock cycle” - but CPU load IS NOT ASIO LOAD ! - you’ve even observed this yourself.

regardless - you have proven that your PC is capable of running a very heavy test project without any problem whatsoever . Even though you said you didn’t understand it. You have a project that is hammering your ASIO meter - and yet you maintain it’s a ‘light’ project even though all the metering tells you different.

It seems you are judging your ‘heavy’ project by just looking at it rather than the ‘facts’ - There are some Kontakt instruments that if you load them with a 32 sample buffer will kill the ASIO performance. That’s a SINGLE PLUGIN.

one last time asking - do you have “input monitor” enabled on any of your tracks ?
number 1 on this page:

just quoting this again.

you have proven your system has lots of power

That’s what I meant, no never use it. Sorry thought I’d already answered that.

I apologise we seem to be talking past each other in some way, I guess my frustration is you keep going back to it being the plugins and the buffer size, but my test demonstrated that the plugins and buffer size I’m using aren’t the issue.

Why are just 15 instances of the exact same third party plugins overloading the ASIO even with a 1024 buffer while idle on one project with a hand full of sparsely place audio, when another can manager glitch free playback running 160 of them + 400 stock across double the tracks with continuous audio input completely fine on a buffer of just 128?

I even got up to 192 + 832 stock over 64 tracks without the amp sim.

If I can run over 10 times the amount of the all the same plugins, with a smaller buffer size, it must be something else, so can you suggest something else that might be causing such an insane difference in performance?

I never said it was the buffer size ?

you never use it - how do you input midi or audio ?