Performance Issues Cubase 8.5 vs Cubase 8.0.3

Hey guys, I am troubled by the bad performance of Cubase 8.5. I dissabled Asio Guard but still my projects run way more stable and smoother in Cubase 8.0.3. The asio meter is around 30 % lower. I hope there comes a bug fix soon. Performance is everything!!!


I highly doubt that it is “a bug” with 8.5 as I see the exact opposite on my system.

I had extremely poor performance (~10 Tracks) on the previous CubasePRO 8.0.30 (Win7 64)
and really excellent performance (100+ tracks!) on the new CubasePRO 8.5 (Win10pro 64) both on the same PC.

I upgraded my PC to Windows 10 using the Free Microsoft update (process was painless and perfect!)
Only issue an error message for the eLicenser.
All that was needed was to launch the eLicenser Control Center using right-click and “Run As Administrator” and perform maintenance (just the one time only and not every time since)

Do you know for certain what exactly fixed your issue? Was it windows 10 that did it? Did you try Cubase 8.5 on Windows 7 first? Or did you try Cubase 8.5 on Windows 7 first? I tried 8.5 on my system running Windows 7 64bit and it was exactly as bad as Cubase 8.0.3: Unusably slow.

I think its because you disabled Asio Guard, you should enable it, set it to normal and check your buffer size to make sure its not too low.

I am using Windows 8.1 - 64 bit. Will windows 10 improve the overall system performance? I am still happy with my 8.0.3 performance, but as I descriped before the asio peaks are around 30 percent higher on Cubase 8.5, running it on the exact same system, using the exact same plugins.

I also have performance issues since upgrading to 8.5… (Windows 7 64bit, ASIO Guard on or off no difference)
ASIO peaks are 10% higher maybe, but my main problem is editing the tempo track. It used to be smooth in 8.0.3 but now it’s slow as hell and lags like a beast and performs poorly. I can’t draw in a new tempo with 2fps…
And editing multiple tracks in the MIDI editor is also performing at half the speed it used to … :frowning:

I tried different settings, but the problem stays the same. I switched back using Cubase 8. I regret purchasing the update. Performance beats every new feature. Sorry Steinberg.

I’m with you there! €50 as a Student isn’t a small amount, and I never expected a .5 update to drastically hit performance so much. I really hope Steinberg will fix this in an upcoming version; sadly I don’t know if Windows 10 improves on this.

just upped to win 10 and cubase 8.5 no probs mixing 42 tracks with inserts and groups comp 8 years old ? asus p5b, dual core e 6300 @1.6 nvidia 8500 gt 4 gig ram alesis i/o 26 firewire latency 256 not top spec by any means.

And what about iLok2 issue on Windows 10 ?

I’m having a real struggle with Kontakt since upgrading to 8.5. I can’t run any more than 5 instances without the bridge quitting on me (each Kontakt instance is only runung 20-25Mb each), requires a complete computer power cycle to fix - this is on a 32Gb machine. I never had this problem with 8.0.3.

Bridge ?
Stop using 32bit plugins.
You should check the plugins, and make sure that you are using 64bit version of kontakt.

Only version I have installed of all my NI stuff is 64bit.

I was having the same problem - major performance issues when adding or editing tempo track events…but I think I’ve solved it! Well, at least on my end.

Try this:
Open your project, go to Project menu > Project Setup. Change the display format to “Seconds”. Click okay. Now, if you want “beats + bars”, right click on the ruler in your project window and pick beats + bars. But, for whatever reason, when the project setup has the default display format set to “beats + bars” major performance problems. As soon as it’s set to “seconds”, everything works fine… It’s the same for the display in the Transport. Displaying beats + bars causes problems. Seconds, totally fine.

With any luck that will work for you too… it’s a complete workflow saver here.