Performance Meter Average picking to 99% with very few Fx plugins

I have several projects in Cubase with Windows 10. One project has about 27 plugins and it takes almost 90% of the “Performance Meter Average” with 17% real CPU.
It makes impossible to work with medium - big projects. I have buffer to 2048 samples at 44.1 Khz. I have ASIO Guard enabled with multi processor also enabled. My PC is brand new i7 - 10th with 8 cores at 2.90 Ghz, SSD disk and 32 Gb RAM. I have tried the same project with the same plugins in Reaper and it only takes 5% of resources with 11% real CPU.

I use a brand new Audient ID4 Mk2.

I cannot believe this is almos useless for mixing or even producing.

1 Like

Thanks for sharing.

Don’t you think it might be appropriate to mention your audio interface?

Are you looking for help, or just on a rant?

1 Like

Just mentioned the interface is brand new (2 weeks). I need help. I am waiting for Steinberg response but I know it can take months.

Seems unlikely to be Cubase although odd that reaper is ok. You could do with running latencyMon which can highlight where the problem lies.

Your setup is real good. Audient interface has a very low latency. So it should not be a problem, please try lowering your buffer size, I have tried as low as 1024 or even 512 some times on my mac with this same interface. Or you can run the self test in the audio interface control panel (audio/devices setup, in Cubase) Audient sets up the optimum buffer it sees fit. You can try the nearby ranges. (going a bit + or minus) Also try to disable asio guard. (with audient you won’t need it). Hope it helps.

Thanks for editing your post to include the interface.

Have you selected the proper ASIO driver in Cubase? Just making sure to eliminate the obvious.

What plugins do you use?
I’m working now in W10 19xx, and in Cubase Performance (F12) its almost same as in Windows, but for this result, i check every project for “bad” plugins, and find low resource alternative.
Also, background process, my W10, is tweaked ALOT. i cut everything what i can cut from System, (Windows update, Windows security - i didn’t use antivirus, METRO Apps, and so on.)

Also - drivers, its very big deal.
Try also same project on Internal sound (realtek with asio4all)
Steinberg Power Scheme
Also BIOS, its very important to find right settings to get max performance

You should be able to get way below the buffers mention on this thread with your pc. On my old 960 i7 I run at 64 sample buffers on my rme interface for a small project. On my i9 9900k I can run at 64 samples for a big project. Yours should be closer to my i9 without glitches. What is the video card?

You haven’t got any CPU intensive plugins running in Control Room by mistake have you?

Just an update. During this weekend I have tried several things with NO sucess.

1.- Uninstall completelly my graphic card drivers in Windows safe mode (Nvidia Gforce). Reinstall only drivers without utilities.
2.- Reinstall soundcard drivers.
3.- Try with Asio4all.
4.- Try with other sound cards.
5.- Delete Cubase preferences and start fresh new.
6.- Try with Cubase 11 and 10.5 both fresh preferences.
7.- Of course try with any combination of: Steinberg Audio Power Scheme, Audio Priority, Asio guard, Buffers …

Nothing has fixed the problem.

I made the test again with Reaper and at 48kHz it takes only 4.2% of the resorces at 9% real cpu.

The plugins I am using are just pliggins like Plugin Alliance or Ik Multimedia. It does not matter because the same plugins and the same processors in the Control Room Reaper handles it perfectly at less than 5% of resources.

Have you run latencyMon?

Yest I have run Latencymon with negative results but honestly this does not help as it does not tell me how to fix the “possible” issue. It speaks in a language that I do not understand. I am not Systems engineer.

Why don’t you try starting Cubase in safe mode with the plugins turned off. If the cpu comes down to normal there is a plugin issue somewhere. It can happen that a new system reacts differently to some plugins, it has happened to me when I bought a new computer at the beginning of the year. I can see that you are not having issues with Reaper but Cubase is a much more complex piece of software.

Hi, just wondering if you have any plugins inserted on your stereo out, this will affect Cubase performance whilst recording


If latency mon says you should be ok for audio then not sure what else you can do apart from what others suggest.

Lower the buffer size, as others have suggested.
Your large buffer size is killing your CPU.

From my own experience Reaper is horrible to use.
Try Studio One trial for free and see how it performs.

look here everything is explained
tweak glitchfree pdf


Where are your working files located? Make sure that your antivirus program does not scan your working files each time they are accessed.

Let me guess, Task Manager shows no issues with RAM, hard-disk, or CPU but Cubase is bogged down and the little meter for “hard-disk” keeps peaking?
This is the only issue that has ever made me think of switching away from Nuendo. To save you some time:

  • Nope. None of the common sense solutions everyone is giving you are likely to work.
  • Steinberg won’t get back to you in a reasonable amount of time and they won’t have the answer to your problem. They’ll suggest all the stuff everyone else is mentioning. As for their expedience, I’ve been waiting for a response for them to approve my crossgrade from Adobe Audition to SpectraLayers 7 Pro for however many MONTHS its been since SL7 came out (who makes a customer wait to give them money? Seriously).
    I’m running Nuendo 11 with a Ryzen 5 3600x (upgrading to the latest 9 this summer :wink: ), 72GB RAM, Win 10 Pro x64. A year ago when I was on Nuendo 10 and the CPU was still hot $#!+, I was still having the same issue you’re having now. I’ve had the same problem as far back as Nuendo 4 (maybe longer).
    The issue has ONLY existed in Nuendo. I’ve created identical sessions in all of my DAWs to see if I can replicate the issue somewhere else in an attempt to find the source of the problem. Reason Suite, MixBus32C, StudioOne, Acid Pro Suite, Audition… not even an anemic piece of trash like FL Studio have given the same problem. The issue is within Nuendo/Cubase itself and its been an issue for waaaaaaay too long.
    My solution only came after upgrading all the way to a true professional rig (I own DMP Recording Studios), well over $100,000 later. Even then, its not really a solution, more of a work-around, which was switching from a single desktop to a network of remote storage servers and servers in which their sole purpose is to offload processing.

** Just for clarity: The control-room PC is not $100k+ lol, I was referring to the overall studio upgrades (custom hybrid console, more mics, software, hardware, custom cables, monitors, etc.) because I can’t say for certain at what point the hard-disk peaking stopped being a problem.