Performance Spikes with 256 buffer and only one VST Plugin loaded

Hi all I think i need some help!

I have noticed that my system is rather heavy on CPU/performance.

I am simply trying to play live an arturia plugin on a midi keyboard, with it loaded as a plugin into Cubase 11. I have selected 256 buffer size (on my interface) as any higher and the latency is too disruptive. I’ve optimised cubase as much as possible with online guides.

I’m continually getting spikes on the ‘maximum’ cubase performance meter and the windows resource moniter is telling me cubase is using 0-10% fluctuating. Is this normal? Seems crazy given it’s only one plugin loaded ito an empty project (no other audio channels etc) and this laptop is supposed to be quite powerful. I have tried increasing buffer size to 512 and 1024 and the spiking stops - but the latency is too long for live playback.

Can anyone suggest what could be happening? See below all info and current settings.

Any help would be greatly appreciated.

VIDEO link here showing the meter spiking frenzy (at 256 buffer)…

Pic of studio setup…

Thanks
Ross

System Info
Dell Precision 5530 PC laptop running windows 11 Pro 22000.613
Intel(R) Core™ i9-8950HK CPU @ 2.90GHz 2.90 GHz
RAM - 32.0 GB (31.7 GB usable)
Penty of free space on HD which is 1TB
DAW - Cubase version - Cubase 11.0.4.0
Audio Interface - Focusrite Claret 4pre USB (connected via USB C)

Cubase Settings
Optimisation settings already turned on include
Activate multi-processing’ ticked
Activate ASIO guard - ticked
Activaye steinberg power scheme - ticked (guard level normal)

Details of Setup example described above
Example VST plugin loaded into Cubase - Arturia ‘Piano V2’ - (v2.6.0.3815)
Buffer size - 256 (which I feel is the maximum before I notice latency badly)
CPU - fluctuating up to 10% is being taken up by Cubase which seems like a lot for just one plugin and nothing else
‘maximum’ cubase performance meter is continualy spiking / peaking.
The peaking occurs at random and still happen even when I’m not playing anything

Have you checked on the DPC latency of your system?
https://www.sweetwater.com/sweetcare/articles/solving-dpc-latency-issues/

1 Like

Thanks Sparqee,

No I hadn’t tried it. I just installed the home edition and gave it a go. I got an error when i had it running in conjunction with Cubase. But it mentioned power throttling - but I really don’t seem to have any power throttling acrivated - i’m using a high power plan setting.

Perhaps it’s the direct X graphic kernel? see screenshot after 10mins running it

Ross

Checking DPC Latency is always the best place to start, but chasing Cubase Performance spikes can be a very long and frustrating process. It could be anything or nothing… In the past I’ve solve a few weird issues with LatencyMon ex: Cubase Performance Monitor randomly going into the red from Network spikes or hits from a USB connection. In both cases I just needed to update drivers (network card driver, and a USB wireless keyboard/mouse dongle driver). Other times I found nothing after hours of troubleshooting. I’ve learned to just accept that the Cubase Performance Monitor will spike every so often even in small projects when nothing is in playback.

But… with your system Specs running a buffer at 256 does seem odd. Try deactivating ASIO-Guard and change “Audio Priority” to “Boost” (that will give priority to Cubase over background tasks like Windows update processing). And any changes you do, make sure to do them one at a time.

Hope this helps.

x.

this could be a real tough one to solve. This reminds me of a laptop I tried to fix for a friend, it was impossible of my skill level.
For starters, I would disable anything with “live” monitoring of your systems like antivirus, anti-spyware, or similar stuff like ram/os cleaner. Then I would unplug everything from my laptop including the soundcard. Then continue step by step - disable wifi, Bluetooth, and so on. Even change graphic card drivers from brand specific drivers to the Microsoft default

Also try the Ultimate performance plan in your power plan settings

from what I remember ACPI.sys is a virtual device that controls how Windows control power options. my computer skills are at best medium, but from what I have learned is that once you have a laptop like this it is hard to fix latency as most laptops have locked bios and very few options to experiment with.

best of luck on your hunt for better latency, hopefully, some of this can help you on your way

Update - I also just installed Throttlestop and disabled the Dell throttlestopping built into the BIOS
My problem persists.

hey there
Yes i think the spikes are just a sympton of the unlying problem of the system for some reason not having enough resource for stuff that shouldn’t be so resource hungry.
I tried disabling ASIO guard and selecting Boost but no change - spikes and buffer trouble still as before.

Maybe it’s just this laptop!?

Thanks

Ross

Hi Glen, thanks for the tips.

I don’t have the ultimate power plan option strangely - I have only ‘Balanced’ & ‘Steinberg’ - see screenshot. I think the Steinberg plan is meant to give ultimate performance - seems that way when looking through the settings. See screenshot. The settings for the Steinberg power plan are all maximum etc…

I turned of wifi an bluetooth and there’s no change. I had windows firewall defender running in the background - taking up about 1% CPU. I switched that off and still no change to the Cubase performance meter.

btw I also lowered the buffer (with the same example setup descibed above) to 64. Now Cubase is taking 20% CPU when not playing the keyboard. When I play the keyboard it goes up to 40%. Crazy times!

I just feel like this laptop is cursed and I should get a new one. Dell Precision? - more like Dell Precisely Not Nice!

I also installed ‘throttle stop’ which is meant to turn off the power throttling function built into Dell laptops. That didn’t help.

Thanks

R

Hi
You have an I9 computer which should be superior to my I7 computer.
I also have 32 gig ram.
I have no real problems at all with my machine.
I have a first generation Focusrite 6i6 box.
I had done all performance tweaks for my machine and put it on HI PEFORMANCE in power options.
Also running at 256 and on 48 khz and the same settings in Studio setup
Your latency Mon is way over the top as my machine just makes one of those little box divisions or just a little over.
I can only say check the focusrite driver as i had a problem once until they had an update for the first gens. .
If no luck contact Focusrite and they maybe can help.
I contacted them about a problem and gave them remote and they sorted me out when i was struggling to set the box up…
Your machine should be running a power station.

All the best
John

In my somewhat limited experience with laptops and what I have gathered from friends and colleagues, my biased conclusion is—if you buy a consumer laptop for the purpose of running a DAW on it, you are buying a lottery ticket. I have seen several laptops with amazing specs on paper but are struggling to handle real time audio. I bought a top of the line Lenovo Thinkpad a few years back myself, mistakenly expecting IBM quality and thinking I could use it for light DAW stuff when on the road etc., I can’t even remember how many times a re-installed Windows (plus all other software) to try and get rid of frequent BSODs and lower than expected performance.
I guess what I am trying to say is, CPU and the amount of RAM are not conclusive measurements on how well it will handle live audio. This is true with all computers but laptops especially seem to be a crapshoot. YMMV.

1 Like

in command prompt run this command to enable ultimate:
powercfg -duplicatescheme e9a42b02-d5df-448d-aa00-03f14749eb61

but like I said, pc laptops either work decent or aren’t usable at all in my experience. I had a Dell XPS once upon a time, rock solid. now I have a relatively cheap budget Asus 13" which works just fine for recording and starting projects when I am out of the studio. I don’t even need to turn off wifi or Bluetooth to use it. Very happy! When I bought it of course the first thing I did was install latency mon to see if the laptop would pass the test - if not it would have been returned :wink:

If you do a quick search across the forums, going back years, you can find many threads with users seeing similar problems, including a large megathread about this created by steinberg themselves. I think there may be similar threads for older versions of cubase, but the base issue and behavior are the same.
https://forums.steinberg.net/t/cubase-12-0-20-performance-issues/

Have you tried 1) disabling all virtual cores (hyperthreading) in your BIOS, 2) disabling ALL CPU power management (p-states, speedstep, etc), and 3) locking your CPU to its highest rated speed?

Try this, and then try C11 (or C12, or C10, or C9) again with ASIO on or off, depending on where you see the best results. Do you still hear/see the internal ASIO overload and hear the audio pops/glitches/dropouts?

I have been tracking this issue across 3 PCs/laptops, and across cubase versions since 10.
I am also aware that hyperthreading has caused problems on cubase since the early 2000s, when the Core2Duo first rolled out. I have seen IDENTICAL problems with ASIO overload on any Intel / Windows 7 or 10 PC or laptop I have built, and with every current(10, 10.5, 11, 12, 12.0.20) version of cubase.

The ONLY way I have been able to reduce this behavior has been the above config (disabling all power management, and on 2 platforms, I had to totally disable hyperthreading).

Right now, on my fully updated x299-based win10 platform (i7 7800x CPU, 32GB RAM, focusrite 8i6 gen3 interface) the magic formula is:
-disable all power management
-lock CPU at max clock speed
-enable hyperthreading
-ASIO Guard set to normal
This results in MOST of the ASIO overloads stopping. I will occasionally still see random spikes to 100% with an audible pop/click, and when this happens Ive learned I can toggle my audio interface buffer to anything, from anything, and that overload does not come back for that session. I have no idea why, but it works 100% of the time for many months. It may be that resetting the audio interface is the trick and has nothing to do with buffer.

On my other systems (2018 MSI laptop with an intel i5, also an older 2008 x58 chipset desktop with an intel 965 extreme CPU), I have to fully disable hyperthreading to avoid ASIO overloads. I spent many hours troubleshooting other configs and settled on:
-all virtual cores disabled
-power management on/off doesnt matter as long as HT disabled.
-turbo or speedstep, also on/off doesnt matter as long as HT disabled.
-ASIO guard OFF (turning it on adds massive latency and isnt fixing anything)

Ive read these forums and the posts about this issue for years, and I can count on the fact that any time I visit them again, after any length of time away, people are posting about the same issue and struggling with the same troubleshooting and configuration testing to get it to work. I am solidly of the opinion that this QA work should be done by steinberg, should have been done long ago, and a SUPPORTED + UNSUPPORTED hardware and software list should have been created. This is endlessly frustrating to me.

I hope something works.

Thanks a lot John

Just so I’m clear - when yo urun latency mon you’re only getting one green box segment for all 4 rows / readings?

I’ve sent my issue to Focusrite in case they can help

Thanks

R

Hi Glen - thanks a lot

Alas that run code you sent didn’t add a power plan - it only deleted my ‘steinberg plan’. I found lots of threads with different ways to reveal the ‘high performance’ plan (including editing Regedit) - but none of the fixes seem applicable to my version of windows.

I’ve noticed that in Windows/Settings (which appears to be a newer version of the control panel - feels like a design conflict) - there’s the option (under System/Power/Power Mode) to change the mode to ‘Best Performance’, which I’m able to select.

Going back to the control panel however - I’m still on the ‘Balanced Power’ option. Confusing.

Feels like two departments at Microsoft didn’t communicate with each other when they designed Windows 11.

R

Hi Ross

Yes , really one ,two or three segments at the most on Latency mon.
I do get quite a few page faults when starting up a plugin but that is from what i read about is nothing to worry about. Just ignore that as it causes no glitches and once a plugin is open it stays put. It . It is a very touchy tech thing that tries to frighten the life out of you.
I made sure my power options are on HIGH PERFORMANCE. Update Graphic card,is important.
My last Nvidia Update messed the colours up and had to run my system image to get back to the last best working order and kept it at that , but since then it has been updated in May this year and this one is 100%
Yes, i have had a few headaches, but there is always a fix when you dont panic.
I got rid of Norton Anti-virus and Utilities and replaced that with the Windows defender and AVG Tune up.
This seems to work for me as you can put unnecessary programs to sleep and still get rid of junk files. Maybe worth putting Malwarebytes free in to check once in a while but no more than that.

All in all i have my I7, 32gig ram machine working fast.
Once happy Make sure you make a system image. I have two copies just in case one fails
Worth the money for a Couple of terrabyte USB drives which saves you a lot of headaches .
Focusrite drivers have been updated this month for win 10 and 11.
They work perfectly well on my First gen 6i6.

With a Windows desktop, at least you can change peripherals & drivers until it works. With a Windows laptop that’s much harder.
There are plenty of ‘hi end’ Windows laptops that will not work for time-critical stuff like a DAW.

2 Likes

Thanks John

Yeah I’ve seemingly gone through every optimisation troubleshooting / settings changes / updates under the sun and they have had had zero effect on the DPC latency.

I thnk this laptop is a dud. I’m going to move on and buy a new machine.

Ross

If you haven’t please try disabling Hyperthreading AND changing the system performance from “ background services ” to “ programs ”. I got around 10% difference on vst performance meter.

I’ve tried again in the past disabling the HT option alone but there was no difference, so I suggest you give it a try doing both and hopefully it will help.

2 Likes

Hi Ross
If you want to really get down and make music a laptop is really not the way.
Go for a Tower produced specially and built for musc production.
Spend about £1 500 to £2000 and have 32gig ram.
My machine was built by PC specialists in UK and if built ,pick the machine up yourself by arrangement.
I do not trust parcel carriers as i have seen what they do…
A Laptop would be great for doing little bits and pieces whilst travelling or on holiday maybe.
I personally do not like todays music as it is dire in my view. 60s,70s and 80s for me.
Just look at the Queens Jubilee concert, all rappers and moo singers. Even the guy who stood in for Freddie Murcury was dire. I think the Euro vision guy was the best and he sounded like Murcury or near as it could be.
The Standards of music is going downhill to Pepper Piggy proportions. Mass junk.
I say produce electronic music that is melodic and tells a story or rock and pop like it was ,nice and happy.
Being 70 now i wanna still rock!!! and playing actual music is great.
Hope you get the right machine.
Anyone out there who has Korg Wavestate get Sample Robot if you like to get great samples easily.

All the Best
John

2 Likes

I echo that, I also have a stellar computer from PC specialists and their prices are extremely reasonable for what they offer…

1 Like