"permission denied" error and "error opening file:invalid file format"

Hi,

I’m getting the above errors on two different projects, which obviously aren’t opening at all.

We’ve been installing a fresh Dorico install on some new Mac minis within the department. These original compositions were created on our existing Macbook Pros. They were then opened on our new machines and then saved. After re-opening them on any of our machines, we are faced with these errors. We’re not sure what is causing the problem.

Could I upload them for you to have a look please?

Thanks
Tony

If they’re smaller than 2MB when zipped up, you can upload them as an attachment to a reply to this thread. If they’re too big, you could send them via WeTransfer.com to me at d dot spreadbury at steinberg dot de and I’ll take a look. There may be only a limited amount I can do over the weekend, unfortunately, as it may well require the skills and talents of the developers.

Thanks for your reply. Please find attached

Thanks
Tony
TSANG-Composition v2.zip (1.12 MB)
GRASSBY viola piece.zip (1.38 MB)

Thanks for attaching these files, Tony. Dorico projects use zip compression, and the zip files for these projects are both corrupted. So the question remains: how did this happen?

Can you tell us something about the Macs in your department? Are they all the same configuration? What operating system(s) are they running? Are files saved locally or onto the network? If locally, are they saved onto an internal or external drive? If on the network, what network protocol are you using to connect to the network volumes (e.g. Samba? AFS? something else?), and what operating system is the network storage running? What filesystem is the network storage using? Finally, how were the files copied from one machine to another? Were they transported on a USB flash drive, or similar? If so, what filesystem is the USB flash drive using?

Can you open other projects without problems? E.g. if you create a new project, save it, close it, and reopen it, does that work? Try opening one of the Dorico example projects (from /Users/Shared/Dorico Example Projects), and then doing Save As to save it somewhere else, then close and reopen it again: does that work?

The peculiar thing about these projects is that although the zip files are too corrupted for Dorico to be able to open them, macOS seems to be able to recover them OK. See if you can do the following:

  1. Change the file extension of one of the corrupted projects from .dorico to .zip. Answer in the affirmative when asked if you want to proceed.
  2. Double-click the new .zip file to uncompress it.
  3. You will end up with a folder called e.g. ‘GRASSBY viola piece’, inside which are two files (score.dtn and scorelibrary.dtn) and two folders (META-INF and supplementary_data). In the Finder, select these two files and two folders directly, not the parent folder.
  4. Right-click on the selected files and folders and choose Compress 4 items from the context menu.
  5. Change the filename of the resulting ‘Archive.zip’ file to e.g. ‘test.dorico’. Again, answer in the affirmative when asked if you want to change the file extension.

Now try opening the test.dorico file you ended up with in step 5 on your Macs. You should find that it opens as expected.

Hopefully with some answers to the questions above we’ll be able to get to the bottom of this problem.

Hi Daniel,

Your method DID indeed fix the corrupted files. Thanks for this!!!

We have a bank of Macbook pros 2012 all running sierra 10.12.2. These were the original machines we were running Dorico om. We’ve recently bought some Mac minis which are running the exact same software. They are all cloned, so should be the same software wise. The only difference in this case was that the full soundpacks were not installed on the Mac minis at the time.

The students save their projects to a shared folder that everyone has access too. They also open directly from this area too, so they weren’t copied to anywhere externally. They connecting to a Windows server 2012 R2 share on NTFS via cifs://

I will try opening and saving some other projects to see if I can emulate the problem…

Thanks for explaining your setup, Tony. Is it possible that two students both had the same project open at the same time on different machines and were trying to save different versions into the folder? In theory that should work fine, because the way it actually works is that the project(s) you’re working on are kept unzipped in the local machine’s temporary folder, and only when you save is the file re-zipped and then saved to the final location, and I would assume that the network file system won’t allow write access to a file that another computer is also writing simultaneously, so it’s hard to see how this could cause the kind of corruption you were seeing.

Please do let me know if you encounter this problem again, and if so, if you can think of any specific details of the circumstances when the problem occurred that could be significant in helping us to track this down.

Hi Daniel,

Each student had only their own file open so they hadn’t been sharing their projects.

We had the same problem on Friday. A Dorico file was created on a Teacher’s PC and then copied to the shared area. A student then opened this file on one of our Mac Minis directly form the shared area. They then saved and closed Dorico down. When reopening the file, the same error came up. The problem was then fixed using your method.

I can only assume it’s a problem when working directly from the networked area.

We’ve now advised out students to copy their work locally to work on. When finished they copy their work back over to the networked area. We haven’t had any problems yet, but I’ll keep you posted.

Thanks

Thanks for updating me on this issue, Tony. It’s very peculiar. If it happens again, please send us whatever files you have to hand, ideally including the ones saved on each computer as well as the ones put back into the network area.

Hi Daniel

OK this did NOT work for me. Same problem. Dragged all my 3.0 files onto an external drive from my MacBook Pro Sierra. Hooked the drive up to my new MacBook 2020 Big Sur with Dorico 3.5 installed, Put them in the dorico projects folder. .All my other files seem ok. Just this one file is corrupted. It opens ok, I can edit, etc. But I keep getting that permissions message…

If you want to send that file to me (either attach it here, or send it to me in a private message, or by email) I can take a look and see if there’s anything peculiar about the project.

NEW TRAIN.dorico (2.9 MB)

That project opens up OK for me. Could you provide the exact wording of the error you’re receiving, and at what point it appears?

it opens fine as I said. And I can edit, save, but every few moments I get this:

we can also continue this over email if it’s easier. I’m at boom@bobbyprevite.com

thanks Daniel

Bobby

This isn’t anything to do with the file itself. It’s to do with copying the contents of ~/Library/Application Data/Steinberg from one computer to another.

It’s either that the path contains a username that doesn’t exist on the new machine, or it’s that it’s trying to save to a “Dorico 3” folder rather than a “Dorico 3.5” folder - this is something that typically only happens on a computer that previously had Dorico 3.

The quickest way is to delete the folder. The less destructive way is to manually edit whichever XML file in which the AutoSave path is stored. I cant remember which one it is off the top of my head, but it’s definitely come up before.

Edit: it’s preferences.xml
If you delete it you’ll lose basically everything you’d previously set in the Preferences dialog but not e.g. default Engraving/Layout/Notation/Playback Options - Dorico will then recreate it with the correct path the next time you launch. It’s pretty quick to just edit the AutoSave path in that file, though, with Dorico closed.

delete which folder?

do I drag all the projects out of the folder and then delete the folder, then put them back in a new folder?

No. From a Finder window, go to the Go menu, then Go to Folder (it’s something like that). Then type or paste in ~/Library/Application Support/Steinberg/Dorico 3.5 and hit Enter.

Then in that folder you’ll find a file called preferences.xml.
Delete it if you don’t mind losing your application preferences (which govern things like duration before pitch or pitch before duration, any custom background colours you may have defined etc.), or edit it in a good text editor so that it shows the correct AutoSave path.

Moving your Dorico projects won’t have any effect whatsoever. At least, this is the first thing to try. As far as I’ve ever been able to tell, the AutoSave path is a global preference, not tied to individual projects.

OK I THINK that worked. I have it open and so far no message.

Thank you for all your hard work. I moved over from Sibelius, followed you guys. I despise AVID but I miss Sibelius of course because it’s so old there were many things it could do, especially graphic score-wise, that you haven’t gotten to yet with your young program. I’m sure you will, I look forward to your innovations. I’ll try to keep plugging away at it.
Bobby Previte

1 Like

I’m just a user. Welcome, though!