Persistent MIDI Latency Issue

There is a very slight but consistent delay between the moment I press a key on my midi controller and the record of the note in Cubase. I can’t find the source of the problem. The result is that it’s impossible for me to play properly in sync with the metronome - every note is delayed by a small fraction of a beat. Note: it sounds good while recording, but the recording itself is what’s off, which can be seen visually during the performance and heard afterward during playback. Auto Quantize is Off. If If turned on, recording is delayed for a beat or two and the beginning of my performance gets squished together.

I use Cubase Artist 6.5. I’m running a small Alesis keyboard into my PC’s USB. It is installed as a GM Device in the Midi Device Manager. For my ASIO Driver I’ve selected Firebox ASIO (I use a Presonus Firebox for recording audio). The Input Latency is 5.6ms and the Output Latency is 9.5ms (which I think it acceptable, please correct me if wrong). I have my Firebox’s latency set to 4.0ms. I could drop it to 3 or 2.0 in my Firebox control panel, but neither causes a drop in the latency values in Cubase.

This happens regardless of the VST instrument being used: HAL Sonic SE, Groove Agent, etc.

I’m also using Windows XP. I suspect that this may be an issue with my OS’s routing of MIDI data through USB to Cubase, but it’s only a guess and I don’t know what to do about it if I’m right.

Does anyone have experience solving this problem? Do any of these particulars stick out as negative to anybody? If I’m missing necessary information here please let me know and I’ll be glad to be as specific as necessary. This is beginning to drive me crazy. :neutral_face:

Thanks!

There was/ is recently a huge topic (and some) on this issue:
http://www.steinberg.net/forum/viewtopic.php?f=19&t=20516

Does it look like this ???
http://www.freeimagehosting.net/qw6ry
(btw this is my audio/midi sync test)

I have notice it painstakingly also.

It’s a nightmare for any Midi-Performance players.

PLS FIX SB!!!

One thing to try. After starting Cubase, disconnect the usb keyboard and then reconnect.
Pity you’re using XP as you could contact support about this but they don’t support XP.

Your latencies look fine.
You could also try starting XP in safe mode and see if Cubase behaves the same way there. Use a new Project so as not to mess up any existing material.

Q: Have you tried using the ‘midi out’ of the keyboard to control the midi function instead of the USB?

I have only recently picked up a Keyboard and I am using the midi out connection with some M-Audio driver for Win7. It seems to be working fine in play-along mode but I have not recorded it so I could be just like you. I will try this right now.

Are the other complaints about the USB driven or the midi out driven midi recording process? Both?

OK, back to say I just tried recording using the ‘midi out’ function of my keyboard and it kept perfect time on playback. So maybe it’s the USB function causing the midi error, is that possible?

Could well be. I forget the midi chip specifically (Texas Instruments? Or was that the goodie?) but a while ago there were problems with some midi chipsets on certain motherboards. I would think though that now these problems were overtaken but we could be dealing with some older motherboards here?

Midi can be quite strange due to it’s old establishment. It’s always worth reconnecting or trying out keyboard settings just to try to trip it into working as you want sometimes. :neutral_face:
Worth a look is seeing if there are any relevant firmware (rare but you never know) updates for your interface as well as drivers.

Both of these suggestions make sense, and so far I’ve tried neither. I had thought to try my keyboard’s MIDI Out into my Firebox’s MIDI in already, but I’m trying to find the cable I thought I had for this purpose. Once I find it (or just buy one), I’ll test the issue that way.

I’ll also try disconnecting/reconnecting my USB once cubase is started. I’m not at my machine now but I will try this asap and let everyone know which of the two tests (if either) makes a positive difference. It makes sense to me that the problem should result from the routing of USB data through my PC, to my Firebox, to Cubase. Whether it fixes the problem or not, it makes better sense to be running the keyboard directly into my Firebox anyway.

Still, MIDI is expressed as such tiny bits of data. It does seem silly that any latency problem would be possible! But, it is what it is, right? Beerbong: my performance record does look something like what you’ve shown, yes. Every recorded MIDI note is staggered off the beat, though I’m playing exactly on the beat in my tests.