Petaluma chord symbol text font wrong

When I’m trying to select Petaluma as a music font after creating a project with Bravura/Academico first, the chord symbol text font doesn’t change to Petaluma Text (or Petaluma Script, whichever it’s supposed to change to), but instead stays as Academico or even occasionally changes to an Arial-like font.

I’ve reinstalled Dorico 4.3.11 using the Download Assistant, but the problem persists.
Macbook Pro 16" M1 Max (2021), 64 GB RAM, Dorico running as Intel (Rosetta 2) version, Monterey 12.6.2, Dorico 4.3.11

Kind regards,
Hannu Ala

Is it something to do with this option?


No, that option is selected and it used to work well before 4.3.11 update.

The Chord symbols font should indeed change to Petaluma Script, while the Chord symbols music text font should change to Petaluma Text, and I find this to be the case. Hannu, could you please do Help > Create Diagnostic Report and attach the resulting zip file here, so I can have a look at your saved settings, in case something in there could be affecting things?

In both Edit Font Styles and Edit Paragraph Styles,
CleanShot 2023-01-17 at 10.29.13@2x

Try : “Reset to Factory” (the circled arrow) for each element from the left side; click OK, then try changing the music font to Petaluma.

Here you are, Daniel.

Dorico (622.4 KB)

Update: Using Maintain’s Cocktail I removed user caches, including font caches, restarted my Mac, reinstalled Dorico using Steinberg Download Assistant and made sure all settings were reset to factory defaults.

The problem still persists.

I tried to update to Dorico 4.3.11 on my other Mac and it’s working fine, so it looks like that I’d need to reinstall this computer if a working solution can’t be found.

I believe the problem is due to the fact that you’ve saved default fonts for the chord symbols and chord symbols music text font styles in your user library. I’ve adjusted your user library XML file to remove these saved font styles. Unzip the attached archive, and in the Finder, go to /Users/your-username/Library/Application Support/Steinberg/Dorico 4, delete the userlibrary.xml file there, and replace it with the one you unzip from the archive here. (2.6 KB)


I believe I’m having this same problem, using 5.6.30 on an M1 Mac. Is there something I can look for in my own unserlibrary file to see if I have the same situation? Thanks,

Apparently, if I first change the overall music font to Petaluma, then change it back to whatever font I want to use, I then get the option for the Petaluma font group in the list of parent fonts in the font styles dialog. Once I have that, it will allow me to change the chord symbols fonts. Is this normal behavior?

You can examine the userlibrary.xml file in a text editor. It’s located in /Users/your-username/Library/Application Support/Steinberg/Dorico 5. Look for a definition in the <fontstyles> node for font.chordsymbols.