Piano Plugin woes

Downloaded and installed CB 10.0.20 yesterday. Obviously a lot to figure out from 6.5 :slight_smile:
The only problem I’ve found (so far) is that when I try to create an instrument track with 4Front’s TruePianos it causes CB to freeze.
I’ve downloaded and installed the latest version of TruePianos (seems that development stopped a couple of years back). It is (apparently) a 64bit vst.
Is there any reason why this plugin is incompatible with CB 10? Anything I can try to get it working?

Any help to get my “go to” piano working much appreciated.

Hi,

You can try to rescan all your plug-ins in the VST Plug-in Manager.

If TruePiano would become blacklisted, then there is something wrong with it. You can try to reactivate it manually afterwards, on your own risk.

Thanks for the reply, Martin.
I had already rescanned the plugins. The TruePianos 32bit is blacklisted, as expected.
However, “TruePianos x64” is listed in VST Instruments… I’m just not able to use it :frowning:
Any more suggestions appreciated.

Hi,

Does it freeze or crash? If it crashes, could you please attach a crash dump file?

Thanks Martin,
It freezes. No actions within CB10 are possible. The only option is to force close CB in Task Manager.

Hi,

Then the only chance how to get any information what’s going on, is via Task Manager > Create dump file.

Thanks Martin,

Unfortunately, the task manager ‘frozen’ CB10 dump file is a whopping 1.23GB :astonished: , so too big to attach here!
The ‘unfrozen’ dump file is a slightly less whopping 975MB, but still too large to attach here.

For whatever reason, it seems that TruePianos x64 and CB10 just don’t get along!
TruePianos x64 worked flawlessly in CB 6.5

Interestingly, I have a similar problem with Pianoteq. Three instances and it’s fine, add a fourth and it hangs, with a split second here and there where I can move the mouse. If I can actually manage to remove the fourth instance everything is fine again.

I wouldn’t have usually mentioned it here, but it is a virtual piano as well. I can’t say when this problem arose as I have been away from Cubase for a bit, but I think it’s within the last few months. Both 10 and 9.5 are affected. Possibly a windows update?

Hi,

Share the dump file via Dropbox or similar, please.

Thanks Martin, here’s a Dropbox link to the dump file:

https://www.dropbox.com/s/bsh9z4tuq9mzi65/Cubase10%20frozen.DMP?dl=0

Hi All

I often use 4front piano in C10, never had any kind of problem at all.

Best Regards, Dave

What audio interface do you have?

Hi jamesd,
I normally use a Focusrite 2i4 (2nd gen), but have to confess that I’ve been checking some of the CB10 features without hooking it up.
My work as a bass player means that I’m often on the road, and sometimes use the travel/hotel time to edit CB projects, with no need for an interface.
I may be wrong, but I don’t see how the lack of interface effects a plugin’s ability/inability to load.
In CB 6.5 I had no such problems.

Hi Dave,
That’s interesting! I’ve so far, only tried CB10 on my laptop. Over the weekend I’ll install onto my desktop and see if that works.

You won’t! Everything will work! You’ll maybe just get some more latency not using a quality audio interface? But overall all plugins should work with the embedded sound device.

Just to update:
I installed CB10 on my desktop - TruePianos loads and works as it should! :slight_smile:
I copied the TruePianos .dll to my laptop, so it was exactly the same file - no joy! :frowning:
I should add that the 64bit works fine on the laptop as a standalone.
There is a conflict somewhere.