Piano Roll Notes Velocity stuck

I have notes stuck at zero velocity. They sound when I click on them. But when I adjust Velocity using pencil, or line tool, or setting a value in the numerical field on the left, it appears momentarily then snaps back to zero.

Any suggestions please?


Hi @misnoma ,
posting here the file where it is happening "helps us to help you" :wink:

Are you e.g. using the Silence playback template, or have you not assigned one or more instruments to valid endpoints (i.e. either a VST instrument or a MIDI output) in the Routing tab of the Track Inspector panel in Play mode? You can’t edit velocities for notes that won’t be played back.

Here is an isolated example …
With Halion playback template applied…
Some of the notes in Mandolin and Acoustic Guitar have zero velocity and I can’t change them.

No, not using Silence template.
Yes, end-points are assigned.

Hi @misnoma in your example the notes whose velocity is set to 0 and not editable, are slash voices. Putting them in a normal voice (not slash) reestablish the editability of their velocity (as they have now a specific note/pitch).

I don’t know if this behaviour is expected (I seldom use slashes), but thinking logically: slashes represent no note/pitch, they are an indication of the rhythm that the instrument has to play. So if I would be Dorico :face_with_monocle:, I would also put them at 0 velocity (so producing no sound) since no particular notes should sound where the slashes are, being they a mere rhythmical indication. (but I may be wrong of course)


There’s a playback option for whether slash voices should play back, so if you want them to be played, make sure that option is activated.


1 Like


Thank both you for these excellent replies.

I see now the Mandolin and Guitar parts have guide pitches in playback, but are notated as slash voices to indicate they will be comping. Is there any indication in Play view of slash voices or must the user switch view to check? Feature request: message to user when velocity change of slash voice is blocked?

Nice there is an option (which i never would have found otherwise) to have slash voices play, and include in audio exports, for demo purposes.

This was probably my best “asked and answered” experience on any discussion forum ever!

1 Like

Yes, you can see the voice name and kind in Play view also, for the selected note:

if you change the option that Daniel posted above, and you then click on Save as Default, you don’t need to worry anymore about this in future projects, because beyond hearing the inputted pitches of the slash voice in the playback, their velocities will now be editable:

1 Like