piano sustain won't release

I’ve been working on this piece and have encountered a problem I can’t solve. At ms. 21 it appears that the piano sustain is locked down – everything in the piano staves is sustained to the end of the piece. It’s not a problem up to that point, and I don’t know what I did to create it. I can’t find anything in the PLAY section but don’t know enough about that to know what to look for. Can somebody help me figure out what’s going on?

Mascagni_Intermezzo (cello and piano).zip (1.45 MB)

In play mode change the settings:
two chanels,
channel 1 = HSO cello (or violin) solo
and channel 2 default (for piano)

in Halion Sonic
for channel 1 - cello or violin
for channel 2 - Yamaha S90ES piano

The pictures in addition.

Piano-EK, I’m not understanding your response. The cello and the piano sound fine and appropriately as desired. But beginning in measure 21 the piano is sustained continually to the end of the piece, as if the sustain (damper) pedal is being held down and not released. Why is that? I’ve reset the expression map and default playback template, to no avail. What else can I try?


You have set instruments for 3 channels (picture2) in HALion Sonic.
You play be channels 4 and 5 (picture1), for which you have no instruments.
Attempts to set the channels as shown in my images before.

I have the same issue

Here the corrected project
Mascagni_Intermezzo (cello and piano)2.zip (816 KB)

In my case, all of the midi is set up correctly. I managed to fix it by adding a Pedal marking that I don’t want right after a barline. It seems that a pedal marking that releases at the barline is not triggering in the midi playback?

With me it has not played, only after the setting of the MIDI channel. I thought it was.
But it’s still really bad from the measure 21.

There’s something with the piano “Yamaha S90ES piano” wrong (maybe?).
It comes with the quite deep Tonen (with legato) in a mess.
For example, with “SR live Grand Piano” the error is gone.

I opened the project - no playback at all = silent.
I went to Play Mode, then in the Play menu “Apply Default Playback Template…”
Result: playback works fine, no hanging piano or other issues.

k_b, from the end measure 27 is not clean yet.

i’ll check again later, but I played it through without any hiccups. Even tried a transcription for viola :innocent:

Dennis, I and k_b have loaded your project, besides, the MIDI channels with us were displaced.
Here I suppose, in *.dorico everything is not correctly stored for the Halion what concerns the MIDI channels.
Therefore, the history with the settings of the channels which is really irrelevant here.

As you said, in your project, what is really with sustain (Yamaha S90ES piano) wrong, but I do not know what this can be.
But the piece I like it, sounds wonderful :slight_smile:

Dennis, the measure 28 sound not good (see pic-1).
I would play it differently (see pic-2).
(You must still verify that may delete the duplicate notes).

Dennis, I tried it again, I think it is now correct.
I completely deleted measure 19 (not the content, but the whole measure),
new measure added and re-entered the notes.
Should now properly sound. I also entered the “correction” in 28 :wink: .
Mascagni_Intermezzo (cello and piano)3.zip (817 KB)

I have changed the measure 28 afterwards still thus: see myMeasure28.

I mean, there are yet two small bugs.
Measure 11: delete slur, there should be tie.
Measure 46: tie together the three marked notes.

Thanks for all the help, Piano-EK. Your fix worked – and thanks for finding the mistakes in measures 11 and 28 (it must have been too much brandy!) :unamused: It all seems to work fine now.

Measure 46-47 is intended to be separated; the note is re-articulated again.

This lovely piece is originally orchestrated in the key of F. The version I found for solo cello is in C – I may put it back to F for a more mellow sound. :slight_smile:

This pleases me that it has worked.
With 46 I was not quite sure, I play no cello. I leave 46 then also in such a way.
I will try out it also in F.