Pianoteq 8 unstable in Dorico iPad

I use Pianoteq 8 AUv3 plugin in multiple apps on iPad. It sounds great and seems to be a very light app in general because it’s not sample-based. I’ve never had performance issues in other host apps, but when I load it in Dorico for iPad, Pianoteq plays back with noise and has trouble keeping up. I’m using an M1 iPad Pro. Any idea why this is? Is there any way to optimize my settings to resolve this?

We don’t have Pianoteq for iPad ourselves at this stage, but we’ll look into this and I’ll come back to you as and when I learn more.

Excellent. Here’s the developer’s website:


Thank you.

No problem here. I use Pianoteq 8 + Dorico on my iPad pro, just piano sounds, no other instruments…

Which iPad are you using?

I also haven’t run into any issues with Pianoteq 8 on iPad. I’m using an iPad Pro M2 currently, but I don’t recall any issues on my previous iPad Pro (2018).

I’ve also just got hold of Pianoteq and have tried it on my iPad mini 6th generation and it seems to be running fine. Does the problem occur in all projects, or only in larger projects?

I got in touch with my colleague Alex, who is the main developer of Cubasis and also the author of the audio engine used by both Cubasis and Dorico for iPad, and he suggests that you go to the Play page of Preferences and disable Enable multi-core rendering. That should improve the performance of Pianoteq on the M1 iPad Pro.

This won’t be necessary in the next Dorico for iPad update (which will arrive at the same time as the next Dorico desktop update, before the end of the year), which will bring improvements in the handling of multi-core CPUs, and will no longer require an option to enable or disable multi-core rendering.


Thanks for the suggestion. I tried turning off multi-core rendering and so far the crackling noise seems to be gone. I will continue to monitor, and I look forward to the next update :slight_smile:

To answer your prior question: The crackling was occurring even on small projects with only one instrument and very little music data.

I wonder (because I haven’t played around with the iPad version, only desktop) if there are audio level settings in the pianoteq app. Is it possible that the crackling was clipping?

iPad pro 12.9 gen 6 (2022)

1 Like

There is a mixer, like in the desktop version, so absolutely a possibility, only not in this case. I just tried playing a piano piece through Pianoteq with multi-core rendering enabled. Not a good idea! It must not be enabled for playback with Pianoteq, unless you have a weird penchant for crackles :slight_smile:

1 Like

Romanos, yeah it’s not clipping. Daniel’s solution about turning off multi-core rendering has fixed it and I didn’t touch the mixer/volume/level settings. Good creative idea, though. Thanks!

1 Like

Thanks for confirming my experience. Let’s just keep multi-core off to avoid this :slight_smile: