Pianoteq, VST3 tuning and playback templates

The playback templates confuse me. I am using a microtonal Tonality System for a piano staff. It turns out that if my Playback template is Halion SE, a piano instrument on Halion plays the microtuned notes correctly but if I switch to Pianoteq, it does not respond to the microtuning but stays in 12-equal. But when I use the NotePerformer playback template, both NP and Pianoteq play the tuning correctly. Why is this, and can I get Pianoteq work under the Halion SE template? I do have a combination template for Halion and NP, so everything works, I’d just like to understand how the templates work. Or is this about Expression Maps? Both Halion and Pianoteq 8 do use VST3 Expression for retuning,; I haven’t changed the Expression mapd (and I have no idea wguch one Pianoteq uses, anyway).

I would have thought you needed to set your tuning directly within pianoteq. You can’t fault pianoteq for playing a regular tuning if it is set to the normal tuning. But if you change the tuning within pianoteq, then it doesn’t matter where it receives midi signals from, it will play back correctly.


Are you sure you are hearing pianoteq at all? My guess is your simply hearing the NP piano.

Have you checked this in Pianoteq->Options?


1 Like

What expression map are you using for Pianoteq? You may need to go to Library > Expression Maps and then in the Expression Map Data section of the expression map you’re working on, set Microtonality playback to VST Note Expression.


Yes, I do have MIDI tuning and yes, and I am listening to Pianoteq.

Yes, I tried that. But I’m not sure which Expression Map I’m using for Pianoteq… I thought it was the one called Default but maybe not. Where can I see which map I’m using?

Have a look in the Endpoint Setup dialog:

Romanos, Pianoteq is one of the few VST instrunents that respond to Dorico’s VST tuning for microtonal notation. For this to work, it must be set to equal temperament.

Interesting. I didn’t realize that. I knew that you could assign very detailed non-equal tunings directly within pianoteq, but not that it would bend from midi data.

Thanks. Well, Pianoteq was using the Default Expression Map, as I thought, and it was on Auto (which should work) but I tested the VST Expression option and that didn’t help. Enclosed is a file that is played with microtuning in Pianoteq when the NP template is in use but not if HSSE templates are used. I will test Dorico 4 and see if this problem only happens in v. 5. -Another thing: Dorico creates one track/channel for the upper staff and another for the lower of the piano but the Mute and Solo buttons do not work on the VST rack on the Play page, or in the mixer. Is this a known bug?
Pitchbend export test2.dorico (954 KB)

Dorico uses a VST3 Expression parameter or a VST2 tuning parameter for playback of its Tonality Systems. This tuning method is very precise but it’s only supported by Halion, some Steinberg synths (although in Dorico 5, at least one less than before), NotePerformer, and Modartt Pianoteq. Pianoteq is extremely well-equipped for microtonality: it has its own tuning editor, and it also supports .scl and .kbm files, MTS (Midi Tuning Standard SySex), MTS-ESP, as well as dynamic multichannel pitchbend (16 voices) and MPE. And this VST parameter which, alas, only works inside Dorico.

1 Like

Tested in Dorico 4. Pianoteq plays the microtuning correctly with the HSSE+HSO template, so this seems to be a problem introduced by Dorico 5, unless there is yet another setting I have missed. (The Expression Map Pianoteq is using (Default) is set to Auto or VST, MIDI tuning is on in Pianoteq). Perhaps there are some changes in the microtonal programming in Dorico 5? Steinberg’s VST instrument Padshop responds to VST tuning from Dorico 4 but cannot be microtuned by Dorico 5 (changing the tuning method in the Expression map parameter does not help).

Yes, we’ve already discussed this in this earlier thread:

Please make the change described above in my earlier reply in this thread:

I did, as I wrote above. Setting it to VST doesn’t help. Auto doesn’t work, either, although it should.

No, Auto won’t work, because (as explained in the other thread), Auto means to use VST3 note expression for HALion, VST2 detune for NotePerformer, and nothing for anything else (though in due course it will also use VST3 note expression for other Steinberg-manufactured instruments like Retrologue and Padshop).

OK, I’d misunderstood; I thought Auto chooses between VST2 and VST3 for any instruments that support one or the other. Anyway, now that I tried Padshop with the VST tuning on, as I did previously (or thought I did, anyway), it does work. So that problem is gone, unless it’s something that occasionally reappears. But the Pianoteq problem persists. With the tuning method set to VST, it does not play the microtuning with the HSS-HSO template. It only does so with the NP template. I tested with PIanoteq 8 and Pianoteq 7. And Dorico 4, which does not have this problem.

I believe Pianoteq might actually use the VST2 detune method rather than VST3 note expression – by the looks of things, that would be what Dorico 4 would have been sending to Pianoteq. I have sent a support request to Modartt to clarify exactly what Pianoteq expects to receive.

In the meantime, you can certainly specify MIDI Pitch Bend in the Default expression map to hear microtonal playback from Pianoteq.

1 Like

I’ve heard back from the good people at Modartt, and Pianoteq is indeed using the VST2 detune parameter – but only when MIDI Tuning is activated in Pianoteq’s options: click Options at the top of the Pianoteq window, then in the MIDI tab set MIDI Tuning to Yes.

Now provided you set Microtonality playback to Detune, you will hear your microtonal playback in Pianoteq as expected.

We can make Dorico do this when Auto is set in the expression map for Pianoteq in future, but you’ll still need to actively turn on MIDI Tuning in Pianoteq’s options.


Thank you very much; that solves it. MIDI tune was on Yes in every test but I suppose some trials worked because Microtonality playback had been already set to Detune without my noticing it. As NP uses this older method, wouldn’t it make sense to have the Default Expression Map be set to Detune by default in the NotePerformer template? Or are the Expression Maps independent from the templates?

Sorry for repeating myself, but the point of the Auto setting is that it will automatically choose the appropriate microtonal playback method for known plug-ins, which includes NotePerformer, HALion, other Steinberg plug-ins, and (soon) Pianoteq, precisely for the reason that if Dorico knows how to achieve microtonal playback with those devices, you don’t need to.

1 Like