Pick up bar definition

I noticed when creating a time signature that the pick up bar is always designated 1/2 beat, 1 beat, 2 beats relative to the crotchet (quarter note) beat no matter what the time signature. I found this confusing and it is technically incorrect since a one beat note in 2/2 is a minim and in 3/8 is a quaver. The other correct option would be to specify crotchet, minim or quarter note, half note etc.

I’m sure there are far more important things to work on at the moment but perhaps this could be tidied up at some point in the future.

I’m not sure I understand: the pick-up length is described in terms of the time signature’s denominator, so if the denominator is 8, then you enter the number of eighth notes that add up to the length of pick-up; if the denominator is 4, you enter the number of quarter notes that add up to the length of pick-up, and so on. It’s not always relative to a quarter note beat.


I was trying to enter a new time signature in the middle of a piece with a pick up bar. (It’s the start of a new section.) The drop down attached below only offered 1/2, 1 beat and 2 beat options, and these corresponded to crotchet beats in 3/2 time and 3/8 time. Perhaps this is a bug , perhaps I should be using a new flow for a new section. Is the pick up measure only designed to work at the beginning of a flow or am I missing something?

Thanks for your help.

Ah, I see what you mean. Try typing the pick-up into the Shift+M popover using the method I described above (e.g. for half a bar in 6/8, enter “6/8,3”, or for one and a half quarter beats in 4/4, enter “4/4,1.5”), rather than using the drop-down in the panel. I agree that the UI in the panel needs to adapt more to the time signature chosen. Sorry for the misunderstanding.

This works perfectly. Obviously I still don’t know the program well enough. Thanks a lot.

How about if I want to add an upbeat bar to existing music? Just as an example, the piece is in ¾ and I inserted a bar at the beginning, which worked as expected, but any attempt to change this new first bar to a ¼ upbeat shifted all the music after it two quarters to the right. How does one do this?

You don’t need to insert a bar first: just replace the time signature at the start of the flow with a new time signature with the pick-up specified, and that should be all there is to it.