Picture Transcoding problem

I am trying to transcode (insert) an image in Wavelab’s spectrum editor but there’s always a high-pitched “interference” on top of every image/sound.

I have tried with JPG and TIFF files, high-resolution images, downloaded from NASA’s website and the result is the same.
I have edited the images in order to remove EXIF, IPTC and JFIF data but the interference remains.
It’s audible and visible.

Here’s an image from the spectrum where the interference is visible:

It’s easy to test for anyone with Wavelab.
I’m using 11.1

Create a new File either by opening an audio file or using the “Signal Generator” under > File > Tools.
It’s best if the imported/created file has low signal level in order for the image transcoding to be clearly visible.

Then > Audio Editor > Spectrogram View > Create a selection > go to Spectrum > Processing > select Transcode Picture from dropdown > click Apply > select picture (JPG, TIFF…) …and voilá!

I have changed Spectrogram options and used different image files (TIFF and JPG) and the same thing happens.
Spurious noise is added both above and below the spectral image transcoding.
It happens with Mono or Stereo files in all the SampleRates i have tested: 44.1, 48 and 96KHz
It happens with different FFT windows (Mel, Hanning, Kaiser…)

I have made an animated GIF of the process, that you can follow here:

The test above was done by transcoding the image into a silence file, 48KHz, 32 Bit FP.

Can anyone confirm this or please indicate what i may be doing wrong?
Thanks all in advance.

I can reproduce the problem. This will need some investigation, hopefully before the next minor update.

1 Like

Despite it now being a reproducible problem i feel kinda happy because it wasn’t me being silly.

Thanks a lot for checking this out PG1!

Picture Transcoding problem reported above remains in WL12.

Sorry, this issue was overlooked. However, the good news is that it has been fixed in the upcoming WaveLab 12.0.10.

1 Like

Looking forward to it.

Picture Transcoding is fixed in 12.0.20.
Thankyou @PG1 !

1 Like