Pinch me... Multi-Processor Support in Cubase AND Kontakt is MORE stable??

Over the years it’s generally been discouraged by Steinberg and Native Instruments to have Cubase’s Multi-Processing support AND Kontakt’s Multi-Processor utilization both enabled at the same time, and I’m fairly sure I’ve had problems when trying that in the past.

I’ve always just assumed that you’d NEVER want to enable both, so I only ever had MP enabled in Cubase and not in Kontakt.

But for years I’ve been suffering constant Cubase ASIO meter peaks and audio dropouts from large Kontakt patches or Kontakt patches with complex scripting.

I tried this scenario again of enabling Multi-Proc in Cubase and Kontakt, and lo and behold, a lot of session drop-outs disappeared. They’re not all gone, but it’s much better.

Anyone (Steinberg or otherwise) know why this might have made such a big difference?


Cubase 9.5.20
macOS 10.13.3
Mac Pro 6,1 (trashcan) 3.5GHz 6-core 64GB RAM, 4TB SSD

I pride myself of the same things you do :wink: but I am also very curious and tried enabling both many years ago and even then it was much better with both on MP. Oh I am on win7 64 so it seems to be a cross platform thing too.

I’m on Windows 7 here and have exactly the same experience. Best performance with both enabled.

Win7Pro64, both enabled as well - selected 6 cores of 12 available in Kontakt.

Have you noticed any difference in performance doing this? I just have kontakt set to use all cores…but would be happy to scale it back if it improved things…

Curious about this as well.
And following this thread… I’ve had the multi-processing turned off in Kontakt for forever but just turned it on to see if it’s better!

I had a small session a while back, might have been using 9.0.30 or 9.5.0, that was performing poorly…audio stuttering and average load spiking with 3 instantiations of Kontakt, amongst other VI’s. So I activated MPS in Kontakt then kept adding cores until it stopped, and that was 6 cores for me. And I’ve just kept it that way since to be honest. On 9.5.20 now.

But you’ve piqued my curiosity, so I opened that same session with MPS off and on with 6/12 cores selected. It now plays fine with any of those settings. Go figure. Any recent session has been with 6 cores. Maybe updating to 9.5.20 and/or installing a new video card fixed something? What I did notice though, was the average load meter does not pulse as much with MPS activated…interesting!

I think I’ll keep it on 6 cores as it hasn’t shown any negative side effects doing so, and maybe avoid any potential errors.

EDIT: Another thought just occurred to me… I edited the registry so Windows 7 Core Parking was DISabled, which it wasn’t. This may have also influenced the improved performance.

In most plugins, this warning is about the possibility of dropouts if you enable that option while working on a project. It’s recommended to quit Cubase before resuming your work. In Kontakt’s case, some hosts just don’t handle the multi-processing well, but it should work fine in Cubase for most people.

The same applies to Steinberg’s plugins such as Halion, Halion Sonic and Groove Agent. Multi-core processing works fine.

If you use Halion or Kontakt multi-timbrally, it’s recommended to set the number of cores to one less than the maximum number of available cores. For example, if you have a 4 core i5 CPU, set the plugin to use 3 cores. If you don’t use them multi-timbrally, set them to use a lower number of cores.

Can I ask what the reasoning is here with regards not using them multitimbrally?

I’m not challenging, just wondered why this might work…

In general I use them not multitimbral (sometimes maybe 2 or 3 related sounds on one kontakt/output) because I find it more flexible then using multiple outputs of one Kontakt. So one midi track one instrument one mixer channel. But for me 5 Kontakts is rare. And I use them with multicore on all my (4) cores. Tried less and off and 4 was best performance.

I rarely use them multitimbral. Will try tweaking the “core number” settings and see what happens…

Don’t forget you have to at least close and restart all Kontakts!

Thanks :slight_smile:

Simply restarting your DAW should be enough.

Cubase will have better thread scheduling since it has much more information on how your system’s resources are being used, so if you’re not using these plugins multi-timbrally, setting their number of used cores to a low number or “off” will lead to less crashes and usually better performance.

Here no crashes and better performance with MCPU on.

Just tried a test. 5 kontakts. Didn’t notice any difference in either average load or real time meter level changing from 12 cores down to 6. However, both levels noticeably higher when turning all cores to “off”.

Just for Sh*ts and giggles I tried changing the processing precision (in Cubase) from 32 to 64 bit . Again no noticeable difference on the meters. Well maybe very slight…

i7 3930k Hex core oc’d to 4.2 GHz with hyperthreading on. Windows 7 x64. Cubase 9.5.10, Kontakt 5.7.3

This is not unexpected. I would think that differences between 6 and 12 cores would become visible under much higher loads (which would be interesting :wink: )

OK. I’ll try a test in one of my bigger pieces which have lots of Kontakts in them :slight_smile: