Pitch Problem with VSTi's in Nuendo 12

I was loading up and old project for updating. The original version used my synth rack modules. I was replacing several parts with various Virtual Instruments. But ALL of them, regardless of vendors, are playing back a half step sharp, even though the MIDI notes are reading as unchanged.:exploding_head:

So A is showing A on the keyboard but sounding A#. None of the hardware synths are doing this. So the problem has to be some universal setting in Nuendo. But I can’t figure out what is causing this or where, besides the MIDI Setup Page, to look.

Can anybody help me with this?:thinking:

That is strange as hell. Could there be some kind of sample-rate mismatch, where they are playing back at the wrong rate and that is causing them to be sharp?

NO clue! I’ve never seen anything like this. My audio interface is an Allen & Heath SQ6 32 channel digital desk. This desk doesn’t go to 44K. It starts at 48K and goes up. This has never been an issue, since all of the video/DVD projects are also at 48K. So my synths are all coming in analog and printing at 48K and there’s no pitch problems there. But trying to print the VSTi’s is all of a sudden an issue.

I’ve done dozens of projects using only the VSTi’s and the pitches were all correct. However, as I’m writing this, it just dawned on me that all of those tracks were rendered, not recorded. So, MAYBE that’s something to consider. But that’s a long shot at best!

Something else to note. When I tried using the pitch tool to lower the printed track a half step. The pitch didn’t change. So, something is fundamentally wrong now. I just can’t determine the cause.

I just rendered the VSTi Track and then pitched shifted the resulting wave file down a half step. It now played the A as an A. But it was still a few cents sharp, which was made very obvious as it made a chorusing effect when played against the printed file of the same part from the hardware synth.


Meanwhile, look at the rendered wavefile compared to the printed wave file. That is NOT a natural wavefile shape! I also left the VSTi open (GigaStudio Clarinet) so that you could see the tuning readout. There is no modification registered. So why is it playing sharp? Why is the wavefile all screwed up? What’s going on?

Well, it appears to be a CORRUPTED IMPORT. I don’t know how that happened. But I decided to try importing the files again. When it asked if I wanted to create a new project, I said yes. The new project opened witheverything mislabeled (via General MIDI). But I found the same clarinet track and it played back with the correct pitch. When I rendered it (see screen shot), you can see that these wave files look normal.

So, I guess the solution is to delete the first import and re-import the MIDI file again and see if that corrects the issue. Weird!

Re-importing the tracks didn’t work. Clearly, this entire project environment is corrupted, as the re-import yielded the same pitch issues.

I’ll have to start from scratch in an entriely new environment. :frowning_face:

Man that sucks :frowning: . Do you have an older version of Nuendo you could try opening it up in to see if the corruption is in the file itself, or is peculiar to the way it is being rendered in the newer version?

I opened a completely new session (TOTALLY BLANK). I imported my MIDI tracks. I checked the tuning. Perfect! No issues at all over any instrument on any track.

Then, I imported my audio tracks, which were printed in tune on the other session. Even though they were all printed from bar one, they imported with a full extra measure. Odd, but easily correctable. I cut the extra measure off at the front and lined the tracks up again from measure one. Everything is in synch and in tune except now all of the audio tracks are a half step flat! :scream:

WTH?!!? :face_with_symbols_over_mouth:

Damn this is weird as hell. I am out of ideas at this point other than trying an old version, or maybe processing the audio tracks in an editor like Wavelab before importing them.

1 Like

I don’t understand how a PRINTED track can play back at a different pitch from its original recording without using some kind of pitch processing tool to make that happen. This is nuts!

Only thing I can imagine is that the sample rate is wrong, like the file is 44.1kHz but the metadata says it is 48kHz so SRC doesn’t happen but it just plays at the wrong rate or something like that.

1 Like

If that was the case, then it should be sharp, not flat. But besides that, that couldn’t be the case because it came in analog and was recorded at 48K.

Ya… I still think it is worth checking the files in Wavelab or Sound Forge or something and seeing if the metadata is correct at 48kHz or if it is somehow wrong.

I had a very similar experience with a much older version of Cubase (circa 2010) on Windows 7 that had worked fine for a number of years and then all the VSTis started generating pitches that were off. I don’t recall any of the specifics, but they were mostly not exact standard intervals (e.g., C sharp instead of C natural). I’m providing this info, vague as it is, just to lend some moral support and hopefully credibility to the original poster’s claims. 44.1k vs. 48k sounds like a reasonable hypothesis. I never did resolve it. After a Cubase hiatus I’m now running Cubase 12 on a Mac M1 Max Studio, thankfully with none of these issues.

1 Like

Well, I finally got all of my tracks (Analog Prints +VSTi) loaded in tune. I can’t swear to it. But I’m pretty sure the culprit was conflicting Software.

I use Wondershare for Video downloads when I teach online. There has always been some weirdness when both were on at the same time. In version 12 I couldn’t delete videos if Nuendo was on. Now with version 14, Nuendo apparently goes nuts! I realized that all of these quirks and craziness started shortly after the update to version WS14. Even my Nuage hardware went nuts! It dropped connection right in the middle of the session with me actively using it! THAT requires a complete shutdown of the PC in order to get the hardware to show back up in the Work Group Manager Page.

So, when I rebooted, I left everything off except Nuendo and Nuage. When I did that, everything went back to normal. I had to delete the audio that I recorded over the weekend and re-track all the parts. But this time the VSTi’s were in correct pitch and the synth rack parts came in also in the correct pitch and when I played everything back together, it was all in tune.

So, I think what has to happen is that Wondershare will have to reside on a different PC. This will mean importing video files from the other PC, which will be a slight pain, comparatively speaking. But it will OBVIOUSLY be a small price to pay considering all the aggravation it seems to have caused this past week!

Thanks to all of you for your help and support. Much appreciated! :sunglasses:

1 Like

That is… wow. I have never heard of software causing that level of conflict.

Glad you found out what it was.

1 Like

I don’t know that for sure. But since I’ve turned it off. I haven’t had a single problem. So, it’s looking pretty certain. Meanwhile, I’m absolutely loving being able to JUST WORK, as in NOT chasing down problems that actually interrupt the work! :grinning: :sunglasses:

1 Like

Pssssst! Never say that out loud!! They are always listening!!!
(… looks anxiously from left to right and turns away from the screen …)

8-]

1 Like

:laughing: :laughing: You’re right about that! I lost my head momentarily. Move along folks. Nothing to see here! :neutral_face: :wink:

All my M-Audio keyboard controllers eventually start sending out false pitch info. It sounds crazy but all of a sudden when I press any note it will sound about a half tone flat. Hook up another controller and all is well. I swear this has happened with three separate M-Audio 88-key controllers. When it happens it’s as crazy as you described.