Pitch shift (Envelope mode) incorrect behaviour ?

Something seems off with envelope mode in the “pitch shit” when turning time correction off.

On the older versions, if you (for example) had a pitch envelope going downwards, and turned time correction off, it would slow down the audio as well as pitching it down.

On Cuabase 10…(just tried this a few times)
I put a pitch shift envelope on some audio (down 7 semitones over the course of the sound), and it pitched down as expected. Turn off time correction, and it seems to do something that sounds like ring modulation to the audio… no pitching, no slowing down etc.

Anyone else tried?


the bug Is happening to + semi or - semi envelope use…
DOP is marking the process with a (!) …

same here : https://www.steinberg.net/forums/viewtopic.php?f=283&t=148705
in transpose pitch process … :open_mouth: :open_mouth: :open_mouth:

and also I just found out that…
if you have a small audio excerpt in length size (for example a percussion hit, let’s say 0.125ms)
the transpose pitch process with a + semitone (+3 for example) is happening as expected (without time correction)
and also seems that is working on - semitones (-3 for example)…
but after a point, as you continue to process the same pitch process and you expect this excerpt to be more pitch downed and the audio length to change, is not working as expected, a silence comes inside the excerpt audio clip!!!

(check image)

but if you have a longer audio excerpt in length size (like 1:15ms) is buggy again, as the envelope…
(!) appears in the dop!

time to switch back in C.9.5…


They had the same bug in a 9.x version. So they fixed it and it broke again, how is that even possible?


Also, if you apply pitchshift using time correction (any of the modes) and try and go and further than +/-12, it doesn’t work, it just pitches it a maximum of 12 semitones in any direction.

Does anybody remember back before DOP, when you could just destructively apply pitch shift whenever you wanted, manipulate the envelope in any way you like, and it just worked? And if you needed the unaffected audio file you could just grab it out of the pool whenever you liked.

The gold old days! :laughing:

Don’t get me started on the issues when combining variaudio/additional timestretching with these new ‘DOP’d’ clips. It is always a roll of the dice…

If anyone needs to see it in action…I made a quick video

I also submitted a ticket about it (but not holding my breath that anything will happen)
I’ve not really been a fan of the direct offline stuff since it got introduced, as Joe90 above says, the old way was working just fine, and this new way, always feels slightly flakey…even when it was working.

crossing fingers! this is one of my most used tools when I do sound mangling/design and it sucks that it’s broken right now!