Pitchbend values on macro page


I made a pitchbend value thingie on my macropage…

The thing is, it only maps to one sample… (Instead of 2 layers)

If one connects it, and changes the value on the macropage, the pitchbend range values turn red (only mapped to one sample)

How can i have the pitchbend range from the macropage control everything? (Like it does when it is not connected to the macro page)


Things i have tried:
Select all samples in tree before connecting
Select upper program in tree before connecting
Select everything in program tree before connecting

Hi ggc,

It is possible to connect a single value box for example, to the parameter of all zone inside a program or only a sub layer. To learn more about that please refer to the online manual.


But in short words. Normally, when you drop a parameter on the value property, it adds a connection by inserting a path to the parameter of the dropped object parameter, for example a zone parameter.

That will for example look like this
@0:Zone 1/@id:33001e” (PitchBendUp of a Zone that lives directly in a program)
This means connect to the parameter with the id 33001e of the first (0) object with the name “Zone 1”.

If you have mutiple zones in your program you need to adapt this connection path to
This means connect to the parameter with the id 33001e of all objects of the type “Zone”.

If the zones are in a sub layer the path can also be more complex like for example
@0:Layer 1/@type:Zone/@id:33001e”.
This way you can also control only zones in a specific layer.

The description of how you tried to establish the connection, is something we also consider to implement in a future update.