"play from last start position" problem

I like the feature where you can select notes in different staves and only hear those staves. Good.
However - if I select the keyboard command for “start or stop playback from last start position” I hear ALL the staves. Not so good.
Bug or design ?
Also - there’s a KC for “move playhead to playhead position”. How does that make sense…?


The reason there is a “Move playhead to > playhead position” option in the Key Commands editor is that the command to start/stop playback and the command to move the playhead both use the same set of options for locations. If you assign this command to a shortcut of course it won’t do anything.

If you want to hear only the staves with notes you’ve selected, you do need to use P. Any other form of starting playback will play all staves. The other option is to use the commands in the Play menu to solo only the selected staves and then start playback.

A trick I use a lot is to create custom scores for instrument groups. For example, in a big band score, I might have a sax score (including bass, so I will see the chords.) And I will likewise have a brass score, and maybe a separate rhythm section score.

That accomplishes two things:

  1. It makes it convenient to leave the main score transposed, with the custom scores in concert pitch.
  2. The playback is automatically limited to the section of instruments in the score (plus the chord playback if enabled)