Play mode -no sound in playback


I’m getting no sound in Play mode.

Hi @stevensd380 , could you please be a little more specific? What Dorico version, what OS? What did you do? What did you try?

Have you checked the ASIO driver and output ports under ‘Edit > Device Setup’?
Please create a new project from piano template, enter some arbitrary notes, does that sound on playback? If not, choose from the menu ‘Help > Create Diagnostics Report’ and post the corresponding zip file here. Thanks

At the very least you should work through the advice provided in this troubleshooting video:

1 Like

I understand. The problem you’re facing is that it might involve Play mode, which is not documented yet because it’s been evolving a lot these days. I am quite confident it will soon be solved, but alas your problem will be solved by then :bowing_man:

Here is a hastily edited version of the transcript of that video:

Hello, I’m Anthony Hughes, and in this video I’ll be helping you to fix some of the problems you might experience with playback in Dorico, the advanced music notation software from Steinberg. We want you to have the best possible experience as you start to use Dorico, our aim being to get you up and running as quickly as possible without any problems: however, one area that is quite difficult to keep 100% problem free is that of playback. In the world of computer audio there are so many variables with computer hardware and varying configurations and plenty of settings to change that benefit different applications in different ways, on occasion you may hit a problem where Dorico isn’t playing back as you expect it, or in some cases isn’t playing back at all.

This video aims to work through as many as possible of the more common issues you may encounter, so please keep watching to the end. I’ll be covering quite a few scenarios. Firstly I’ll be checking that all components needed to run Dorico and successfully hear the music playback have been installed and are configured correctly, then I’ll move on to device setup and any onboard or external audio interfaces you have and problems such as YouTube not working correctly while Dorico is running. What’s more, with the problem fixed you’ll be able to hold your head high and take on the world with renewed energy, safely knowing that you mastered the computer.

Ready? Let’s make a start.

No sound during playback – HALion Sonic SE not appearing in Play mode

I’ve started a new project and added a piano but I’m not hearing anything either during input or playback. Let’s switch to Play mode to investigate. In the VST instruments panel on the right you should be able to see one entry labeled HALion Sonic SE. HALion Sonic SE is the player that loads and plays back the sound library that is bundled with Dorico. If this is not here, it is quite possible that it hasn’t been installed.

If you installed Dorico using DVDs, then try the installation again and this time make sure you are selecting to install HALion Sonic SE and the HALion Symphonic Orchestra sound library. When you download Dorico using the Steinberg Download Assistant, which is freely available on the Steinberg website, then you are presented with four items. As well as downloading and installing either the full application or latest update you must download and install these middle two items named Dorico playback one and two, as these will install the HALion Sonic SE player and the HALion Symphonic Orchestra library that actually contains the sounds.

Once installed then you should find that when you create a project and add an instrument an instance of HALion Sonic SE will be added to the VST Instruments panel and loaded with the appropriate sounds.

No sound during playback – HALion Sonic SE installed

OK, the next step is for when you can confirm that HALion Sonic SE is installed and loading but you still can’t hear any sounds. Click on this “e” button to edit the instrument and the HALion window opens. We can see the 16 available slots down the left here, with just the first in use for our piano that we added. Dorico has helpfully automatically loaded this Yamaha S90 ES piano patch, and if you were to add additional instruments then these other slots would be used to load appropriate sounds.

So if you can see the piano loaded, that’s a good sign, and when you drag your mouse along the keys you should be able to hear the notes audition. Not only that, but you should also get some visual feedback from the level meter lighting up as you play the notes. If you can see the lights on the level meter, but cannot hear any sounds, then double-check that your headphones or speaker cables are properly connected to the correct audio port, because at the moment Dorico will only send audio to the first pair of stereo outputs on your device.

I should probably also ask you to double-check that the volume of your computer or speakers is turned up! If this still does not fix the problem, please keep watching: we’ll be getting into some more operating system-specific solutions later in the video.

Sound during playback, but incorrect sound

Sometimes you may find that when you start to play back your project the sound you hear resembles this mind-blowing synthesizer effect that really makes you wonder what’s about to happen next in your life: don’t fear. All that’s happened is that HALion has loaded the incorrect sound, and you can fix this simply by opening the Play menu and choosing Apply Default Playback Template, and this should force all of the correct sounds to be loaded for the instruments you have added to your project.

Clearing the audio engine data folder (Windows)

If that doesn’t work, then it is possible that you need to reset HALion’s database we do this by deleting a special folder that then gets rebuilt next time you run Dorico. Now this folder is in different places on Windows and Mac, so we’ll start by closing Dorico and then on a Windows machine, open a File Explorer window and navigate to your home directory. We’re looking for the AppData folder so if you don’t see it, open the View tab and check this Hidden items checkbox.

Then double-click to open AppData/Roaming/Steinberg. We want the VSTAudioEngine_64 folder, but beware: if you have previously created a whitelist for your VST2 instruments, this is where that is saved so you might want to make a copy of that VST2whitelist.txt file before you delete this folder.

Now when you restart Dorico it will spend a bit of time rebuilding the database for your sound files again, but after that hopefully Dorico and HALion Sonic SE will choose and load the correct sounds.

[Note: in Dorico 3.5 or later you can click Reset Audio Engine Data on the VST Plug-ins page of Preferences, then restart Dorico.]

Clearing the audio engine data folder (macOS)

On Mac you can find the folder by opening a Finder window and choosing Go > Go to Folder. Type ~/Library/Preferences and press Go, then find the VSTAudioEngine folder and move it to the trash. Restart Dorico and again it will take a little longer than usual to startup while it scans the folders and rebuilds the library.

[Note: in Dorico 3.5 or later you can click Reset Audio Engine Data on the VST Plug-ins page of Preferences, then restart Dorico.]

Clicks and drop-outs during playback

Now if you’re finding that the audio is playing back but perhaps you’re experiencing clicks or drop-outs, then you might need to tweak the options for HALion Sonic SE. Open the HALion Sonic SE window using the “e” button and press this Options button. You can try moving the balance slider to the right to increase the amount of RAM, used especially if you have plenty of available memory.

You could also try increasing the maximum number of voices, particularly if that number is currently set to something like 128. It is surprisingly easy how quickly the number of voices in use will add up, especially in orchestral textures, and once you consider that many sound libraries use additional voices for release trails. Try setting it to 256 at first and see if that improves matters.

if you have a multi-core processor you can try switching on this control that will make use of the additional power your computer has you might not want to set it use all available cores straightaway. Perhaps try setting it to two and seeing if that makes a difference.

We also strongly recommend using an SSD which will allow Dorico to access the sound library data far more quickly.

Edit > Device Setup (Windows)

Now we’ll turn our attention to the more general audio setup of your computer and any devices you may have connected to it.

Okay, so perhaps you’ve confirmed that HALion Sonic SE and the HALion Symphonic Library are installed but when you press play in your project you don’t hear any sounds. Check to see if the playhead is moving during playback, and if it’s not, open the Edit menu and choose the item at the very bottom, Device Setup. It’s the first option we’re interested in at the moment: the ASIO driver. Now ASIO is a technology that was developed by Steinberg to convey digital audio data between professional audio applications and the audio interface. The audio drivers made for the built-in audio hardware that shipped with your computer are great for many tasks including playing the system sounds and watching your favorite videos online, but software such as Dorico needs a more powerful ASIO-compatible driver.

So when you installed Dorico on Windows a special ASIO driver is also installed: it’s called the Generic Low Latency ASIO Driver, and while it’s not possible to guarantee it will work with 100% of all audio interfaces, it does work with the vast majority, especially with the most common sound chips that are built into computer motherboards these days. If you have no special audio interface and just want to listen to Dorico through the headphone jack of your PC, then you’re most likely going to want to choose the Generic Low Latency ASIO Driver.

However, if you do have a specialized sound card or a USB audio interface that handles the audio coming out of your computer, then you should choose that device instead.

Edit > Device Setup (macOS)

On Mac it essentially works the same way except the default option is called Built-in Audio and again, if you have any other devices attached to your Mac then these will show up here in the list as well.

Now it’s very important to understand that Dorico can only currently send audio to the first stereo pair of outputs on your device, so if you’re plugging your speakers into outputs 3 & 4 or 5 & 6, then you’re not going to hear anything coming out of Dorico. Similarly, if you have a computer that has a headphone jack at the front and the back and you’re not hearing anything through your headphones, try the other jack and see if that makes a difference. In the future we plan to give you more control over the outputs that Dorico’s audio can be routed to.

At the moment, don’t worry about the other controls in this dialogue: we shall come back to those in a moment. So just press Close and now when we play back, hopefully the playhead is moving. But if you still cannot hear any sound, then let’s try some other things.

Device Control Panel (Windows)

We’re going to look at a couple of details specific to Windows, so let’s open the Device Setup dialog again, and you’ll notice this Device Control Panel button.

The Device Control Panel is specific to the ASIO driver you have selected. I have the Steinberg UR22 interface connected, which uses the Yamaha Steinberg USB Driver, and when I open the device control panel you can see that it looks like this. When you’re using a dedicated audio interface such as this one there should hardly be the need for a Dorico user to make any changes here: however, you might need to if you’re using the Generic Low Latency ASIO Driver, especially if you’re having a problem such as no sound being produced.

No playback on YouTube when Dorico is open

The control panel for this device looks like this: the first option allows Dorico to take exclusive access of your sound device, which is good if you don’t want the risk of any other audio sounding while you’re using Dorico but bad if you need to be able to switch applications and listen to video playback and so on. You may have experienced a problem whereby you cannot watch YouTube videos while Dorico is running: sometimes the YouTube video will play but without any audio. In that case, make sure this option is not checked.

Probably the most important part of the dialog is this section in the middle labeled Output Ports and this lists the available devices that the driver can see and use to playback audio. As the name suggests, this is a generic driver and so can be used with my connected UR22, and if I so wish I can select it here, but you’re probably more likely to leave it with the system sound device enabled.

No output ports listed in Generic Low Latency ASIO Device control panel

In order to enable a device you have to click in the box so that it is checked, and only then will its port be selected for audio output. Sometimes if you are having a problem with no sounds coming out of Dorico you might discover this output port section is completely empty. If this is the case then close down Dorico down, then in the taskbar right-click the loudspeaker icon, and choose Playback Devices.

In the Playback tab select the Speakers item and press the Properties button. Ensure Device usage is set to Use this device (enable) and then switch to the Advanced tab. This first control sets the default audio format for the device, but if this doesn’t match with what our good friend the Generic Low Latency Driver is set to, then you’re not going to get any audio out of Dorico. So from the list of supported formats choose the first entry: 16-bit 44.1kHz, and close the dialog. Restart Dorico and hopefully now you will hear audio.

Playback out of tune or out of step with the playhead

If you’re still not, or if you find that everything has been working for a while but suddenly the playhead has stopped moving during playback, or now it’s out of sync with the audio then, open up the Device Setup dialog again and double-check that the Sample rate is set to 44.1kHz. Even if it is, select it again, and wait maybe just a second or two to make sure it has definitely taken the new value.

44.1kHz is probably the most common sample rate and it provides a CD quality audio so we do recommend it’s what you use: the only time you might want to change it is if you have sound libraries that were sampled at a higher sample rate. Otherwise you’re going to notice a higher CPU usage but no better sound, and of course if you do need to set a higher sample rate you will need to change it both here and in the device’s properties like we did a moment ago.

Dorico sets volume to maximum when it starts (macOS)

One final tip back on Mac is that if you find that Dorico always plays back at full volume, then in the Device Setup dialog, click on Device Control Panel and uncheck the option to Set device attenuation to 0dB. This is a persistent setting, so you won’t need to set it every time you run Dorico.

I really hope that I’ve been able to help solve your problem but if not please visit the Dorico forum: I’ll put the address in the video description. You may find someone has already solved the problem you’re experiencing, but if not start a new topic with as much detail as you can provide and we’ll do our best to get you sorted quickly. If you found this video helpful it really would mean the world to me if you would click the thumbs up button below to let me know you’ve liked it and please subscribe to our Dorico Channel right now to see many more videos like this one. I’m Anthony Hughes: thanks for watching.


Thank you thank you – that is very helpful. scanning through text is a lot easier than scanning through a video – and with tools like otter (and others) it can’t be that impossible to render out the text?? much obliged.

I am hearing no sound on playback. I have worked through the video, tried trashing the Dorico 4 AudioEngine folder and relaunching. made sure the halon engine is there, everything seems to be working, I can even see activity in the audio faders. I have checked and rechecked audio device settings, tried switching from audio interface to built in computer audio, no luck. trying Dorico 4 pro, on a Mac mini 11.4. Any help appreciated.

Have you tried reapplying the Playback Template in the Play menu? That sometimes works.

got it working! (even though I had to select the SE engine instead of the PRO HSSE. Not complaining right now, I just need to hear the notes playback. Thanks for the help!

Dorico (850.5 KB)
This issue happens constantly to me on Dorico 4 for Mac. It is my biggest criticism to potential customers for this product. The playback feature is most important to me. I have had this issue since I downloaded, and it does not matter what audio device I have selected in System Preferences or within the Dorico Play settings.

1 Like

Hi @jlippmusic,
welcome to the forum and thanks for the data.
Actually, going through the logs and things, the only thing that strikes me is that you are still on Dorico 4.0 while we are already at Dorico 4.3, but that has no direct influence on your issue of no playback, but I wanted to mention it.
So from what I see, I would expect playback to be working with you but apparently it is not. Then, the next thing to check would be, start Dorico and from the menu go to Edit > Device Setup. In that dialog click on the Conrol Panel button, a new little window opens. In there, are the output ports actually activated, that means is the tickmark set for them?

Hi @Ulf ,

I have the same problem where I don’t get any sound out of the playback feature. however the system recognizes that there is an output detected.
Could you please look at what may be the problem?
Thanks in advance
Dorico (454,2 KB)

Hi @tomdijkstra62 ,
welcome to the forum and thanks for the data, but allow me to ask some things beforehand.
Could you do the following instead?

  • Start from scratch with a project from solo piano template
  • Enter some arbitrary notes
  • Go to the Play Mode, and on the left side choose the VST and MIDI tab
  • In the near vicinity where HALion Sonic is listed there is a little e-button, click that to bring up the HALion Sonic editor window
  • The question then is, in the first slot, is there the Yamaha S90ES piano patch loaded? And when you click with the mouse on the virtual keyboard on the bottom of the HALion window, does some metering start flickering at the top middle of the HALion window? Is some sound coming out?
    And with the project open as it is, could you please create another diagnostics report and send me? Thanks a lot
1 Like

I have a similar problem - getting no sound in playback of an existing Dorico project.

Using Dorico 5 SE - on a Windows 11
I have run through the troubleshooting video.
Issue 1) - I do not see the “Panel” on the right side when in “Play” mode - but I do see a “VST and MIDI” tab in the left hand navigation. I think this is just a change to User Interface between Dorico 4 and 5 - but want to be sure I am not missing something. I presume that updating the troubleshooting video is on the (possibly very long) list of things to do now that Dorico 5 is out - but just in case someone needs a reminder - here it is.
Issue 2) Following Ulf’s suggestions in the last reply in the thread - I have created a project for a single trombone. When I choose the VST and MIDI tab - then click on the “e” button - I do get the HALion Sonic editor window - and it does show "GM 058] Trombone as the selection in slot 1. However, if I click on the virtual keyboard at the bottom of the page - I see the keys move, but do not see any metering flickers, and do not hear anything. I think it is possible that tried to save some time by skipping the download of the library of sounds when installing Dorico - so maybe I just need to get the library - but am not quite certain which thing to choose in the Steinberg Download Assistant - in particular, while I can find some things in the “VST Instruments & Plugins” section of the assistant, none of them are designated as “SE”, and I don’t want to just try things that may require licensing fees.

Is my self-diagnosis possibly correct (and if so, is there anything else I need to know to address)? Is more information needed to figure out what may be wrong (and if so, what do I need to do)? Is the information I have given above clearly indicative of a different sort of problem?

From other suggestions in the comments above:

I do see things that appear to indicate that the ASIO sound driver is correctly installed.

When I call up “Edit - Device Setup” - I see the ASIO driver selected - but the “Stereo Output” option is blank, and when I click within the dropdown selection box, no options show up. When I click on “Device Control Panel”, it does have the “Output ports” correctly pointing to my laptops internal speakers.

Volume on computer is turned up - I can hear YouTube video content without issue. I think I have found (and turned up) Dorico volume controls - so I don’t think I have an issue with a volume control in the app - but might be missing something

I do not find the VSTAudioEngine_64 folder in the AppData/Roaming/Steinberg - but I do see things that might be related deeper down that file tree - this could be another change from version 4 to 5 - but if so, I am not sure which folder and/or file(s) to delete.

Thanks for any suggestions you can provide.

Welcome to the forum @Lornix .

That is exactly the problem why you can’t hear anything. You say that an ASIO driver is selected, but not which one. Do you use the Generic Low Latency ASIO driver? If so then try our new driver which you can download from this thread. Simply run the installer, restart Dorico and it shall turn up in the list of ASIO drivers as Steinberg Built-in ASIO driver.

Thanks very much. You are correct, I had been using the Generic Low Latency driver. Installation of the new driver solved the problem. Interestingly - just installing the new driver appears to have made the old driver work - after hearing the output - I followed the instructions to see the new driver in “Device Setup” - and was surprised to see that it still pointed to the Generic Low Latency driver. The new driver was available as a choice - and I did switch over to it (figuring it probably is more reliable) - but some tweak in your install program appears to have enabled the old driver as well.

1 Like

@Ulf, will this new driver come standard (as an option) with Monday’s Dorico 5.1 upgade?

Yes, and it should be already now, I think, because it does not become part of the Dorico installer but of our common environment, which will get installed/updated by the Steinberg Download Assistant.

1 Like

4 posts were merged into an existing topic: Instruments drop out during playback

hi ! I, too am getting no output from playback .In following the troubleshooting video I got as far as the instrument menu, but didn’t get a default piano track ( or anything else ) at the top of the instrument list .

I’m working with :

Dorico 4.3.31
Mac OS Ventura 13.5.2

any insight would be greatly appreciated . . . thanks !