Playback cursor does not snap to grid when 'Locate when Clicked in Empty Epace' is enabled

The playback cursor does not snap to grid according to its setup when ‘Locate when Clicked in Empty Space is enabled’ and mouse is clicked in an empty space.

How to reproduce:

  1. Click ‘Edit’ → ‘Preferences’ → ‘Transport’ and enable ‘Locate when Clicked in Empty Space’ checkbox
  2. If not enabled, enable grid snapping by clicking on the ‘Snap’ button or pressing the key J
  3. Click left mouse button on any are inside the track view
    → Result: playback cursor moves to the exact place where mouse button was pressed
    → Expected result: playback cursor snaps to the closest grid line according to the grid snap setting

Platform:
Cubase 11.0.20 Build 371
Windows 10 Pro 10.0.18363 Build 18363
64GB RAM

Hi,

It works like this since ever. It works as specified. The Snap is applied when you click to the Ruler area only.

Then it begs the question “why?”

Does having it work differently with regards to snap when done from the ruler or the track area have some benefit, or is being consistently inconsistent just a thing with Cubase?