Playback delay problem


I had Wavelab 7 set up ok, and functioning well. One day I opened WL and found it had lost all my settings and preferences. It also had to re scan all my plugins. I then reset all my preferences and have now saved them.

However, I now find that when I playback a track, there is quite a long delay, 2 or 3 seconds, between striking the keyboard and anything happening on screen? In my previous set up before the crash, the playback was instant.

In Cubase, there is no delay so it seems something specific to WL?

Any ideas why this delay is happening?



Check Options / Audio Streaming Settings…
Audio Device

and select driver for your audio device

the very first time if switching between different Audio Device/drivers
there can be a Initialize process with Audio Device
if you find this is to long before playback try this

Audio Streaming Settings… / Options tab
and untick
“Initialize streaming engine at first use”

hope it helps

regards S-EH

All the time, or the 1st time after you launch WaveLab?


thanks, that did the trick, when WL7 lost all my settings, it reverted the audio driver back to ASIO. What I can’t quite fathom is why it reverted to ASIO when it clearly cannot operate properly on ASIO. There are several other posts here saying that WL7 doesn’t seem to play nicely with ASIO drivers?

thanks very much for your help.


It was all the time, but the suggestion above did the trick. But check out my comment re. ASIO drivers.

I am experiencing a playback delay issue as well. I have always used the keyboard shortcuts as my stop and play transport controls (number pad: 0 & Enter) ever since Wavelab 3. I recently upgraded from version 4 to 7. As recently as version 4 the stop and play keyboard shortcuts worked so instantaneously that they felt like a real-time analog control. So much so that during editing sessions I frequently press the play shortcut (num pad Enter) to audition an editing point, similar to how one would press the play button on a sampling keyboard several times to confirm the edit is starting and stopping cleanly. Not sure if I have explained this well but… now in Wavelab 7 pressing the Play keyboard shortcut several times in succession freezes playback and I am left with silence, a long delay, then eventually playback. I miss my “sampler button”.

I do not have the Initialize Steaming box checked nor do I have Perform Short Fade box checked in the Audio Streaming options. I am currently configured with ASIO drivers on an RME FireFace 800. The rest of the system:

Windows 7 64 bit
Intel i7 950 CPU
6gb RAM
All music files stored on secondary HDD.
Wired keyboard, not wireless.

Thanks in advance for the input.


I think there Is problem with asio drivers. ThAt was causingthe problem for me. As soon as I changed my wavab settings to my own soundcard drivers the delay disappeared


I am also getting ASIO delayed playback problems. Also have experienced phantom changes in my settings for Audio streaming. I’m using XP sp3. When I use the same Focusrite Safire on the OSX side of my computer, I have a much more stable experience with my soundcard. Must be the Core audio.

Wavelab 7 is not supported on Windows XP, only Windows 7:

As far as my original issue, I have narrowed it down to my UAD plugins. I tested several scenarios and got consistent results (the delay) whenever I insert any UAD plug in the Master Section. I’ll follow up with my PC builder to see if there are any settings that can be tweaked or if it’s just because my card is old (UAD-1). Wish me luck.

Here is what the problem is NOT. While this stuff did not help my particular delay scenario, it may be helpful to others:

  2. For driver version 3.031 the FireFace 800 buffer size settings default to blank. I adjusted to 256 from blank.