Playback is not insant with any ASIO setting

Hello!
First of all i have a very fast PC (i7 and Smasung SSD), i’ve searched all the internet and also i can confirm that this is NOT an ASIO issue.
Other software like Ableton, FL, Pro Tools and Studio One (on the same computer) don’t to this.(also with integrated soundcard)
I have a Focusrite Scarlett 2i2 and any buffer length i’d try, the issue is still the same.

I found this issue also in Nuendo:
When i press the Play button, the button lights up for a second and then the playback starts(not instantly).
I am pretty sure this is a setting for prebuffering or something but it can’t find it.

Thanks in advance.

Hi,

1 second is very long. There is a Pre-Record Buffer, in Cubase, but this is recorded continuously.

Even if you say, it’s not an ASIO issue, I would recommend you to check your system via LatencyMon utility.

I’ve had that kind of delay at different times, depends on how much stuff is going on in my song.

Don’t know about a second but half a second.

Is it only when you press play? Then you have low latency on tracking/real time inputs?

I am very sure there is a setting somewhere.

It happens the same with an empty project or with a full project. (even with no project opened)
Video proof:
https://www.youtube.com/watch?v=0w5dHNEgPNs

How can it be a latency problem if all the other software on my pc don’t have this problem?

As I said, there is a Preferences > Record > Audio > Audio Pre-Record Seconds. This is the one, I guess, you refer to. But has nothing to do with your issue (as I said, the signal is recorded permanently in the background). Of course, you can try to change it. :wink:

The pre-record seconds was set to 0. Do you have any other idea ? Or is this how the software works?

Because Cubase is Cubase, an your other software is your other software…

That´s how Cubase works.
First of all, Cubase starts playback on release mouse (Don´t know how the others do it though)
second Cubase has full latency compenstion, so the more plugins with a high Plugin delay in series, the more time it takes to fil the buffers.

Hi,

The default settings is 1 second. And it makes sense. I would recommend you to set 1 sec here.

First of all thanks everybody for the answers. Apparently this thing can’t be fixed(it may be just how the software works)
I set it to 10 seconds and it doesn’t seem to affect anything. I am just going to use another software, because it’s very annoying to wait everytime you need to play short things quickly.

Still, would seem like it’s something to do with your combination of ASIO drivers and your hardware.
Or a VSTaudio setting.


If the problem was the software seems like it would happen to someone besides you.

Of course not, since “Audio pre record” does not have anything to do with your problem.

It happens to soemeone alse: Load 8 multiband compressors into a a channel´s inserts and try yourself

Like I said in an earlier post, it happens to me if I have a lot of stuff (processing) going on.

I guess I use a lot less stuff than you guys.

Workload and performance are correlated.

Like the closer you push the machine towards real time the closer it gets to being overloaded and has trouble doing everything you ask of it.

Just a truism.

Some people track with smaller versions of their song and or change their latency depending on if they’re tracking or mixing. If I have a complex song with heavy processing I could do a mixdown then start a new song and track to that mixdown then bring the results back into the main song. No need to make the machine do all that work when it doesn’t need to.

That might sound like a hassle but in Studio One it really isn’t.

Like mentioned by svennilenni, it’s just how Cubase works.
You can easily test it by running Cubase and DAW x side by side (when your ASIO device supports Multi Client Mixing) and create an empty project with even tempo in both DAW’s, enable click in playback for both DAW’s and start them simultaneously by using an external device.