Playback Issue : Pianoteq and pedal marks

Hi,

I’m using Pianoteq as an integrated VST and I noticed that when I write a pedal change, there is some resonance that stay there, as if it was a half pedal change. I’m wondering if there is a way to fix this.

Best,

Francis

If you are writing a regular sustain pedal change, Dorico will send controller 64 value 127 when the pedal is depressed and controller 64 value 0 when the pedal is lifted. You should check how Pianoteq is configured to see whether or not there is a setting that may affect what happens when the pedal has been lifted.

Pianoteq works fine with Dorico from my experience. The sustain does stop when the pedal marking in the score ends. I would also recommend with default piano settings in Pianoteq to rule out any possible accidental user-reconfiguration. Or check in a DAW if you use one. Which version, incidentally? I’m on 6 but it’s not impossible if you’ve upgraded to 7 that there might be something going on there (though I doubt it).

I moved recently from 6 to 7 but I encountered the same issue in both versions. Yeah, the sustain does stop when the pedal marking in the score ends, but there is a problem when there is a pedal change. Look at this for example :


ok, I think I misunderstood that you’re referring to “retake pedal” as it’s called in the English version. I tried this but am sorry to say that it still sounds as I would expect. Would it be possible send a short audio clip with your two examples and make sure you are using the default Steinway D Prelude preset with no configuration changes? Your MIDI settings seem fine.

That’s strange!

You have the audio clip in my previous post. I believe I’m using the default settings

sorry - going blind – there is of course a clip of the two chords at least. Mine sounds much the same . If you switch off the Dorico reverb in the mixer, it’s a bit cleaner. If you leave a rest after the first chord as in this example

Screenshot 2021-03-13 190742

then there is indeed a slight resonance left which I don’t hear with the default piano or my VSL Steinway. Have you tested with another DAW or notation software? I can’t see a reason why something like this should be Dorico-specific.

You’re right, it does the same thing in Logic after having imported the MIDI file.

https://forum.modartt.com/viewtopic.php?id=6465

I think what we need to do is to decrease Damping Duration in the action panel!

sounds like a good idea. Interesting thread in the Pianoteq forum by the way!

I think the issue is that you’ve told Dorico to retake the pedal very quickly — up and down in 0.125 seconds. The virtual dampers do not have enough time to deaden the virtual strings, and Pianoteq is modeling this accurately. That is to say, when the pedal is retaken so quickly, the notes will continue to ring slightly. Try deleting the Db chord in your example. The C chord will be damped, but then un-damped.

I would increase the retake duration (longueur de reprise) to at least the default, 1/2 of a quarter note at 120 BPM, or perhaps slightly longer, 3/5 or 2/3.

2 Likes

I’ll try that! Thank you :slight_smile: