Playback lag in cubase vs ableton

Hi all,

load an audio file in both daws. Nothing else. In ableton live, hit the space bar. Immediate playback! Like immediate! Now in cubase hit the space bar. Is it just me, or is it not like absolutely immediate like ableton. A slight lag. Oh, and I haven’t updated to 10.5 yet. Still on 8.5. Maybe in 10.5 this isn’t an issue any more?

I’m not trying to compare daws, I’m genuinely interested if it’s just me who’s experiencing this.

Cheers guys.
Luke

You’re correct, Cubase pre buffers it a bit more - Ableton and Studio One are both super immediate. Ableton and Studio also can’t handle nearly the same amount of complexity and track count that Cubase can. Ableton is designed for Live responsiveness and therefore demands a lot more CPU in general.

Could it be an ASIO Guard or interface buffer setting difference?

Asio guard is off. There is literally one audio track. Buffer settings are the same in ableton and in cubase. Live plays immediately. I think even audacity plays immediately, but I’ll have to check later. I understand cubase handles many tracks, complexity etc. But the way I work with audio, I wonder if this aspect of cubase could be improved.

Preferences>MIDI>MIDI Latency Mode
Try to set this to Low.
https://steinberg.help/cubase_pro/v10.5/en/cubase_nuendo/topics/preferences/preferences_midi_r.html

Edit:
This is a feature since version 9.
I know you are talking about Audio. But it affects responsiveness.

Because cubase is still built on cubase sx code but just with added features

Aah, as I’m on 8.5, i can’t try it. Can someone please confirm that with this setting, audio playback is immediate? Or is it true that the current codebase doesn’t allow for improving this at this time? I’ve seen requests for gapless playback. Will playback lag be improved / become non existent if the audio engine is reworked for gapless playback?

Also, I can confirm that Audacity has snappy audio file playback like ableton (no lag upon hitting play / space bar)

Wow, this definitely makes it more immediate. Thanks so much for this info, how had I missed this!

You should download the demo of 10.5 and try this, very immediate playback response! Gapless engine may be a tall order, I’m hoping for it too. If your using mostly audio just create a bunch of audio tracks and then drag and drop audio to those tracks and no gap will happen, Cubase always stops playback for a second when creating new tracks.

So there is supposed to be a playback lag due to pre buffering?

I’m on Cubase 10.5 Pro now on a 2015 Macbook Pro.

I have MIDI Latency Mode set to Low which also made a difference for me, but there’s still a lag vs in Ableton when I trigger playback.

It’s because cubase doesn’t have a gapless playback engine. We have to live with it.

Thank you. I just wanted to make sure it’s supposed to work this way.

Hi, playback on my 2015 MBP was lagging pretty bad as well. I upgraded to big Sur from Mojave to try and fix it. Worked, except my plugins didn’t. I tried Catalina. Catalina and Cubase are a good pair! It’s almost as immediate as Ableton now. I love it. Cubase 11 on Catalina is so smooth and near gapless. Recommended. Do a clean install from a boot disk. Also, don’t add plugins with latency until the mixing stage.