Playback over bluetooth?

Hello! I just made a post on Reddit looking for some help and offering some feedback, but I wanted to copy it over onto the official forum also in the hopes that my experience is useful to the developers or other users. My post is copied below:

Hi all, I’m on macOS Catalina and I’ve been working in Elements 3.5 for a couple months now. Still getting used to things coming from Sibelius, but pretty excited to be getting more fluent with Dorico.

The one thing that is a huge sticking point for me is how much of a pain in the butt it is to get simple playback to work over bluetooth headphones. I use AirPods Pro on my computer almost 100% of the time because I’m always either working on the go, or from my “home office” which is pretty much a corner in the dining room. The portability, easy connectivity to all my devices, and noise canceling on the AirPods makes my life a lot easier. The trouble is that Dorico doesn’t seem to know how to handle playing sound through AirPods at all.

When I go into the Audio Device Setup panel, it lists two options for AirPods (maybe one input and one output? Or one left and one right?), but neither of them have any output options in the dropdown menu––it just doesn’t list any available channels. Sometimes if I’m lucky I can just switch between options at random and it will work, but most of the time it I just can’t get it to play any sound over my headphones. My system output is set to my headphones and no other program has trouble playing back through them.

This seems like such a weird thing for Dorico to not handle elegantly this many years into development. Is this an issue for other people? Does anyone have any reliable workarounds? Am I just totally missing a setting somewhere?

Thanks for any help, hope this issue gets fixed soon!

Edit: I’ve also already checked out their long troubleshooting video on this topic, without any luck. The necessity of that video tells me that I’m probably not the only one with these frustrations. I’m delighted that Dorico has all kinds of audio playback options for people who have more complex setups and spend a lot of time using Play mode to create high quality audio files, but there really needs to be an easier way for people who just want a midi piano to play back the score for quick proofing. That’s all I ever need, and it’s something that Sibelius does instantly, without any setup, when you hit the spacebar in any new file. A simpler option for folks who don’t need the advanced playback options would be stellar, and would be all I need to be totally sold on this software going forward.

Edit 2: My current best workaround is silly and impractical: I can set output device to Soundflower and record the playback in Quicktime, then playback the Quicktime recording through my system output. Ridiculous, but the best I can come up with right now.

Hi, what is Reddit and why do you post there first and not in this forum? Here you would have gotten help immediately.

It’s true, BlueTooth headsets usually turn up as two devices, one as input for the microphone and the second as output for the earphone. So make sure that you always choose the second entry in the list and then it shall work. Maybe the output ports are not automatically updated, close the Device Setup dialog and open again, still nothing shown?

If you still can’t get it going, I can offer a remote screen sharing session and help you setting it up. Send me a private mail and we’ll sort the details.