Playback Processing

I’m struggling to get playback processing to work. I’ve added Frequency EQ so I can do speaker correction. It looks fine and I only have my main speakers connected but the effect is not happening on my speakers. If I look at the effect I can see it sees the input. What could I possibly be doing wrong. Wavelab 10.0.70. I set this up easily in control room in Cubase. Even If I use the Before Playback processing and select a different output and enable it the eq is still not applied on the outputs I choose.


ISnt your mastersection disabled? I see it in red

I don’t think Playback Processing works the same in WaveLab as it does in Cubase, but it’s a common request.

Unless there is a trick I don’t know about, the Playback Processing slots in the Master Section are only for the Main Playback Bus. You don’t need to add them as a separate output in the Audio Connections area.

And as Pedro mentioned, the Master Section looks bypassed.

The master section is bypassed but that wasnt the point. It’s only disabled because I had just rendered. I should have taken the shot before I rendered. That makes no difference to what I’m asking.

I thought the playback processing was independent of the master section so you could in theory put room/speaker correction on the playback processing without it impacting what you render but only what you hear. As far as I see it does nothing. Shame as it looked a good place to put it.

I would put room correction on my rme eq but it’s only 3 band.

Thanks for the answers but does anyone know any different. Please ignore the master section as that is not what I am referring to.

The Playback Processing slots are somewhere you can put room/speaker/headphone correction but it requires no extra steps in the Audio Connections area.

In the scenario you see here, I am hearing the effects of the FabFilter EQ on the main stereo output of WaveLab, but the FabFilter EQ is not part of the audio rendering path, and doesn’t influence the internal metering of WaveLab.

If you’re trying to EQ/correct different outputs with different EQ/correction, that is what I don’t think is possible right now in WaveLab, but seems to be an option in Cubase.

For example, I don’t think you can EQ/correct output 1-2 differently than output 3-4, or 5-6.

I’ve seen a number of requests for an EQ slot for each of the Speaker Configuration options but right now, the Playback Processing slots happen before and separately from any of that.

Ok so that is what I tried first but it didn’t work. I had a single output configured and on the eq I could see an input to it but it did not translate to the output I was hearing. I did radical eq so it would be obvious but nothing. I’ll have another go when I get home as it’s obviously working for you (what version of Wavelab are you on?) My original attempt and from how I read the manual suggest it should work how yours looks.

Strange :thinking:

Hmm so the pre-set I was using didn’t work even though it looked like it should. Everything was enabled and I went through each band making sure it was turned on and it was but when I actually touched the dot for each frequency on the graph part they suddenly started to work. So I touched them all and saved and now it works. I just can’t see why the pre-set I was using in Cubase did this but something was stuck with it.

Anyway thanks Justin for proving it does work as I thought which prompted me to have another go. I was sure I tried radical changes last time and nothing happened. Could be me I suppose lol.

Hmm, it’s hard to say what was going wrong but I’m glad you got it.

At first I thought you might be talking about what appears to be possible in Cubase, but I’m not a Cubase user so I can’t say for sure…but I thought you were trying to apply a dedicated EQ/correction to each of the Speaker Configuration outputs.

AFAIK in WaveLab, you can only apply one EQ/correction in the Playback Processing slots, and that feeds all the Speaker Configuration outputs.

Thanks. I brought in my headphone presets and had the same problem until I touched the dots in the eq. All enabled yet not working. Saved and now fine. I’ve saved two presets. One for headphones and one for speakers. The speaker one disables the headphone eq and vice versa. Seems to be all working correctly now. Seems Wavelab didn’t like the presets I made and brought in from Cubase.

1 Like

Even though Cubase and Wavelab are both Steinberg products they are separate products meant for different applications and even though one would think they should work together nicely they don’t. FWIW

Yeah but you would have thought a preset in exactly the same plugin in Cubase would be the same in Wavelab! I used frequency eq which is the same on both. Ah well we live and learn.