Playback Template mismatch

Hi,

I solved the issue in this way:

  1. Manually edited the .xml file in the Library’s Endpoints folder. There was a mix of the old and new names in the file. Probably due to the fact that I had saved the old Endpoint Configuration with a new name.

  2. Applied the Silence playback template.

  3. Applied my custom playback template again. The names, when the instruments appeared again, were now right.

Paolo

More than one year after, I’m trying to solve the same issue: I can’t apply an endpoint configuration to existing or new projects. Old, outdated setting save who knows where are still recalled.

Manually editing a suspect endpoint configuration didn’t work. For example, I had a series of techniques named something like:

<techniqueIDs>pt.user.detune_m2</techniqueIDs>

in a “playbacktemplatedeps.doricolib” file. I was sure this was the code corresponding to my “detune min2” technique, and I changed it to:

<techniqueIDs>pt.user.detune_min2</techniqueIDs>

to be sure it exactly matched the assigned name in the UI.

Alas, when saving the endpoint configuration back from the correctly working template project, the older code was again in the configuration file.

I really don’t know where to look. All my knowledge of Dorico seems to end at this point. I can’t go deeper. Unfortunately, this is also a show stopper, since I can’t really create all the techniques again at each new project or when re-editing an existing project.

Paolo

A guess to myself: the new techniques are in the Orchestral Strings endpoint configuration. They are not in the other endpoint configurations. I did resave all the end-conf after creating the new techniques, but they were only save in the first one (first VSTi, first staves in the template project, first in the playback template).

When applying the playback template, the first end-conf is the woodwinds one. But I also tried moving the Orchestral Strings end-conf on top, and the result was the same: no new techniques applied.

A dangerous solution could be to copy all the new techniques definition in the end-conf files of the other instrument groups. None will then prevail. But I might as well end up with a total mess.

Paolo

For one problem recently with VSL, I found that just resaving the Endpoint configuration under the same name made the PB config. OK again. Like some others, I do find there seem to be inconsistencies in this area though it could be I’m doing something wrong. Actually, I often just prefer to delete the contents of the score and resave under the name of the new project which is using the same configuration.

Thank for your hint!

I’ve done it repeatedly, and with varying types of apotropaic rituals proffered aloud. Unfortunately, the result didn’t change. And then,

I often just prefer to delete the contents of the score and resave under the name of the new project which is using the same configuration.

What if you want to update your template, or apply a different template (for example, to adapt the piece to a different sound library)?

Paolo

This didn’t work. Again, the old, at this point ‘ghost’ endpoint configuration is recalled, even when creating a new, empty project.

It’s not a default one – it’s my old configuration. That I have now overwritten, and all the rewritten endpoint configurations have been assigned to the playback template, after having deleted all of them from it.

EDIT: Another note: I applied the Silence playback template to a new project, and got the default techniques. Applied my playback template, and got the ‘ghost’ techniques of my old configuration. Applied Silence again, and the old ‘ghost’ techniques were still there…

The same happens with a new, empty playback template I created for testing: it didn’t delete the ‘ghost’, sticky techniques.

EDIT2: I tried with a new, empty testing template, applied to a new, empty project. I added one of the custom endpoint configurations. The ‘ghost’ techniques are there, despite the copied techniques definition file copied from the only working one.

Where are they stored? Where are they hiding?

Paolo

These are the error messages I received when I opened one of my template projects:

|error|14:32:53.531767 +0100|kernel|Sandbox: fseventsd(61) System Policy: deny(1) file-read-metadata /private/var/folders/jn/91m__3851rb__dp8grm464mr0000gn/0/com.apple.LaunchServices.dv|
|---|---|---|---|
|error|14:32:58.570476 +0100|Dorico 3.5|        AEGetDescData of non-desc type 'reco' not a good idea|
|fault|14:33:12.482037 +0100|apsd|Failed entitlement check 'com.apple.private.secure-apsclient' for <private>|
|fault|14:33:12.483000 +0100|apsd|Failed entitlement check 'com.apple.private.aps-connection-initiate' for <private>|
|fault|14:33:12.487033 +0100|mdmclient|Connection Invalid for service com.apple.apsd|
|fault|14:33:12.488011 +0100|apsd|Failed entitlement check 'com.apple.private.secure-apsclient' for <private>|
|fault|14:33:12.489011 +0100|apsd|Failed entitlement check 'com.apple.private.aps-connection-initiate' for <private>|
|fault|14:33:12.492204 +0100|mdmclient|Connection Invalid for service com.apple.apsd|
|error|14:33:12.530805 +0100|kernel|Sandbox: fseventsd(61) System Policy: deny(1) file-read-metadata /private/var/db/ConfigurationProfiles/Store|
|fault|14:33:12.838846 +0100|apsd|Failed entitlement check 'com.apple.private.secure-apsclient' for <private>|
|fault|14:33:12.839790 +0100|apsd|Failed entitlement check 'com.apple.private.aps-connection-initiate' for <private>|
|fault|14:33:12.843628 +0100|mdmclient|Connection Invalid for service com.apple.apsd|
|fault|14:33:12.844958 +0100|apsd|Failed entitlement check 'com.apple.private.secure-apsclient' for <private>|
|fault|14:33:12.845914 +0100|apsd|Failed entitlement check 'com.apple.private.aps-connection-initiate' for <private>|
|fault|14:33:12.848944 +0100|mdmclient|Connection Invalid for service com.apple.apsd|
|error|14:33:46.751908 +0100|mdworker|Invalid display 0x00000000|
|error|14:33:46.801460 +0100|mdworker|0 is not a valid connection ID.|

Has this anything to do with Dorico and my issue?

Paolo

So far, I haven’t spent that much time on templates for the simple reason I don’t yet entirely trust them. If I want to use a different sound library then I create a completely new version of the piece — they are so different that there’s no other way. NotePerformer is perhaps the exception. I’m afraid I can’t as yet be more helpful

After more accurate analysis, I can see that even the endpoint configuration saved from the more accurate template project is not right. Some of the data is saved, some is not.

I can’t find a pattern in this. For example, add-on techniques appear as “techniqueAddOns” items, and not as “CompositeDefinition” and “PlayingTechniqueDefinition”.

Some of the techniques appear with a name saved in a previous version, not matching the new name appearing in the Playing Techniques panel. Some are totally missing.

The code of the endpoint configuration file is only partially human-readable, so I’ve no idea of what is right and what is not, and why. So, even the idea of saving a blank endpoint configuration, and then manually adding techniques, would not be feasible.

Paolo

Here is an example of how I can’t load my custom techniques in a new or existing project.

I created a new project, and applied my playback template. By examining an associated configuration file (“playbacktemplatedeps.doricolib”) for the Orchestral Strings, I should have, for example, the “release slow” and “release slower” add-on techniques.

However, when I add a new player of Section Violins, the list of techniques remains a different one, read I don’t know from where (somewhere from my past). The “release” techniques are not there, while being in the configuration file.

Yet, these techniques are in the original template project, and in the expression map:

Where are they lost, after saving?

Paolo

I’ve not had time to look in detail at this, as you know, Paolo, but I expect the playing techniques you no longer expect to see are coming from the userlibrary.xml file in your application data folder, because you have at some point clicked the star/Save as Default button in the Playing Techniques dialog. Try moving that file out of the way, then restarting Dorico, and when you create a new project you should find that none of those playing techniques are present: only those included in the playback template will be added.

Daniel, thank you for being here even in the evening of Christmas! Now I feel guilty for having broken your holidays!

Anyway, thank you very much for this hint! Removing the userlibrary.xml from the ~/Library/Application Support/Steinberg/Dorico 3.5 folder didn’t immediately solve my issue. But I could see there was some ‘dirt’ inside, and this may be the right track to follow.

Have a nice evening!

Paolo

There should be some other deep repository for those outdated technique definitions.

I deleted the userlibrary.xml file. I then opened the template project “Orchestral Strings”. I re-edited some of the techniques that were problematic in the endpoint configuration file.

For example, a “legato slurred” technique insisted to appear in the endpoint configuration file as “pt.legato_fingered”. I edited the name of this technique, in the hope it would have been saved with the new, edited name.

Alas, no. After I resaved the endpoint configuration from the VSTi panel, the “pt.legato_fingered” definition was again in the just saved endpoint configuration file.

This name didn’t appear anywhere in my template project. No visible place, at least.

Paolo

Ok, I’ve found this ‘ghost’ data. It’s in the template project. It’s not something that can be seen in any of the editing windows or in the panels. You can see it by opening the .dorico file with a text editor, and check the “score.dtn” and “scorelibrary.dtn” files.

How can I ‘clean’ these hidden data from the template project? I could even try to do it manually, but I’m sure it will be a disaster. Some command or operation allowing to rebuild the file removing ‘dirt’ would be great.

In InDesign one could export in IDML, and then reimport to clean the file. Unfortunately, the MusicXML doesn’t contain everything a .dorico file can contain. Another solution they use is to do a Save As to clean the file from unnecessary data, while also reducing its size.

Paolo

I’ve deleted and created again some of the playing techniques that were coded in the wrong way in the configuration files.

No way. The same wrong strings are still there after saving the endpoint configuration. When applying the playback technique to a new project, both the new and the old techniques are shown in the panels.

Unless some command/script automatically cleans the code inside the project, there is no apparent way to fix it.

Paolo

You cannot in general edit the score.dtn or scorelibrary.dtn files inside the Dorico project. They are written in a binary file that only Dorico can read.

If you can enumerate the playing techniques that you want to get rid of, i.e. provide me with a complete list, and then provide me with the project that contains the unwanted techniques, I could remove them for you.

Thank you very much, Daniel! I’ll make a list of the ‘dirty’ techniques found hiding in the files, and explain if they should not be there, or have a different name.

Any chance there is a tool to do this kind of maintenance that you can soon release to a public beta?

Paolo

Hi, I didn’t read all th post but may be is the same problem ?

I don’t know for sure, but it sounds like a related issue. I’m not having it with techniques saved as defaults, but with techniques in an external endpoint configuration. But the behaviour looks like the same: techniques created in a project, saved as defaults or endpoint configurations, and not found either as defaults or part of the endpoint configuration.

As far as I can see, it’s probably some issue with saving from the original project, and then Dorico being confused by the missing or ill-formed data it is expected to load.

Paolo

No, absolutely zero chance.