played MIDI-notes are recorded double

Hi all,

When I play and record a midi-part, all the notes are recorded double (without a shift in time).
I then always have to delete the double notes by hand or by the menu: MIDI>Functions>Delete Doubles, but that’s becoming a bit annoying :frowning:

Anyone any ideas on how to prevent this?

Thanks in advance!

Mario

===============
Cubase 10
Windows 7, 64bit

Hi,

Double-check Studio > Studio Setup > MIDI > MIDI Ports. Yellow are inputs.I expect, you will see your hardware device twice in the matrix. Disable visibility of the doubled-entries so, it’s present only once.

Hi Martin,

Thanks for your reply!

I checked my Cubase 10 studio settings: Studio > Studio Setup > MIDI > MIDI Ports: No doubles there.
The ESI M8U is an 8-ports midi-interface.
The Q49 is a midi-keyboard.
The only other apparatus that’s connected to the ESI M8U is a digital piano KAWAI ES7.

Not through the ESI M8U, another device is connected to my PC (Win7): the usb midi controller Icon QConProX.
And a connected but not-in-use Faderport midi-fader.

That’s all the MIDI gear in my studio.

Anything wrong there you guess?

Hi, have you checked what the KAWAI ES7 sends? You could do that with the midi-monitor insert - maybe the source is already “double” for some weird reason.
Another idea could be a midi loop (even though it is strange that this leads to “doubles” only) - is “local control” off on your keyboard?

Cheers, Ernst

Hi,

How is the KAWAI ES7 connected to the computer? Via USB? I can’t see it in the list. Or via MIDI over the ESI? Isn’t there problem in the ESI? Can ESI do some routing?

I had exactly the same issue, but slightly different circumstances . . .

For one I’m using Nuendo 10 (cross graded from Cubase).
For another your solution, Martin, worked for me. Turns out I had DirectMusic AND Windows MIDI input ports active from my RME. Turned off Windows MIDI (cause DirectMusic sounded cooler). Problem solved.


Thing is, I don’t ever remember having this issue in Cubase - or turning anything off. Strange.

But a bigger issue for me is that the “Delete Doubles” function doesn’t work. Tried selecting the Part. Invoking the Menu item. Nothing. Doubles still there.
Tried opening the Key Editor and selecting all the note. Still nothing.

What might I be doing wrong?

Another question: Is there a general preference for DirectMusic or Windows MIDI? One better than the other usually? Or is it just a Crap Shoot?

Thanks!

Hi,

Yes, this is what I was thinking about, when I wrote, if the MIDI Port is not two times in the list. I just didn’t know the exact terminology, because I’m not on Windows.

Btw, this can happen in Cubase too. It depends on the way, how MIDI Drivers are installed in Windows.

Hi Martin.Jirsak, Elien, HughH,

A big thanks for all your replies!

I’ll go into various of your questions and remarks:

My piano Kaway ES7 does not show up in te studio/midi-settings. I don’t know why that is. I can record from it though.
My Icon QConProX doesn’t show up in that settings-list either.
Meanwhile my MIDI-keyboard Alesis Q49, DOES show up in the list.

No hardware device mentioned twice in the matrix (see previous uploaded screenshot).

I don’t understand the thing about DirectMusic AND Windows MIDI input port, I’m too much of a noob to everything midi-related, as you noticed.

To make things more difficult: the double notes do not ALWAYS appear! I don’t know why that is. I only notice (always afterwards :frowning: that notes are doubled.

The doubles could be caused by a midi loop, I guess.

The double notes I experience always differ a few milliseconds.

“Local control” is turned off on my Kawai piano.

The ESI midi interface cannot do any routing. Basically it’s no more than a switch with 8 connections. It connects through usb to my computer.

As you might have noticed, I’m NOT enough familiar with all the midi related items / problems. I think things might be easier if the issue could be addressed by phone. So Is any of you living in the Netherlands and willing to be contacted by me on phone? (in English or Dutch). If so, please send me a PM.

Thanks to you all.

The problem with doubble notes is also written here:
https://www.steinberg.net/forums/viewtopic.php?p=51484