Playhead snap to grid = BAD

How do I tell the playhead to ignore the snap to grid function while jumping around in the project? This drives me NUTS!

Turn off snap, or activate “Locate When Clicked in Empty Space”

Turn off snap is what I want to avoid doing in order not having to jumping back and forth to that shortcut while working.

I’ve tried “Locate When Clicked in Empty Space” but it is an even bigger hit to the workflow as I always click in empty spaces to cancel selections etc.

Wouldn’t it be easy to have an option to turn snap off just for the playhead? :slight_smile:

Yes. Start a feature request thread, I’m sure this would get +1s.

what is playhead?

I set up a keyboard shortcut to toggle snap on or off. (Shift-S)