Please help! Import midi drums into project recorded at different tempo

OK so were just about finished with our first single and our drummer wanted to punch drums_ On a near finished mix-(guess he didn’t like what he played )
we encountered some issues with the cpu trying to playback the finished mix so I exported the song without drums into another project.

Unfortunately on the temporary project we did not set up the tempo correctly because we went for the live feel vs doing it to a click

the original song .cpr file is 166bpm 6/4

the drums( midi file) we created ( were using an electronic kit) on the new project were @ 90bpm 4/4

AND of course because I don’t have cubase pro THE MOST EXPENSIVE VERSION
I can’t find any information that pertains to me. I don’t have the icon for musical mode/linear mode whatever it’s called.

there HAS to be a way around this.

I dont care how it needs to be done , whether or not I import the audio from the massive song into the new project ( would that be destructive in any way?)
and sync it up that way, or somehow change the tempo on one of the songs in a way that doesn’t affect the midi.

this is a nightmare I can’t believe we overlooked this after a 6 hr recording session

idk if it matters but the drums are the only midi in the song the rest is all audio tracks.

if anyone has an idea that works I will love you forever.

Otherwise I’ve got to mix the entire songs with a drum take I’m not gonna keep until its perfect and ready to master, which would be a nightmare. but possible I suppose.
Id just hate to lose control over the mix , yikes.


First of all, I’m afraid your 4/4 drums will not fit to the 6/4 signature.

But if you import a MIDI to already existing Cubase project, the tempo of the MIDI file is ignored (by default, you can change this settings) and the MIDI file is using the Cubase project tempo. Make sure the MIDI Track is in the Musical Time Base, please.

Double check the settings while import, or in the Preferences > MIDI > MIDI File > Import Options, please. The Ignore Master Track Events on Merge option has to be enabled, if you want to use the project’s tempo when importing a MIDI file.

Hey Martin, super thankful for the response.
I’m not trying to fit the midi into any time signature or sync it to a click.
I just need it unchanged somehow When I transfer it.
I did check that box you were saying.
Also I don’t think I have musical mode because it’s cubase a.i. Correct??

As of now I WAS able to import it.
The particular song has a lot of pauses so it’s pretty easy to line up the kicks by time stretching it.-
And I’m darn close, just wish there was another way because right now my best effort is visually syncing it and then listening to see if anything is off.

Is cubase pro the only version able to do this easily?


It’s not Musical Mode, it’s Musical Time Base on the track. Either the orange Note (this is Musical Time Base) or grey clock (Linear Time Base).