Please help me figure out Quantize in Cubase

I know that I’m probably doing something wrong, I’ll just start with that because other than the awful GUI redesign in 13, if something doesn’t work out for me in Cubase, I assume it’s me and not the program.

When using Logic Pro X, quantize was something that always worked as I expected. Even for someone with only the most basic knowledge of music theory, when I quantized something in Logic, it would align perfectly to the bars and the lines in between. But in Cubase I cannot get the same result, no matter how many tutorials I watch.

For example, I’m trying to do a MIDI mockup of “Dream is Collapsing” from Inception. Those of you familiar with it know it has a few ostinatos, mostly on the same note. In fact, for beginners it’s a great song to try because it’s not super complicated. That doesn’t mean that I will get anything remotely similar to the original, but man when I play both together it’s pure gold! :smiley:

So I did the same thing as I do with all mockups, start a new project, bring in the audio original, detect tempo, smooth tempo because usually it’s crazy, set definition from tempo, then start adding instruments.

So when I get to the ostinatos, I play them on my MIDI piano, then listen to them and my timing naturally sucks, so I try to quantize it. It’s been so long I don’t even remember how I did it in Logic, but I remember something like this was easy, just a couple of things and it would play like a Swiss clock. Even being a total beginner in LPX, I was able to do this with my hands tied.

But in Cubase I get this:

Looks fine, right? But let’s take a closer look:

While to the casual viewer it may seem fine, I’m sure all of you are fine musicians and see that this is not perfect in any way. This is what that sounds like:

I think I had used 1/32 for this, but I tried all the presets, included the weird ones that have the trippled and the dotted, but nothing. Some of them really make it far worse, obviously.

So what’s the problem here? I just want to achieve one thing: that the distance between each of these notes is exactly the same. I already made them the same length. But no matter which one of these presets I try, it still plays like someones pushing the 60 violin players at the same time to make them lose tempo.

Is it because I’m using the variable tempo detected by Cubase, so some bars have a tempo and others have other tempo?

Sorry, I’m sure this sound like the most basic stuff to all of you, but I’d be so grateful if someone could explain the basics of this to me so that I know what I’m doing wrong, because I know it can’t be Cubase.

Do you use the Quantize panel?

There’s a setting, called Soft Quantize. If this is enabled, Cubase will try to “approach” the quantize setting (e.g. 1/8th note) little by little. This is for performances that we want to preserve the human element, but we also want to tighten them up a bit. So, with this setting, we must use the button many many times if the playing is somewhat sloppy and we want to make it very tight.

On the other hand, if we deactivate this setting, quantize will put the MIDI events hard on the grid, to the closest position.

I don’t understand what musical values your screenshots are, but if they are quarter notes and you want them smack on the 1, 2, 3, 4, you just deactivate “Soft Quantize”, set the grid to 1/4, hit Q, and that’s it. If it’s eighth notes you want, set 1/8 to the grid, etc etc.

Edit: Oh, you could also use the Auto Quantize button (right click on the transport bar and see if it shows up). If you use this while recording, all incoming notes that you play on your MIDI keyboard will be automatically quantized according to your quantize setting.

It would be helpful to get a screenshot of your quantize settings

1 Like

Well, this is what happens with soft quantize. This is the beginning of that ostinato I showed you before quantizing it:

Now, I applied a regular quantize (you will see the soft q button was enabled in the screenshot above, but I disabled it before doing the Q)

What it did there doesn’t make any sense to me. It put two notes together, so much that you can barely see it. If you were to see the rest of the part, you would see this a few times.

Now, I undo this, press the soft quantize button, and do Q again:

Same thing happens. Another double note, the same one actually, so it’s not so soft after all.

What I don’t get is why doesn’t it make the distance between them equal, or at least that it really aligns each note to each (this is where my lack of knowledge makes me wonder what it’s called) half bar? I don’t even understand how can this be considered 1/8 when looking at the grid it’s obvious that it should be 1/4, but I’m probably wrong because [quote here please :)]

But then thing is, most of the notes are quantized correctly. The problem is, when I press play, that doesn’t sound right to my ears at all. I may not know music theory, but I’ve been listening to it for 50 years, and all kinds of music from classical to heavy metal, and I have a good ear for tempo and all that. So I know this doesn’t sound like it does when I hear it in the original song.

Which I have a theory, and that is that the reason it doesn’t sound right is because of the variable tempo that I got from the tempo detection. But if I’m trying to do a mockup, what other choice do I have? Sometimes I go online and lookup the tempo for the song, but one website tells you one tempo, another tells you another tempo, and I’ve seen like 5 different tempos for the same song, so that’s not reliable.

I tried using the tap tempo function in Cubase Pro 13, but even if I’m clicking the button in a steady tempo, the number I see on screen is a lot different each time I click, and that might because of the mouse being wireless.

Does this all make sense?

Ok, Sebastian, I listened to the track because the title didn’t remind me of anything.

I see you are using a 4/4 signature (judging from the snap lines). Could you also tell me what BPM the tempo is?

From what I listened, the original track could be written as 3/4, BPM ~ 140. I don’t know if Hans Zimmer did it that way, or 6/4, or 6/8, that’s besides the point. But it’s 3.

It’s not a problem if the numbers fluctuate a bit (even 10 BPM) up or down from one measure to the other. See if there are some changes that “topple the rhythm over” instead. If there’s a bar after which what was supposed to be on the beat comes off-beat, then the tempo track needs correcting. There should be a BIG change in numbers if this was to happen.

This looks “equidistant” enough. If you had set up the signature and tempo correctly, (and if your playing was on time - I trust you that it was) you would then have a better picture. You should have each of the notes falling on the |1 -2 -3 | 1- 2- 3 | 1 -2-3 | of each bar. If they didn’t, you could first slip the part left or right, and once it was close enough, THEN use quantize.

Did you first record the part and then went ahead with the tempo detection? Which part are you playing? The violins?

Edit: By the way, some sounds, especially strings have some delay built in, their attack is very slow. So after all is said and done, maybe you need to slip the whole quantized, nailed to the beat performance behind the beat just a little, so that it actually sounds on the beat, taking the slow attack into account.

Thanks for the advice. Actually no, my playing wasn’t remotely good, I don’t know how to play the piano at all, more than a note here and there. I started learning music but got too caught up on the MIDI part of it because it fascinates me how many high quality instruments you can have at your disposal these days.

That’s why I don’t even know what the signature is yet, 4/4, 3/4, it’s all the same to me. I don’t plan on staying this ignorant forever, I already bought some music theory books, but I wish I had the time for them.

Also, to listen to this specific track, you would need to do what I did, which is put track 1, then track 3 right behind it with a very small crossfade, then render it out to another file, and that’s what I used for tempo detection.

But I found a good way to do this. I cut the track right at the beginning of the big Zimmer bramms towards the end (the ones that would be in track 3 of the album), and I used that to get the right tempo.

And I had forgotten something useful I learned in a video about this. I did the tempo detection, then did the signature thing, but then I disabled the tempo track, and I manually set the tempo to like an average of the variable tempo, like this:

The chaotic line is the tempo detection, the straight line is the constant tempo. And at first I set it to 127, which is what the internet says the 3rd track is supposed to be, but the bramms were not aligned. No matter where I moved them, they didn’t align perfectly.

So just for kicks, I started lowering and raising it with my mouse wheel, and I realized that they aligned perfectly at 126:

The quantizing started working much better after that. But I still get the impression that Logic is better at tempo detection and quantizing. But well, Logic has many headaches that I’d rather not go back to, and I love Cubase, so it is what it is.

Doesn’t seem too off.

Once you’ve done your tempo detection, and you’re left with all 1/4 measures, that’s a critical point. It’s then that you have to see exactly where the first downbeat of the music falls, and to make sure that everything aligns well to the grid, right at that point. If it does, you just go to that 1/4 bar where the music starts, mark it, remember it, delete all subsequent ones, and change that first one to what it should be. (3/4, 4/4 5/4, whatever)

If you are just using the plain quantize, this is to be expected. Because Quantize quantizes to the grid. If the grid is not in agreement with the actual music, anything quantized to it will be wrong.

You could also explore the “Groove Quantize” method, where you quantize your music to agree with another selection, but I’m not sure if it would fit a whole piece of musicas the groove, it’s supposed to be made for smaller chunks. Actually, I’ve never tried it for big selections.