plugin delay compensation not working for me

I intentionally loaded a lot of insert plugins to create channel latency, and when I “render in place” it renders it without compensating at all.
you can see the steps in this video:
https://drive.google.com/file/d/18R2TqpnfRGR-zndyu8keSgJpIVTAEowq/view?usp=sharing
let alone when i load a heavy plugin, the delay between the channels are too big to be able to mix…
what’s the solution?

thanks

1 Like

pls help |:

theoretically speaking, you shouldn’t need that many of the same plugins to test latency - ie, it’s not an accumulative protocol, Cubase just uses the latency of whichever single plugin has the longest latency and thus, all any plugin with the same or less latency is within that latency processing time frame no additional latency is needed.

I tried duplicating this problem with a high latency plugin, but my render in place came back in sync sample accurate.

Have you tried a different high latency plugin?

Hi,

What Buffer Size (latency) is set on your Audio Device, please?

should it matter? Just curious

Hi,

I have to say I’m not really string in this area, but… As far as I know it could. If you render the very same signal multiple times, it might be a bit shifted (depending, where the buffer was, when you jumped in, so actually how long did you have to wait to reach a new block). If the Buffer Size is higher, the blocks are bigger and you would get a bigger jitter, so the distance between the most-left and the most-right shift would be bigger than if you have a small Buffer Size.

But I will be happy to be corrected by someone, who does really understand this. I might be totally wrong.

I would have figured everything processed ITB would always be in sync no matter what or how high the buffer.

You can’t really make a comparative test w/o having the exact same plugin chain - reason being if a plugin misreports it’s latency, or it does some sort of audio domain delay processing…

Have the OP retry the test using a different plugin - say, one of the Steinberg ones that all have, excepting the delay plugins. That test should prove whether it’s Cubase or the OP original plugin…

yes me thinks it’s a plugin problem with those particular plugins. try a different plugin as suggested above.

I’m new to this, and have a similar latency issue on a vocal track, but mine is unintentional and has only begun to happen, despite no settings being changed. I can add a dry vocal, but when I add reverb insert it creates latency.

Is anyone able to help please?

Many thanks.

Hi,

This is how all DAWs work. Most of the plug-ins bring some delay.

If you want to hear a Reverb while recording (because it’s more comfortable for you), but you don’t want to get a delay, use the Audio Device FX (if you have one with DSP).

Hi there,

I am having the same issue, on Cubase 10.5, when I add plugins (famous and known ones that I use on Cubase 5 without issues), like Waves, Antares etc…I get massive latency, I can see the delay that has been added by the plugin in Milliseconds in the mixer which is informative, then Cubase does not compensate for it! there must be a way to fix this? normally Cubase should calculate all these delays added by plugins in Ms and compensate for it automatically so that I can mix properly…

This is so inconvenient and I am not sure how to solve this problem! any help would be much appreciated. thanks much

1 Like

Antares is going to add a fair amount of delay. Where how are you hearing the latency? I think you must be monitoring wrong somehow.

Hi there, I have been making music since 2003 and used tons of DAWs and gears, always been on Cubase 5 which I am using now by necessity. CUBASE 10.5 is having some sort of bug or issue that so many people are reporting this. The program should auto compensate, and it doesn’t happen, I open the same project in Cubase 5 and no problem.

The tracks are not synced when there is a plugin on, it shows for instance 60ms delay added, yet it does not compensate for it.

I wish there is a fix.

1 Like

Bah, and still no real answer to this at all, like how we can fix this.
I have the same problem in Cubase Pro 10.5 specifically with Oeksound Spiff plugin: it adds hell of a lot of latency and Cubase does not care: that specific track where that plugin is inserted is delayed a lot, as soon as I disable that Oeksound pugin, all works as expected - WHY IN THE WORLD?
For example, when I test that plugin in FL Studio 20 it works absolutely fluessly as expected!

Hey there, i got the same problem. The bult-in plugin delay compensation doesnt work for most of my plugins. All Fabfilter, UAD, some Waves and even some Cubase Stock plugins. get my tracks out of sync. Im using Cubase 10.5 on a Windows 10 with an Apollo Twin USB.